aboutsummaryrefslogtreecommitdiff
path: root/dns/dns_mre
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-07 21:28:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-07 21:28:14 +0000
commitd3bddc5648f9b6e07aad1a9659efcd320b5228a2 (patch)
tree1429c5916cf00cbd1f72d2a4055e14ae09b69a09 /dns/dns_mre
parenta77a5fd167fb6548555be20df61d76bb38ef5583 (diff)
downloadports-d3bddc5648f9b6e07aad1a9659efcd320b5228a2.tar.gz
ports-d3bddc5648f9b6e07aad1a9659efcd320b5228a2.zip
Notes
Diffstat (limited to 'dns/dns_mre')
-rw-r--r--dns/dns_mre/Makefile27
-rw-r--r--dns/dns_mre/distinfo3
-rw-r--r--dns/dns_mre/files/patch-dns_mre.c27
-rw-r--r--dns/dns_mre/files/patch-dns_mre.h10
-rw-r--r--dns/dns_mre/pkg-descr6
5 files changed, 73 insertions, 0 deletions
diff --git a/dns/dns_mre/Makefile b/dns/dns_mre/Makefile
new file mode 100644
index 000000000000..aac8e28a7e6e
--- /dev/null
+++ b/dns/dns_mre/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: dns_mre
+# Date created: 2008-08-02
+# Whom: Tomoyuki Sakurai <cherry@trombik.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dns_mre
+PORTVERSION= 1.0
+CATEGORIES= dns security
+MASTER_SITES= http://www.securebits.org/tools/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= cherry@trombik.org
+COMMENT= DNS Cache Poisoner/Overwriter
+
+NO_WRKSUBDIR= Yes
+
+PLIST_FILES= bin/dns_mre
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -Wall main.c dns_mre.c -o dns_mre
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dns_mre ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/dns/dns_mre/distinfo b/dns/dns_mre/distinfo
new file mode 100644
index 000000000000..af0f9e998b08
--- /dev/null
+++ b/dns/dns_mre/distinfo
@@ -0,0 +1,3 @@
+MD5 (dns_mre-v1.0.tar.gz) = a080cf0d3d5faa5bc1351c55d9f43415
+SHA256 (dns_mre-v1.0.tar.gz) = 7a3c264805686bedf06f10fa7536403d679cf69f269b95cb8a11d4f3e1d026e6
+SIZE (dns_mre-v1.0.tar.gz) = 21958
diff --git a/dns/dns_mre/files/patch-dns_mre.c b/dns/dns_mre/files/patch-dns_mre.c
new file mode 100644
index 000000000000..7f95557f77ab
--- /dev/null
+++ b/dns/dns_mre/files/patch-dns_mre.c
@@ -0,0 +1,27 @@
+--- dns_mre.c.orig 2008-08-02 01:23:19.000000000 +0900
++++ dns_mre.c 2008-08-02 20:37:50.000000000 +0900
+@@ -160,7 +160,6 @@
+ u_int8_t * udp_pointer = NULL;
+ u_int8_t * dns_pointer = NULL;
+ int dns_size;
+- int i;
+
+ if( !answer_flag )
+ printf("# Preparing query raw packet...");
+@@ -195,7 +194,7 @@
+ u_int8_t * ip4_pointer = NULL;
+ u_int8_t * udp_pointer = NULL;
+ u_int8_t * dns_pointer = NULL;
+- int dns_size;
++ int dns_size = 0;
+ int i;
+
+ if( !answer_flag )
+@@ -797,6 +796,7 @@
+ " -x <no_txids> Number of static Transaction IDs to use (optional; default 15)\n"
+ " -v Verbosity\n"
+ , cmd);
++ return 1;
+ }
+
+
diff --git a/dns/dns_mre/files/patch-dns_mre.h b/dns/dns_mre/files/patch-dns_mre.h
new file mode 100644
index 000000000000..0e7833febf49
--- /dev/null
+++ b/dns/dns_mre/files/patch-dns_mre.h
@@ -0,0 +1,10 @@
+--- dns_mre.h.orig 2008-08-02 04:02:47.000000000 +0900
++++ dns_mre.h 2008-08-02 04:02:51.000000000 +0900
+@@ -32,6 +32,7 @@
+ #include <netdb.h>
+ #include <arpa/inet.h>
+ #include <string.h>
++#include <time.h>
+
+ /* Definitions */
+ #define Q_S_PORT 2345 /* Query Source Port */
diff --git a/dns/dns_mre/pkg-descr b/dns/dns_mre/pkg-descr
new file mode 100644
index 000000000000..b17e67c33877
--- /dev/null
+++ b/dns/dns_mre/pkg-descr
@@ -0,0 +1,6 @@
+DNS Multiple Race Exploiter is a tool that exploits an inherent flaw in the
+DNS Server Cache. By sending many queries to a DNS server along with fake
+replies, an attacker can successfuly writes a fake new entry in the DNS
+cache.
+
+WWW: http://www.securebits.org/dnsmre.html