aboutsummaryrefslogtreecommitdiff
path: root/dns/dnscap
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-05-02 22:44:13 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-05-02 22:44:13 +0000
commite47de4b05b0644358bd4834ea7a7c777ddf3b398 (patch)
tree53201d5960e0c192db280ff84823b17a4b3e369a /dns/dnscap
parent306b680d7e60a7694a0f592dc9360b5bbf0d4e92 (diff)
Notes
Diffstat (limited to 'dns/dnscap')
-rw-r--r--dns/dnscap/Makefile31
-rw-r--r--dns/dnscap/distinfo3
-rw-r--r--dns/dnscap/pkg-descr13
3 files changed, 47 insertions, 0 deletions
diff --git a/dns/dnscap/Makefile b/dns/dnscap/Makefile
new file mode 100644
index 000000000000..ed1790e50884
--- /dev/null
+++ b/dns/dnscap/Makefile
@@ -0,0 +1,31 @@
+#
+# Ports collection makefile for: news/openftd
+# Whom: Edwin Groothuis <edwin@mavetju.org>
+# Date created: 2007-05-02
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnscap
+PORTVERSION= 0.0
+CATEGORIES= dns net
+MASTER_SITES= http://public.oarci.net/files/active/0/
+DISTFILES= dnscap.shar
+
+MAINTAINER= edwin@mavetju.org
+COMMENT= DNS traffic capture utility
+
+WRKSRC= ${WRKDIR}
+
+PLIST_FILES= bin/dnscap
+MAN1= dnscap.1
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${WRKSRC} && ${SH} ${DISTDIR}/${DISTFILES}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dnscap ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/dnscap.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/dns/dnscap/distinfo b/dns/dnscap/distinfo
new file mode 100644
index 000000000000..ab97548d0b0a
--- /dev/null
+++ b/dns/dnscap/distinfo
@@ -0,0 +1,3 @@
+MD5 (dnscap.shar) = aba3cccb5d31eac7171deb534843ca12
+SHA256 (dnscap.shar) = 873756559a69147b22bdae7477ad56f0b71b2425cc239246f479b58f742ec225
+SIZE (dnscap.shar) = 35311
diff --git a/dns/dnscap/pkg-descr b/dns/dnscap/pkg-descr
new file mode 100644
index 000000000000..97d2ab5f6f40
--- /dev/null
+++ b/dns/dnscap/pkg-descr
@@ -0,0 +1,13 @@
+cap is a network capture utility designed specifically for DNS
+traffic. It produces binary data in pcap(3) format, either on
+standard output (by default) or in successive dump files (if the d
+command line option is given.) This utility is similar to tcpdump(1),
+but has finer grained packet recognition tailored to DNS transactions
+and protocol options. dnscap is expected to be used for gathering
+continuous research or audit traces.
+
+SYNOPSIS
+ dnscap [-avf6] [-i if ...] [-l vlan ...] [-p port] [-m [quire]] [-h [ir]]
+ [-q host ...] [-r host ...] [-d base [-k cmd]] [-t lim] [-c lim]
+
+WWW: http://public.oarci.net/tools/dnscap