aboutsummaryrefslogtreecommitdiff
path: root/dns/dnscrypt-wrapper
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2017-02-08 11:35:03 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2017-02-08 11:35:03 +0000
commit7a5fb5edb7677b9e759177420955fe6eb2dcab1e (patch)
treeea1fc24c4ca9390809b60ac753c5434276e7d167 /dns/dnscrypt-wrapper
parente3216a87979afca690443a6269874f6ccba6fdb4 (diff)
downloadports-7a5fb5edb7677b9e759177420955fe6eb2dcab1e.tar.gz
ports-7a5fb5edb7677b9e759177420955fe6eb2dcab1e.zip
Notes
Diffstat (limited to 'dns/dnscrypt-wrapper')
-rw-r--r--dns/dnscrypt-wrapper/Makefile7
-rw-r--r--dns/dnscrypt-wrapper/distinfo5
-rw-r--r--dns/dnscrypt-wrapper/files/patch-Makefile29
-rw-r--r--dns/dnscrypt-wrapper/files/patch-argparse_Makefile19
4 files changed, 6 insertions, 54 deletions
diff --git a/dns/dnscrypt-wrapper/Makefile b/dns/dnscrypt-wrapper/Makefile
index 559344b90833..08c5e6c27e21 100644
--- a/dns/dnscrypt-wrapper/Makefile
+++ b/dns/dnscrypt-wrapper/Makefile
@@ -1,22 +1,21 @@
# $FreeBSD$
PORTNAME= dnscrypt-wrapper
-PORTVERSION= 0.2.1
+PORTVERSION= 0.2.2
DISTVERSIONPREFIX= v
-PORTREVISION= 4
CATEGORIES= dns
MAINTAINER= freebsd@toyingwithfate.com
COMMENT= Adds dnscrypt support to any name resolver
-LICENSE= GPLv2
+LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libsodium.so:security/libsodium \
libevent.so:devel/libevent2
USE_GITHUB= yes
-GH_ACCOUNT= Cofyc
+GH_ACCOUNT= cofyc
USERS= _dnscrypt-wrapper
ETCDNSCRYPTWRAPPER= ${PREFIX}/etc/${PORTNAME}
diff --git a/dns/dnscrypt-wrapper/distinfo b/dns/dnscrypt-wrapper/distinfo
index 0fc176d89a50..3a218e4ac626 100644
--- a/dns/dnscrypt-wrapper/distinfo
+++ b/dns/dnscrypt-wrapper/distinfo
@@ -1,2 +1,3 @@
-SHA256 (Cofyc-dnscrypt-wrapper-v0.2.1_GH0.tar.gz) = 28c9936e90fc5602821353ca34c3180a047ae9eff08e0373cfa582e6af0c4e90
-SIZE (Cofyc-dnscrypt-wrapper-v0.2.1_GH0.tar.gz) = 52026
+TIMESTAMP = 1486543775
+SHA256 (cofyc-dnscrypt-wrapper-v0.2.2_GH0.tar.gz) = 6ac2a813d05a3d985da5b9ecce7147e1d3062b23e173ad7c99e7e2719b5a12a8
+SIZE (cofyc-dnscrypt-wrapper-v0.2.2_GH0.tar.gz) = 45976
diff --git a/dns/dnscrypt-wrapper/files/patch-Makefile b/dns/dnscrypt-wrapper/files/patch-Makefile
deleted file mode 100644
index 4f3ec441620f..000000000000
--- a/dns/dnscrypt-wrapper/files/patch-Makefile
+++ /dev/null
@@ -1,29 +0,0 @@
---- Makefile.orig 2016-07-08 19:10:05 UTC
-+++ Makefile
-@@ -7,7 +7,7 @@ all::
-
- ### Defaults
-
--BASIC_CFLAGS = -O2 -std=c99 -Wall -I./argparse
-+BASIC_CFLAGS = -std=c99 -Wall -I./argparse
- BASIC_LDFLAGS = -lm -lsodium
-
- # Guard against environment variables
-@@ -29,13 +29,13 @@ uname_P := $(shell sh -c 'uname -p 2>/de
- uname_V := $(shell sh -c 'uname -v 2>/dev/null || echo not')
-
- # CFLAGS and LDFLAGS are for users to override
--CFLAGS = -g -O2 -Wall
--LDFLAGS =
-+CFLAGS ?= -g -O2 -Wall
-+LDFLAGS ?=
- STRIP ?= strip
-
- # We use ALL_* variants
--ALL_CFLAGS = $(CFLAGS) $(BASIC_CFLAGS)
--ALL_LDFLAGS = $(LDFLAGS) $(BASIC_LDFLAGS)
-+ALL_CFLAGS = $(BASIC_CFLAGS) $(CFLAGS)
-+ALL_LDFLAGS = $(BASIC_LDFLAGS) $(LDFLAGS)
-
- ifdef PREFIX
- prefix = $(PREFIX)
diff --git a/dns/dnscrypt-wrapper/files/patch-argparse_Makefile b/dns/dnscrypt-wrapper/files/patch-argparse_Makefile
deleted file mode 100644
index 7eb0abb80ec9..000000000000
--- a/dns/dnscrypt-wrapper/files/patch-argparse_Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
---- argparse/Makefile.orig 2016-07-08 19:10:50 UTC
-+++ argparse/Makefile
-@@ -1,10 +1,13 @@
- # Defaults
--BASIC_CFLAGS = -Wall -O3 -g -ggdb -fPIC
-+CFLAGS ?= -O3 -g -ggdb
-+LDFLAGS ?=
-+
-+BASIC_CFLAGS = -Wall -fPIC
- BASIC_LDFLAGS = -lm
-
- # We use ALL_* variants
--ALL_CFLAGS = $(CFLAGS) $(BASIC_CFLAGS)
--ALL_LDFLAGS = $(LDFLAGS) $(BASIC_LDFLAGS)
-+ALL_CFLAGS = $(BASIC_CFLAGS) $(CFLAGS)
-+ALL_LDFLAGS = $(BASIC_LDFLAGS) $(LDFLAGS)
-
- LIBNAME=libargparse
-