aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsdist
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2017-08-22 20:38:35 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2017-08-22 20:38:35 +0000
commitbdfbe6302d853f8e2d1d4d0358ff8ac9d5023271 (patch)
tree3b65c4c1be3a98caecd9c15fe072d78ac248bc51 /dns/dnsdist
parent3df74f6ca89c1ef6b9d61e724218091831a5b279 (diff)
downloadports-bdfbe6302d853f8e2d1d4d0358ff8ac9d5023271.tar.gz
ports-bdfbe6302d853f8e2d1d4d0358ff8ac9d5023271.zip
Notes
Diffstat (limited to 'dns/dnsdist')
-rw-r--r--dns/dnsdist/Makefile9
-rw-r--r--dns/dnsdist/distinfo6
-rw-r--r--dns/dnsdist/files/patch-ext_json11_json11.cpp36
-rw-r--r--dns/dnsdist/pkg-descr2
4 files changed, 8 insertions, 45 deletions
diff --git a/dns/dnsdist/Makefile b/dns/dnsdist/Makefile
index 25b12151515a..9a0b592a88c6 100644
--- a/dns/dnsdist/Makefile
+++ b/dns/dnsdist/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= dnsdist
-DISTVERSION= 1.1.0
-PORTREVISION= 7
+DISTVERSION= 1.2.0
CATEGORIES= dns net
MASTER_SITES= https://downloads.powerdns.com/releases/ \
LOCAL/cpm
@@ -40,9 +39,9 @@ USE_RC_SUBR= dnsdist
# Fix dnsdist binaries when building on FreeBSD 10.3
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100000
-BUILD_DEPENDS+= clang39:devel/llvm39
-CC= clang39
-CXX= clang++39
+BUILD_DEPENDS+= clang40:devel/llvm40
+CC= clang40
+CXX= clang++40
.endif
post-install:
diff --git a/dns/dnsdist/distinfo b/dns/dnsdist/distinfo
index 044b5a9032b2..ce6b5a63d08a 100644
--- a/dns/dnsdist/distinfo
+++ b/dns/dnsdist/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483106940
-SHA256 (dnsdist-1.1.0.tar.bz2) = b4a1e8931b6d05a24494f54224211c0de0eeb1f5ff170f6b9f5665219bfeafc2
-SIZE (dnsdist-1.1.0.tar.bz2) = 874837
+TIMESTAMP = 1503429670
+SHA256 (dnsdist-1.2.0.tar.bz2) = 9885c9ee8ac7076aede586ea58d4642eb877e7b2d76c902254494e2a5a5faa78
+SIZE (dnsdist-1.2.0.tar.bz2) = 876104
diff --git a/dns/dnsdist/files/patch-ext_json11_json11.cpp b/dns/dnsdist/files/patch-ext_json11_json11.cpp
deleted file mode 100644
index 600308eaa51b..000000000000
--- a/dns/dnsdist/files/patch-ext_json11_json11.cpp
+++ /dev/null
@@ -1,36 +0,0 @@
---- ext/json11/json11.cpp.orig 2017-01-18 02:13:48 UTC
-+++ ext/json11/json11.cpp
-@@ -37,11 +37,20 @@ using std::make_shared;
- using std::initializer_list;
- using std::move;
-
-+/* Helper for representing null - just a do-nothing struct, plus comparison
-+ * operators so the helpers in JsonValue work. We can't use nullptr_t because
-+ * it may not be orderable.
-+*/
-+struct NullStruct {
-+ bool operator==(NullStruct) const { return true; }
-+ bool operator<(NullStruct) const { return false; }
-+};
-+
- /* * * * * * * * * * * * * * * * * * * *
- * Serialization
- */
-
--static void dump(std::nullptr_t, string &out) {
-+static void dump(NullStruct, string &out) {
- out += "null";
- }
-
-@@ -204,9 +213,9 @@ public:
- explicit JsonObject(Json::object &&value) : Value(move(value)) {}
- };
-
--class JsonNull final : public Value<Json::NUL, std::nullptr_t> {
-+class JsonNull final : public Value<Json::NUL, NullStruct> {
- public:
-- JsonNull() : Value(nullptr) {}
-+ JsonNull() : Value({}) {}
- };
-
- /* * * * * * * * * * * * * * * * * * * *
diff --git a/dns/dnsdist/pkg-descr b/dns/dnsdist/pkg-descr
index bb027a0faad7..b2ea9ccab636 100644
--- a/dns/dnsdist/pkg-descr
+++ b/dns/dnsdist/pkg-descr
@@ -3,4 +3,4 @@ goal in life is to route DNS traffic to the best DNS server,
delivering top performance to legitimate users while shunting or
blocking abusive traffic.
-WWW: http://dnsdist.org
+WWW: https://dnsdist.org