aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsmasq
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-09-30 16:44:41 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-09-30 16:44:41 +0000
commitb9940e2ddaa787f07f41405913a351b16e1e9d62 (patch)
tree7559d1adb4ae7d772fd2e3a936adde3c68004006 /dns/dnsmasq
parent38f7d5776b2404242e7253ebd720da7a7a2678d9 (diff)
downloadports-b9940e2ddaa787f07f41405913a351b16e1e9d62.tar.gz
ports-b9940e2ddaa787f07f41405913a351b16e1e9d62.zip
Notes
Diffstat (limited to 'dns/dnsmasq')
-rw-r--r--dns/dnsmasq/Makefile39
-rw-r--r--dns/dnsmasq/pkg-plist3
2 files changed, 18 insertions, 24 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index 684a28077344..d37b2941410b 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -16,8 +16,6 @@ LICENSE= GPLv2
CONFLICTS_INSTALL=dnsmasq-devel-*
-MAN8= dnsmasq.8
-
PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
SUB_FILES= pkg-message
@@ -32,7 +30,6 @@ NLS_DESC= National Language Support (NLS, enables IDN)
IDN_DESC= International Domain Names (IDN) WITHOUT NLS
LUA_DESC= Support lease-change scripts in LUA
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if empty(PORT_OPTIONS:MIPV6)
@@ -41,20 +38,20 @@ CFLAGS+= -DNO_IPV6
.if ${PORT_OPTIONS:MNLS}
USES+= pkgconfig gettext
-LIB_DEPENDS+= idn:${PORTSDIR}/dns/libidn
+LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
PLIST_SUB+= NLS=""
ALL_TARGET= all-i18n
-USE_GMAKE= yes
+USES+= gmake
.else
PLIST_SUB+= NLS="@comment "
.if ${PORT_OPTIONS:MIDN}
CFLAGS+= -DHAVE_IDN
-LIB_DEPENDS+= idn:${PORTSDIR}/dns/libidn
+LIB_DEPENDS+= libidn.so:${PORTSDIR}/dns/libidn
.endif
.endif
.if ${PORT_OPTIONS:MDBUS}
-LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
USES+= pkgconfig
CFLAGS+= -DHAVE_DBUS
.endif
@@ -86,28 +83,24 @@ pre-configure:
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${PREFIX}/etc
- ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.8 ${PREFIX}/man/man8
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/dnsmasq ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/dnsmasq.conf.example ${STAGEDIR}${PREFIX}/etc
+ ${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.8 ${STAGEDIR}${PREFIX}/man/man8
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MNLS}
.for i in de es fi fr id it no pl pt_BR ro
- ${MKDIR} ${PREFIX}/share/locale/${i}/LC_MESSAGES
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${i}/LC_MESSAGES
${INSTALL_DATA} ${WRKSRC}/src/${i}.mo \
- ${PREFIX}/share/locale/${i}/LC_MESSAGES/${PORTNAME}.mo
+ ${STAGEDIR}${PREFIX}/share/locale/${i}/LC_MESSAGES/${PORTNAME}.mo
.endfor
.endif
- ${MKDIR} ${EXAMPLESDIR}/dynamic-dnsmasq ${EXAMPLESDIR}/dnslist
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl ${EXAMPLESDIR}/dynamic-dnsmasq/
- ${INSTALL_SCRIPT} ${WRKSRC}/contrib/dnslist/dnslist.pl ${EXAMPLESDIR}/dnslist/
- ${INSTALL_DATA} ${WRKSRC}/contrib/dnslist/dhcp.css ${EXAMPLESDIR}/dnslist/
- ${INSTALL_DATA} ${WRKSRC}/contrib/dnslist/dnslist.tt2 ${EXAMPLESDIR}/dnslist/
- if [ ! -f ${PREFIX}/etc/dnsmasq.conf ]; then \
- ${CP} -p ${PREFIX}/etc/dnsmasq.conf.example ${PREFIX}/etc/dnsmasq.conf; \
- fi
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/dynamic-dnsmasq ${STAGEDIR}${EXAMPLESDIR}/dnslist
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl ${STAGEDIR}${EXAMPLESDIR}/dynamic-dnsmasq/
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/dnslist/dnslist.pl ${STAGEDIR}${EXAMPLESDIR}/dnslist/
+ ${INSTALL_DATA} ${WRKSRC}/contrib/dnslist/dhcp.css ${STAGEDIR}${EXAMPLESDIR}/dnslist/
+ ${INSTALL_DATA} ${WRKSRC}/contrib/dnslist/dnslist.tt2 ${STAGEDIR}${EXAMPLESDIR}/dnslist/
.include <bsd.port.post.mk>
diff --git a/dns/dnsmasq/pkg-plist b/dns/dnsmasq/pkg-plist
index a6881d038e9d..d5ae548e866b 100644
--- a/dns/dnsmasq/pkg-plist
+++ b/dns/dnsmasq/pkg-plist
@@ -1,7 +1,8 @@
sbin/dnsmasq
-@exec if [ ! -f %D/etc/dnsmasq.conf ]; then cp -p %D/%F %B/dnsmasq.conf; fi
@unexec if cmp -s %D/etc/dnsmasq.conf %D/etc/dnsmasq.conf.example ; then rm -f %D/etc/dnsmasq.conf ; fi
etc/dnsmasq.conf.example
+@exec if [ ! -f %D/etc/dnsmasq.conf ]; then cp -p %D/%F %B/dnsmasq.conf; fi
+man/man8/dnsmasq.8.gz
%%EXAMPLESDIR%%/dnslist/dhcp.css
%%EXAMPLESDIR%%/dnslist/dnslist.pl
%%EXAMPLESDIR%%/dnslist/dnslist.tt2