aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsmasq
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-04-12 01:59:59 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-04-12 01:59:59 +0000
commitd09a1f90f629bd20051a4f6537cfeaf8f513ff60 (patch)
tree1899721e12b7c4c9432562ac8490bf74fe88720c /dns/dnsmasq
parent2da3f1a9f16072fdc3a0fee41a5ae6576804cfd0 (diff)
downloadports-d09a1f90f629bd20051a4f6537cfeaf8f513ff60.tar.gz
ports-d09a1f90f629bd20051a4f6537cfeaf8f513ff60.zip
Notes
Diffstat (limited to 'dns/dnsmasq')
-rw-r--r--dns/dnsmasq/Makefile55
-rw-r--r--dns/dnsmasq/distinfo6
-rw-r--r--dns/dnsmasq/files/patch-src_crypto.c31
-rw-r--r--dns/dnsmasq/files/patch-src_tftp.c18
4 files changed, 37 insertions, 73 deletions
diff --git a/dns/dnsmasq/Makefile b/dns/dnsmasq/Makefile
index daace727615a..5918ebe757f4 100644
--- a/dns/dnsmasq/Makefile
+++ b/dns/dnsmasq/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= dnsmasq
-DISTVERSION= 2.80
-PORTREVISION= 4 # leave this in even if 0 to avoid PORTEPOCH bumps
+DISTVERSION= 2.81
+# Leave the PORTREVISION in even if 0 to avoid accidental PORTEPOCH bumps:
+PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= dns
MASTER_SITES= http://www.thekelleys.org.uk/dnsmasq/ \
@@ -14,34 +15,43 @@ COMMENT= Lightweight DNS forwarder, DHCP, and TFTP server
LICENSE= GPLv2
-CONFLICTS_INSTALL=dnsmasq-devel-*
+USES= cpe shebangfix tar:xz
+CPE_VENDOR= thekelleys
-PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
+SHEBANG_FILES= contrib/dnslist/dnslist.pl \
+ contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl
+
+MAKE_ARGS= CC="${CC}" \
+ CFLAGS="${CFLAGS}" \
+ COPTS="${CFLAGS}" \
+ LIBS="${LDFLAGS}" \
+ PREFIX="${PREFIX}" \
+ RPM_OPT_FLAGS="${CPPFLAGS}"
+CFLAGS+= -Wall -Wno-unused-function -Wno-unused-parameter \
+ -Wno-unused-value -Wno-unused-variable
+CPPFLAGS+= -I${LOCALBASE}/include
+
+CONFLICTS_INSTALL= dnsmasq-devel-*
SUB_FILES= pkg-message
-CFLAGS+= -Wall -Wno-unused-value -Wno-unused-parameter -Wno-unused-variable -Wno-unused-function
-CPPFLAGS+= -I${LOCALBASE}/include
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" PREFIX="${PREFIX}" COPTS="${CFLAGS}" LIBS="${LDFLAGS}" RPM_OPT_FLAGS="${CPPFLAGS}"
+PORTDOCS= CHANGELOG CHANGELOG.archive FAQ doc.html setup.html
-OPTIONS_DEFINE= IPSET IPV6 DBUS LUA DNSSEC DOCS
+OPTIONS_DEFINE= DBUS DNSSEC DOCS IPSET IPV6 LUA
OPTIONS_DEFAULT= DNSSEC IPSET
-OPTIONS_EXCLUDE+= EXAMPLES
OPTIONS_RADIO= INTL
OPTIONS_RADIO_INTL= IDN NLS
-INTL_DESC= Internationalization Support Level
-NLS_DESC= IDN+NLS: Int'l Domain Names & National Language support
+OPTIONS_EXCLUDE+= EXAMPLES
+
+DNSSEC_DESC= Enable DNSSEC caching and validation (needs nettle)
IDN_DESC= IDN: Int'l Domain Names WITHOUT full NLS
+INTL_DESC= Internationalization Support Level
IPSET_DESC= Dynamic firewall management of resolved names (needs PF)
LUA_DESC= Support lease-change scripts written in Lua
-DNSSEC_DESC= Enable DNSSEC caching and validation
-USES= cpe shebangfix tar:xz
-SHEBANG_FILES= contrib/dynamic-dnsmasq/dynamic-dnsmasq.pl \
- contrib/dnslist/dnslist.pl
-CPE_VENDOR= thekelleys
+NLS_DESC= IDN+NLS: Int'l Domain Names & National Language support
-IPV6_CFLAGS_OFF=-DNO_IPV6
-IPSET_CFLAGS_OFF=-DNO_IPSET
+IPSET_CFLAGS_OFF= -DNO_IPSET
+IPV6_CFLAGS_OFF= -DNO_IPV6
.include <bsd.port.options.mk>
@@ -75,14 +85,14 @@ LDFLAGS+= `pkg-config --libs dbus-1`
CPPFLAGS+= -I${LUA_INCDIR}
CFLAGS+= -DHAVE_LUASCRIPT
LDFLAGS+= -L${LUA_LIBDIR} -llua-${LUA_VER}
-USES+= lua
+USES+= lua pkgconfig
.endif
.if ${PORT_OPTIONS:MDNSSEC}
CFLAGS+= -DHAVE_DNSSEC -I${LOCALBASE}/include
USES+= pkgconfig
-LIB_DEPENDS+= libnettle.so:security/nettle
-LIB_DEPENDS+= libgmp.so:math/gmp
+LIB_DEPENDS+= libgmp.so:math/gmp \
+ libnettle.so:security/nettle
.endif
USE_RC_SUBR= dnsmasq
@@ -91,6 +101,9 @@ USE_RC_SUBR= dnsmasq
LDFLAGS+= -L${LOCALBASE}/lib ${_intllibs} ${ICONV_LIB}
+post-patch:
+ ${REINPLACE_CMD} -e '/^lua_/s/lua5\.2/lua-${LUA_VER}/' ${WRKSRC}/Makefile
+
pre-configure: pretty-print-config
.if ${PORT_OPTIONS:MIDN}
.if empty(PORT_OPTIONS:MNLS)
diff --git a/dns/dnsmasq/distinfo b/dns/dnsmasq/distinfo
index 419c2a30af93..e2681914329b 100644
--- a/dns/dnsmasq/distinfo
+++ b/dns/dnsmasq/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539932660
-SHA256 (dnsmasq-2.80.tar.xz) = cdaba2785e92665cf090646cba6f94812760b9d7d8c8d0cfb07ac819377a63bb
-SIZE (dnsmasq-2.80.tar.xz) = 501072
+TIMESTAMP = 1586652751
+SHA256 (dnsmasq-2.81.tar.xz) = 749ca903537c5197c26444ac24b0dce242cf42595fdfe6b9a5b9e4c7ad32f8fb
+SIZE (dnsmasq-2.81.tar.xz) = 510648
diff --git a/dns/dnsmasq/files/patch-src_crypto.c b/dns/dnsmasq/files/patch-src_crypto.c
deleted file mode 100644
index caf63280d398..000000000000
--- a/dns/dnsmasq/files/patch-src_crypto.c
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/crypto.c.orig 2018-10-18 18:21:55 UTC
-+++ src/crypto.c
-@@ -275,6 +275,10 @@ static int dnsmasq_ecdsa_verify(struct blockdata *key_
- static struct ecc_point *key_256 = NULL, *key_384 = NULL;
- static mpz_t x, y;
- static struct dsa_signature *sig_struct;
-+#if NETTLE_VERSION_MAJOR == 3 && NETTLE_VERSION_MINOR < 4
-+#define nettle_get_secp_256r1() (&nettle_secp_256r1)
-+#define nettle_get_secp_384r1() (&nettle_secp_384r1)
-+#endif
-
- if (!sig_struct)
- {
-@@ -294,7 +298,7 @@ static int dnsmasq_ecdsa_verify(struct blockdata *key_
- if (!(key_256 = whine_malloc(sizeof(struct ecc_point))))
- return 0;
-
-- nettle_ecc_point_init(key_256, &nettle_secp_256r1);
-+ nettle_ecc_point_init(key_256, nettle_get_secp_256r1());
- }
-
- key = key_256;
-@@ -307,7 +311,7 @@ static int dnsmasq_ecdsa_verify(struct blockdata *key_
- if (!(key_384 = whine_malloc(sizeof(struct ecc_point))))
- return 0;
-
-- nettle_ecc_point_init(key_384, &nettle_secp_384r1);
-+ nettle_ecc_point_init(key_384, nettle_get_secp_384r1());
- }
-
- key = key_384;
diff --git a/dns/dnsmasq/files/patch-src_tftp.c b/dns/dnsmasq/files/patch-src_tftp.c
deleted file mode 100644
index 101b409fab2c..000000000000
--- a/dns/dnsmasq/files/patch-src_tftp.c
+++ /dev/null
@@ -1,18 +0,0 @@
-X-Git-Url: http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=blobdiff_plain;f=src%2Ftftp.c;h=c618a2c1eeb73de147ade0cf75de24cbc3cb3f38;hp=435b21687ffa366a7bebf1bfc7905997be5b8f7d;hb=936bd82755e8f75fc09c1e9a67fb390175b157d4;hpb=13a58f9590a7071ad4a8c8f7e4178c29a6b66be3
-
---- src/tftp.c.orig 2018-10-18 18:21:55 UTC
-+++ src/tftp.c
-@@ -74,9 +74,11 @@ void tftp_request(struct listener *listen, time_t now)
- #if defined(HAVE_LINUX_NETWORK)
- char control[CMSG_SPACE(sizeof(struct in_pktinfo))];
- #elif defined(HAVE_SOLARIS_NETWORK)
-- char control[CMSG_SPACE(sizeof(unsigned int))];
-+ char control[CMSG_SPACE(sizeof(struct in_addr)) +
-+ CMSG_SPACE(sizeof(unsigned int))];
- #elif defined(IP_RECVDSTADDR) && defined(IP_RECVIF)
-- char control[CMSG_SPACE(sizeof(struct sockaddr_dl))];
-+ char control[CMSG_SPACE(sizeof(struct in_addr)) +
-+ CMSG_SPACE(sizeof(struct sockaddr_dl))];
- #endif
- } control_u;
-