aboutsummaryrefslogtreecommitdiff
path: root/dns/dnsperf
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2018-05-13 04:19:16 +0000
committerHiroki Sato <hrs@FreeBSD.org>2018-05-13 04:19:16 +0000
commit220c428bce75a88490a728f9e3f7009ac8ed16aa (patch)
treec9b93fb00cd55d778e669dee916e91796716de3a /dns/dnsperf
parent07d8ebaf2e96a858290b2805b5f834a7b075685d (diff)
downloadports-220c428bce75a88490a728f9e3f7009ac8ed16aa.tar.gz
ports-220c428bce75a88490a728f9e3f7009ac8ed16aa.zip
Notes
Diffstat (limited to 'dns/dnsperf')
-rw-r--r--dns/dnsperf/Makefile21
-rw-r--r--dns/dnsperf/distinfo5
-rw-r--r--dns/dnsperf/files/patch-Makefile.in10
-rw-r--r--dns/dnsperf/pkg-descr30
4 files changed, 31 insertions, 35 deletions
diff --git a/dns/dnsperf/Makefile b/dns/dnsperf/Makefile
index 827322b3930a..cddd769a26ed 100644
--- a/dns/dnsperf/Makefile
+++ b/dns/dnsperf/Makefile
@@ -2,18 +2,22 @@
# $FreeBSD$
PORTNAME= dnsperf
-PORTVERSION= 2.0.0.0
-PORTREVISION= 3
+PORTVERSION= 2.1.0.0
CATEGORIES= dns benchmarks net
MASTER_SITES= ftp://ftp.nominum.com/pub/nominum/${PORTNAME}/${PORTVERSION}/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}-1
MAINTAINER= hrs@FreeBSD.org
-COMMENT= Accurate performance metrics of Domain Name Services
+COMMENT= Performance measurement of Domain Name System (DNS) servers
-BUILD_DEPENDS= isc-config.sh:dns/bind910
+LICENSE= ISCL
-USES= iconv
+BUILD_DEPENDS= isc-config.sh:dns/bind912
+LIB_DEPENDS= liblmdb.so:databases/lmdb \
+ libjson-c.so:devel/json-c
+
+USES= iconv ssl
+USE_GNOME= libxml2
GNU_CONFIGURE= yes
MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
INSTALL_SCRIPT="${INSTALL_SCRIPT}" \
@@ -27,16 +31,9 @@ PLIST_FILES= bin/dnsperf \
PORTDOCS= caching-dns-performance.pdf \
dnsperf.pdf \
resperf.pdf
-CFLAGS+= -I.
OPTIONS_DEFINE= DOCS
-# This is a workaround for broken isc/stat.h.
-pre-build:
- ${MKDIR} ${WRKSRC}/isc
- ${ECHO_CMD} "#include <sys/types.h>" > ${WRKSRC}/isc/stat.h
- ${ECHO_CMD} "#include <sys/stat.h>" >> ${WRKSRC}/isc/stat.h
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
diff --git a/dns/dnsperf/distinfo b/dns/dnsperf/distinfo
index 513723d8e443..e9566e9851fe 100644
--- a/dns/dnsperf/distinfo
+++ b/dns/dnsperf/distinfo
@@ -1,2 +1,3 @@
-SHA256 (dnsperf-src-2.0.0.0-1.tar.gz) = 23d486493f04554d11fca97552e860028f18c5ed6e35348e480a7448fa8cfaad
-SIZE (dnsperf-src-2.0.0.0-1.tar.gz) = 565871
+TIMESTAMP = 1524326968
+SHA256 (dnsperf-src-2.1.0.0-1.tar.gz) = 64b5f0a680e1ad60bca5fd709f1a9a8404ac2fd85af6138bd22ca9a28b616e0e
+SIZE (dnsperf-src-2.1.0.0-1.tar.gz) = 561502
diff --git a/dns/dnsperf/files/patch-Makefile.in b/dns/dnsperf/files/patch-Makefile.in
index b202bcf51c5a..8a2db0ea87d7 100644
--- a/dns/dnsperf/files/patch-Makefile.in
+++ b/dns/dnsperf/files/patch-Makefile.in
@@ -1,17 +1,15 @@
---- Makefile.in.orig 2012-03-02 11:25:22.000000000 +0900
-+++ Makefile.in 2013-07-19 11:50:57.000000000 +0900
-@@ -7,8 +7,8 @@
+--- Makefile.in.orig 2015-12-16 00:46:49 UTC
++++ Makefile.in
+@@ -7,8 +7,6 @@ mandir = @mandir@
datarootdir = @datarootdir@
INSTALL = @INSTALL@
-INSTALL_PROGRAM = @INSTALL_PROGRAM@
-INSTALL_DATA = @INSTALL_DATA@
-+#INSTALL_PROGRAM = @INSTALL_PROGRAM@
-+#INSTALL_DATA = @INSTALL_DATA@
RANLIB = @RANLIB@
CC = @PTHREAD_CC@
-@@ -41,9 +41,9 @@
+@@ -41,9 +39,9 @@ installdirs:
install: all installdirs
${INSTALL_PROGRAM} dnsperf ${DESTDIR}${bindir}
${INSTALL_PROGRAM} resperf ${DESTDIR}${bindir}
diff --git a/dns/dnsperf/pkg-descr b/dns/dnsperf/pkg-descr
index 2e371826b326..9ce7ff4871a4 100644
--- a/dns/dnsperf/pkg-descr
+++ b/dns/dnsperf/pkg-descr
@@ -1,18 +1,18 @@
-DNSPerf and ResPerf Provide Communication Providers with Predictive
-Planning Tools to Scale Networks.
+DNSPerf and ResPerf are free tools developed by Nominum that make it
+simple to gather accurate latency and throughput metrics for Domain
+Name System (DNS) servers. The latest version of the DNSPerf and
+ResPerf can be used with test files that include IPv6 queries.
-Two tools, DNSPerf and ResPerf deliver accurate performance metrics
-of Domain Name Services (DNS). These tools are easy-to-use and
-simulate real Internet workloads to provide the necessary insight
-that carriers need to plan and deploy network services.
+DNSPerf "self-paces" the DNS query load to simulate network conditions.
+New features in DNSPerf improve the precision of latency measurements
+and allow for per packet per-query latency reporting is possible.
+DNSPerf is now multithreaded, multiple DNSPerf clients can be supported
+in multicore systems (each client requires two cores). The output of
+DNSPerf has also been improved so it is more concise and useful.
+Latency data can be used to make detailed graphs so it is simple for
+network operators to take advantage of the data.
-DNSPerf measures Authoritative Domain Name services and is designed
-to simulate network conditions by self-pacing the query load.
+ResPerf systematically increases the query rate and monitors the
+response rate to simulate caching DNS services.
-Caching services performance and workload profile differ significantly
-from Authoritative Domain services; therefore a different tool is
-needed. ResPerf is designed specifically to simulate Caching Domain
-Name services. To test a caching server, ResPerf systematically
-increases the query rate and monitors the response rate.
-
-WWW: http://www.nominum.com/support/measurement-tools/
+WWW: https://www.akamai.com/us/en/products/network-operator/measurement-tools.jsp