aboutsummaryrefslogtreecommitdiff
path: root/dns/firedns/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-10-15 14:39:10 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-10-15 14:39:10 +0000
commitda8331048021c834bdf8a3b1fa707f517e5d43f9 (patch)
tree00ea757f5207916c497b5fccc4f4deaccdc407ac /dns/firedns/Makefile
parentd5e26cd3c31113a56a70cb179490c1511672976d (diff)
downloadports-da8331048021c834bdf8a3b1fa707f517e5d43f9.tar.gz
ports-da8331048021c834bdf8a3b1fa707f517e5d43f9.zip
Notes
Diffstat (limited to 'dns/firedns/Makefile')
-rw-r--r--dns/firedns/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/dns/firedns/Makefile b/dns/firedns/Makefile
index 60c59b5b5dfe..4a8e9c5a4815 100644
--- a/dns/firedns/Makefile
+++ b/dns/firedns/Makefile
@@ -6,21 +6,20 @@
#
PORTNAME= firedns
-PORTVERSION= 0.1.28
-PORTREVISION= 2
+PORTVERSION= 0.1.29
CATEGORIES= net
MASTER_SITES= http://ares.penguinhosting.net/~ian/projects/ \
http://www.wa.apana.org.au/~dean/sources/ \
ftp://ftp.wa.apana.org.au/pub/pc/unix/packages/
-DISTNAME= firedns-${PORTVERSION}
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= -${PORTVERSION}.tar.gz
MAINTAINER= dean@odyssey.apana.org.au
BUILD_DEPENDS= ${LOCALBASE}/include/firestring.h:${PORTSDIR}/misc/firestring
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
INSTALLS_SHLIB= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
MAN3= firedns_aton4.3 firedns_aton6.3 firedns_dnsbl_lookup.3 \
firedns_getip4.3 firedns_getip6.3 firedns_getmx.3 \
@@ -31,4 +30,8 @@ MAN3= firedns_aton4.3 firedns_aton6.3 firedns_dnsbl_lookup.3 \
firedns_resolvename4.3 firedns_resolvename6.3 \
firedns_resolvetxt.3 libfiredns.3
+post-install:
+ @cd ${PREFIX}/lib; ${MV} libfiredns.so libfiredns.so.0; \
+ ${LN} -s libfiredns.so.0 libfiredns.so
+
.include <bsd.port.mk>