aboutsummaryrefslogtreecommitdiff
path: root/dns/gdnsd
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2013-11-02 03:41:45 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2013-11-02 03:41:45 +0000
commite9c521d74baf4465bc1c89f531eac89737212213 (patch)
tree217b9a5aade6cb988f68aa7230400594ed67560b /dns/gdnsd
parent9a861cab7946652025a3bea10bc3868d1474c5cf (diff)
downloadports-e9c521d74baf4465bc1c89f531eac89737212213.tar.gz
ports-e9c521d74baf4465bc1c89f531eac89737212213.zip
Notes
Diffstat (limited to 'dns/gdnsd')
-rw-r--r--dns/gdnsd/Makefile32
-rw-r--r--dns/gdnsd/distinfo4
-rw-r--r--dns/gdnsd/pkg-plist15
3 files changed, 26 insertions, 25 deletions
diff --git a/dns/gdnsd/Makefile b/dns/gdnsd/Makefile
index 20333ebfcea4..302b8c4c93bc 100644
--- a/dns/gdnsd/Makefile
+++ b/dns/gdnsd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gdnsd
-PORTVERSION= 1.10.0
+PORTVERSION= 1.10.1
CATEGORIES= dns
MASTER_SITES= http://downloads.gdnsd.net/ \
http://gdnsd.scaleengine.net/gdnsd/
@@ -14,36 +14,30 @@ LICENSE= GPLv3
LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
-OPTIONS_DEFINE= GEOIP
-
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --localstatedir=/var
USE_LDCONFIG= yes
USE_XZ= yes
USES= pkgconfig
-
-MAN1= gdnsd_geoip_test.1
-MAN3= gdnsd-plugin-api.3
-MAN5= gdnsd.config.5 gdnsd.zonefile.5
-MAN8= gdnsd.8 gdnsd-plugin-simplefo.8 gdnsd-plugin-multifo.8 \
- gdnsd-plugin-metafo.8 gdnsd-plugin-geoip.8 \
- gdnsd-plugin-weighted.8 gdnsd-plugin-extmon.8
-MANCOMPRESSED= no
+CPPFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
USE_RC_SUBR= gdnsd
USERS?= gdnsd
GROUPS?= gdnsd
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= GEOIP URCU
-.if ${PORT_OPTIONS:MGEOIP}
-RUN_DEPENDS+= ${LOCALBASE}/share/GeoIP/GeoIP.dat:${PORTSDIR}/net/GeoIP
-.endif
+GEOIP_DESC= Enable GeoIP Support
+GEOIP_RUN_DEPENDS= ${LOCALBASE}/share/GeoIP/GeoIP.dat:${PORTSDIR}/net/GeoIP
+
+URCU_DESC= Read-Copy-Update Support (Faster Zone Parsing)
+URCU_CONFIGURE_WITH= urcu
+URCU_LIB_DEPENDS= liburcu.so:${PORTSDIR}/sysutils/liburcu
+
+.include <bsd.port.options.mk>
post-install:
- ${MKDIR} ${PREFIX}/var/run/gdnsd
- ${MKDIR} ${PREFIX}/etc/gdnsd/zones
- ${TOUCH} ${PREFIX}/etc/gdnsd/zones/.keep-me
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/gdnsd/zones
.include <bsd.port.mk>
diff --git a/dns/gdnsd/distinfo b/dns/gdnsd/distinfo
index 912335b11879..89be4b7b475d 100644
--- a/dns/gdnsd/distinfo
+++ b/dns/gdnsd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gdnsd-1.10.0.tar.xz) = 43c1c50cf58bc7a5dacb7379bf39276c5f4ebb2b4697d25dba228953015db3af
-SIZE (gdnsd-1.10.0.tar.xz) = 622584
+SHA256 (gdnsd-1.10.1.tar.xz) = bd879d90f9c0c7695f6b46feb910a30beb904335b8c5c7d12d1f8d60a1140447
+SIZE (gdnsd-1.10.1.tar.xz) = 624772
diff --git a/dns/gdnsd/pkg-plist b/dns/gdnsd/pkg-plist
index 6455c3abb778..c5df9bbd4bba 100644
--- a/dns/gdnsd/pkg-plist
+++ b/dns/gdnsd/pkg-plist
@@ -69,11 +69,18 @@ sbin/gdnsd
%%DOCSDIR%%/gdnsd_geoip_test.txt
%%DOCSDIR%%/gdnsd_manual.pod
%%DOCSDIR%%/gdnsd_manual.txt
+man/man1/gdnsd_geoip_test.1.gz
+man/man3/gdnsd-plugin-api.3.gz
+man/man5/gdnsd.config.5.gz
+man/man5/gdnsd.zonefile.5.gz
+man/man8/gdnsd-plugin-extmon.8.gz
+man/man8/gdnsd-plugin-geoip.8.gz
+man/man8/gdnsd-plugin-metafo.8.gz
+man/man8/gdnsd-plugin-multifo.8.gz
+man/man8/gdnsd-plugin-simplefo.8.gz
+man/man8/gdnsd-plugin-weighted.8.gz
+man/man8/gdnsd.8.gz
@dirrm %%DOCSDIR%%
-@exec mkdir -p %D/var/run/gdnsd
-@dirrmtry var/run/gdnsd
-etc/gdnsd/zones/.keep-me
@exec mkdir -p %D/%%ETCDIR%%/gdnsd/zones
@dirrmtry etc/gdnsd/zones
@dirrmtry etc/gdnsd
-@stopdaemon gdnsd