aboutsummaryrefslogtreecommitdiff
path: root/dns/getdns
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2014-03-04 02:52:52 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2014-03-04 02:52:52 +0000
commit47b3658cbc29c13f7caa670bdf6be7a001ff6360 (patch)
treeae89f6dbd63efe77c5aff588611b81f57ac933da /dns/getdns
parentfc2282820cc83003195437c6de0444aebfe3f277 (diff)
downloadports-47b3658cbc29c13f7caa670bdf6be7a001ff6360.tar.gz
ports-47b3658cbc29c13f7caa670bdf6be7a001ff6360.zip
Notes
Diffstat (limited to 'dns/getdns')
-rw-r--r--dns/getdns/Makefile60
-rw-r--r--dns/getdns/distinfo2
-rw-r--r--dns/getdns/files/pkg-message.in12
-rw-r--r--dns/getdns/pkg-descr10
-rw-r--r--dns/getdns/pkg-plist107
5 files changed, 191 insertions, 0 deletions
diff --git a/dns/getdns/Makefile b/dns/getdns/Makefile
new file mode 100644
index 000000000000..f5b3867d1346
--- /dev/null
+++ b/dns/getdns/Makefile
@@ -0,0 +1,60 @@
+# Created by: Ryan Steinmetz <zi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= getdns
+PORTVERSION= 0.1.0
+CATEGORIES= dns ipv6
+MASTER_SITES= http://getdnsapi.net/dist/ \
+ http://mirrors.rit.edu/zi/
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= Modern asynchronous DNS API
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2 \
+ libidn.so:${PORTSDIR}/dns/libidn \
+ libldns.so:${PORTSDIR}/dns/ldns \
+ libunbound.so:${PORTSDIR}/dns/unbound
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libidn=${LOCALBASE} --docdir=${DOCSDIR} \
+ --with-trust-anchor=${LOCALBASE}/etc/unbound/root.key
+
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+SUB_FILES+= pkg-message
+
+OPTIONS_SUB= yes
+OPTIONS_DEFINE= EXAMPLES DOCS LIBEV LIBUV LIBEVENT
+
+LIBEV_DESC= Build with libev extension
+LIBUV_DESC= Build with libuv extension
+LIBEVENT_DESC= Build with libevent extension
+
+LIBEV_LIB_DEPENDS= libev.so:${PORTSDIR}/devel/libev
+LIBUV_LIB_DEPENDS= libuv.so:${PORTSDIR}/devel/libuv
+LIBEVENT_LIB_DEPENDS= event-1:${PORTSDIR}/devel/libevent
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -Ee 's,^(sharedoc = ).*,\1${WRKDIR}/doc,' \
+ -e '/echo .\*\*\*/d' ${WRKSRC}/Makefile.in
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS} || ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${WRKDIR}/examples
+ @${MV} ${WRKDIR}/doc/spec/${PORTNAME}*gz ${WRKDIR}/examples/${PORTNAME}.tgz
+ @${RM} -fr ${WRKDIR}/doc/spec
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKDIR}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/)
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @(cd ${WRKDIR}/examples && ${TAR} --strip-components=1 -xf ${PORTNAME}.tgz)
+ @(cd ${WRKDIR}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/)
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/getdns/distinfo b/dns/getdns/distinfo
new file mode 100644
index 000000000000..61d292d49a17
--- /dev/null
+++ b/dns/getdns/distinfo
@@ -0,0 +1,2 @@
+SHA256 (getdns-0.1.0.tar.gz) = 23ddcdaa3e48ef794bf8695bbb6d51b30cdabc2915e5c448757d4e6baa32bfe8
+SIZE (getdns-0.1.0.tar.gz) = 501192
diff --git a/dns/getdns/files/pkg-message.in b/dns/getdns/files/pkg-message.in
new file mode 100644
index 000000000000..32881281f5d9
--- /dev/null
+++ b/dns/getdns/files/pkg-message.in
@@ -0,0 +1,12 @@
+***
+*** !!! IMPORTANT !!!! libgetdns needs a DNSSEC trust anchor!
+***
+*** For the library to be able to perform DNSSEC, the root
+*** trust anchor needs to be present in presentation format
+*** in the file:
+*** %%LOCALBASE%%/etc/unbound/root.key
+***
+*** We recomend using unbound-anchor to retrieve and install
+*** the root trust anchor like this:
+*** unbound-anchor -a "%%LOCALBASE%%/etc/unbound/root.key"
+***
diff --git a/dns/getdns/pkg-descr b/dns/getdns/pkg-descr
new file mode 100644
index 000000000000..dbc594230354
--- /dev/null
+++ b/dns/getdns/pkg-descr
@@ -0,0 +1,10 @@
+getdns is a modern asynchronous DNS API.
+
+It implements DNS entry points from a design developed and vetted by application
+developers, in an API specification edited by Paul Hoffman. With the development
+of this API, we intend to offer application developers a modernized and flexible
+way to access DNS security (DNSSEC) and other powerful new DNS features;
+a particular hope is to inspire application developers towards innovative
+security solutions in their applications.
+
+WWW: http://getdnsapi.net/
diff --git a/dns/getdns/pkg-plist b/dns/getdns/pkg-plist
new file mode 100644
index 000000000000..612e4b1f2e98
--- /dev/null
+++ b/dns/getdns/pkg-plist
@@ -0,0 +1,107 @@
+@comment $FreeBSD$
+include/getdns/getdns.h
+include/getdns/getdns_extra.h
+%%LIBEV%%include/getdns/getdns_ext_libev.h
+%%LIBEVENT%%include/getdns/getdns_ext_libevent.h
+%%LIBUV%%include/getdns/getdns_ext_libuv.h
+lib/libgetdns-%%PORTVERSION%%.so
+lib/libgetdns-%%PORTVERSION%%.so.0
+lib/libgetdns.a
+lib/libgetdns.la
+lib/libgetdns.so
+%%LIBEV%%lib/libgetdns_ext_ev-%%PORTVERSION%%.so
+%%LIBEV%%lib/libgetdns_ext_ev-%%PORTVERSION%%.so.0
+%%LIBEV%%lib/libgetdns_ext_ev.a
+%%LIBEV%%lib/libgetdns_ext_ev.la
+%%LIBEV%%lib/libgetdns_ext_ev.so
+%%LIBEVENT%%lib/libgetdns_ext_event-%%PORTVERSION%%.so
+%%LIBEVENT%%lib/libgetdns_ext_event-%%PORTVERSION%%.so.0
+%%LIBEVENT%%lib/libgetdns_ext_event.a
+%%LIBEVENT%%lib/libgetdns_ext_event.la
+%%LIBEVENT%%lib/libgetdns_ext_event.so
+%%LIBUV%%lib/libgetdns_ext_uv-%%PORTVERSION%%.so
+%%LIBUV%%lib/libgetdns_ext_uv-%%PORTVERSION%%.so.0
+%%LIBUV%%lib/libgetdns_ext_uv.a
+%%LIBUV%%lib/libgetdns_ext_uv.la
+%%LIBUV%%lib/libgetdns_ext_uv.so
+man/man3/getdns_address.3.gz
+man/man3/getdns_address_sync.3.gz
+man/man3/getdns_cancel_callback.3.gz
+man/man3/getdns_context.3.gz
+man/man3/getdns_context_create.3.gz
+man/man3/getdns_context_create_with_extended_memory_functions.3.gz
+man/man3/getdns_context_create_with_memory_functions.3.gz
+man/man3/getdns_context_destroy.3.gz
+man/man3/getdns_context_set.3.gz
+man/man3/getdns_context_set_append_name.3.gz
+man/man3/getdns_context_set_context_update_callback.3.gz
+man/man3/getdns_context_set_dns_root_servers.3.gz
+man/man3/getdns_context_set_dns_transport.3.gz
+man/man3/getdns_context_set_follow_redirects.3.gz
+man/man3/getdns_context_set_limit_outstanding_queries.3.gz
+man/man3/getdns_context_set_namespaces.3.gz
+man/man3/getdns_context_set_resolution_type.3.gz
+man/man3/getdns_context_set_timeout.3.gz
+man/man3/getdns_convert.3.gz
+man/man3/getdns_convert_dns_name_to_fqdn.3.gz
+man/man3/getdns_convert_fqdn_to_dns_name.3.gz
+man/man3/getdns_dict.3.gz
+man/man3/getdns_dict_create.3.gz
+man/man3/getdns_dict_destroy.3.gz
+man/man3/getdns_dict_get.3.gz
+man/man3/getdns_dict_get_bindata.3.gz
+man/man3/getdns_dict_get_data_type.3.gz
+man/man3/getdns_dict_get_dict.3.gz
+man/man3/getdns_dict_get_int.3.gz
+man/man3/getdns_dict_get_list.3.gz
+man/man3/getdns_dict_get_names.3.gz
+man/man3/getdns_dict_set.3.gz
+man/man3/getdns_dict_set_bindata.3.gz
+man/man3/getdns_dict_set_dict.3.gz
+man/man3/getdns_dict_set_int.3.gz
+man/man3/getdns_dict_set_list.3.gz
+man/man3/getdns_free_sync_request_memory.3.gz
+man/man3/getdns_general.3.gz
+man/man3/getdns_general_sync.3.gz
+man/man3/getdns_hostname.3.gz
+man/man3/getdns_hostname_sync.3.gz
+man/man3/getdns_list.3.gz
+man/man3/getdns_list_create.3.gz
+man/man3/getdns_list_destroy.3.gz
+man/man3/getdns_list_get.3.gz
+man/man3/getdns_list_get_bindata.3.gz
+man/man3/getdns_list_get_data_type.3.gz
+man/man3/getdns_list_get_dict.3.gz
+man/man3/getdns_list_get_int.3.gz
+man/man3/getdns_list_get_length.3.gz
+man/man3/getdns_list_get_list.3.gz
+man/man3/getdns_list_set.3.gz
+man/man3/getdns_list_set_bindata.3.gz
+man/man3/getdns_list_set_dict.3.gz
+man/man3/getdns_list_set_int.3.gz
+man/man3/getdns_list_set_list.3.gz
+man/man3/getdns_service.3.gz
+man/man3/getdns_service_sync.3.gz
+man/man3/libgetdns.3.gz
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-all-functions.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-reverse.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-simple-answers.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-synchronous.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example-tree.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getdns.tgz
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getdns_core_only.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getdns_core_only.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/getdns_libevent.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/make-examples-linux.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/make-examples-mac.sh
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+@dirrm include/getdns