aboutsummaryrefslogtreecommitdiff
path: root/dns/gresolver/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-06-03 17:52:00 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-06-03 17:52:00 +0000
commit4409c583aebc1a1b4a5562e7207eebe0bd93b5b2 (patch)
treef4c5a0457820dee593c62a213974e4745d338b05 /dns/gresolver/Makefile
parentcec5e782823220fef259545727c700253ab898be (diff)
downloadports-4409c583aebc1a1b4a5562e7207eebe0bd93b5b2.tar.gz
ports-4409c583aebc1a1b4a5562e7207eebe0bd93b5b2.zip
Notes
Diffstat (limited to 'dns/gresolver/Makefile')
-rw-r--r--dns/gresolver/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/dns/gresolver/Makefile b/dns/gresolver/Makefile
index 80d4a647d386..d4ed64988871 100644
--- a/dns/gresolver/Makefile
+++ b/dns/gresolver/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gresolver
-PORTVERSION= 0.0.4
-PORTREVISION= 1
+PORTVERSION= 0.0.5
CATEGORIES= dns
MASTER_SITES= http://jodrell.net/files/gresolver/
@@ -21,6 +20,20 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Lo
USE_X_PREFIX= yes
+.include <bsd.port.pre.mk>
+
+# The Perl script uses GtkFileChooser widgets, which need libpthread
+# through /usr/X11R6/lib/gtk-2.0/2.4.0/filesystems/libgnome-vfs.so.
+# Unfortunately, on FreeBSD, if an application uses a library which
+# uses libpthread, the application itself must link against
+# libpthread. This is why a threaded Perl is required.
+
+HAVE_THREADS!= ${PERL} -mthreads -e '' >/dev/null 2>&1 && ${ECHO_CMD} 'yes' || true
+
+.if empty(HAVE_THREADS)
+IGNORE= needs a threaded Perl, install lang/perl5.8 with threads support and try again
+.endif
+
do-build:
@${SED} -e 's|@PREFIX@|${PREFIX}|' ${WRKSRC}/gresolver.pl > ${WRKSRC}/gresolver
@@ -33,4 +46,4 @@ do-install:
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/gresolver.glade ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>