aboutsummaryrefslogtreecommitdiff
path: root/dns/inadyn-mt
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-03-21 20:38:15 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2013-03-21 20:38:15 +0000
commit35362f0b9ebd1dba51c4387db3163a017aaae95d (patch)
treeec800ddf3e8eeb8a021ec53c98eda9b3f062713e /dns/inadyn-mt
parentcce8c17eb3e6a8a7f61461d4b03a16d67cfd0adb (diff)
downloadports-35362f0b9ebd1dba51c4387db3163a017aaae95d.tar.gz
ports-35362f0b9ebd1dba51c4387db3163a017aaae95d.zip
inadyn, inadyn-advanced fork. A multi-OS (*NIX, BSD, NT, 32 bit Win)
console/service/daemon dynamic DNS client. It gives the possibility to have your own fixed hostname registered on the internet, although your IP might be changing. It checks periodically whether the IP address stored by the DNS server is the real current IP address of the machine that is running it. WWW: http://sourceforge.net/projects/inadyn-mt/ PR: ports/177149 Submitted by: William Grzybowski <william88@gmail.com>
Notes
Notes: svn path=/head/; revision=314870
Diffstat (limited to 'dns/inadyn-mt')
-rw-r--r--dns/inadyn-mt/Makefile44
-rw-r--r--dns/inadyn-mt/distinfo2
-rw-r--r--dns/inadyn-mt/files/inadyn-mt.in24
-rw-r--r--dns/inadyn-mt/files/patch-dyndns.h19
-rw-r--r--dns/inadyn-mt/files/patch-readme.html78
-rw-r--r--dns/inadyn-mt/pkg-descr9
6 files changed, 176 insertions, 0 deletions
diff --git a/dns/inadyn-mt/Makefile b/dns/inadyn-mt/Makefile
new file mode 100644
index 000000000000..15d27419e1fe
--- /dev/null
+++ b/dns/inadyn-mt/Makefile
@@ -0,0 +1,44 @@
+# Created by: William Grzybowski <william88@gmail.com>
+# $FreeBSD$
+
+PORTNAME= inadyn-mt
+PORTVERSION= 02.24.38
+CATEGORIES= dns
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}.v.${PORTVERSION}/
+DISTNAME= ${PORTNAME}.v.${PORTVERSION}
+
+MAINTAINER= william88@gmail.com
+COMMENT= Simple dynamic dns client
+
+USE_RC_SUBR= inadyn-mt
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --disable-sound
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN8= inadyn-mt.8
+MAN5= inadyn-mt.conf.5
+.endif
+
+PORTDOCS= readme.html
+PLIST_FILES= bin/inadyn-mt
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" \
+ ${WRKSRC}/man/inadyn-mt.8 ${WRKSRC}/readme.html \
+ ${WRKSRC}/src/dyndns.h
+
+.include <bsd.port.options.mk>
+
+do-install:
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} -p ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/freebsd/inadyn-mt ${PREFIX}/bin
+.if !defined(NO_INSTALL_MANPAGES)
+ ${INSTALL_MAN} ${WRKSRC}/man/inadyn-mt.8 ${MANPREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/man/inadyn-mt.conf.5 ${MANPREFIX}/man/man5
+.endif
+
+.include <bsd.port.mk>
diff --git a/dns/inadyn-mt/distinfo b/dns/inadyn-mt/distinfo
new file mode 100644
index 000000000000..9c471fad90f3
--- /dev/null
+++ b/dns/inadyn-mt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (inadyn-mt.v.02.24.38.tar.gz) = 3a1028218e395cfda981fd912d2c097d3433037e62ca0594ea0f3bdf2b7bf0a4
+SIZE (inadyn-mt.v.02.24.38.tar.gz) = 991330
diff --git a/dns/inadyn-mt/files/inadyn-mt.in b/dns/inadyn-mt/files/inadyn-mt.in
new file mode 100644
index 000000000000..521313dcec16
--- /dev/null
+++ b/dns/inadyn-mt/files/inadyn-mt.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# PROVIDE: inadynmt
+# REQUIRE: NETWORKING
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# inadynmt_enable="YES"
+#
+
+. /etc/rc.subr
+
+name="inadynmt"
+rcvar=inadynmt_enable
+
+command=%%PREFIX%%/bin/inadyn-mt
+
+load_rc_config $name
+
+: ${inadynmt_enable="NO"}
+
+run_rc_command "$1"
diff --git a/dns/inadyn-mt/files/patch-dyndns.h b/dns/inadyn-mt/files/patch-dyndns.h
new file mode 100644
index 000000000000..42e05cea2047
--- /dev/null
+++ b/dns/inadyn-mt/files/patch-dyndns.h
@@ -0,0 +1,19 @@
+diff --git src/dyndns.h src/dyndns.h
+index ed854c1..7513275 100644
+--- src/dyndns.h
++++ src/dyndns.h
+@@ -106,11 +106,11 @@ typedef enum
+
+ /*test values*/
+ #define DYNDNS_DEFAULT_DEBUG_LEVEL LOG_WARNING
+-#define DYNDNS_MT_DEFAULT_CONFIG_FILE_OLD "/etc/inadyn-mt/inadyn-mt.conf"
+-#define DYNDNS_MT_DEFAULT_CONFIG_FILE "/etc/inadyn-mt.conf"
++#define DYNDNS_MT_DEFAULT_CONFIG_FILE_OLD "%%PREFIX%%/etc/inadyn-mt/inadyn-mt.conf"
++#define DYNDNS_MT_DEFAULT_CONFIG_FILE "%%PREFIX%%/etc/inadyn-mt.conf"
+
+ /*inadyn backward compatibility*/
+-#define DYNDNS_DEFAULT_CONFIG_FILE "/etc/inadyn.conf"
++#define DYNDNS_DEFAULT_CONFIG_FILE "%%PREFIX%%/etc/inadyn.conf"
+
+ #define DYNDNS_DEFAULT_CACHE_PREFIX "/tmp/"
+ #define DYNDNS_DEFAULT_IP_FILE "inadyn_ip.cache"
diff --git a/dns/inadyn-mt/files/patch-readme.html b/dns/inadyn-mt/files/patch-readme.html
new file mode 100644
index 000000000000..b2ffa8f57fa2
--- /dev/null
+++ b/dns/inadyn-mt/files/patch-readme.html
@@ -0,0 +1,78 @@
+diff --git readme.html readme.html
+index fc3d3d2..54553ee 100644
+--- readme.html
++++ readme.html
+@@ -285,7 +285,7 @@ update request, i.e., both ip address types may be sent in a comma delimited lis
+ </p>
+ <p style="margin-left: 20px;">'--input_file &#60;path/file&#62;': input file name that
+ contains inadyn-mt command options (adds to those already present in the cmd line).
+-The default configuration file name is '/etc/inadyn-mt.conf'. It is only
++The default configuration file name is '%%PREFIX%%/etc/inadyn-mt.conf'. It is only
+ used if inadyn-mt is called without any command line options. This allows
+ inadyn-mt to be called without any arguments. The format is as expected
+ for a **NIX config&nbsp; file. See below for details.<br>
+@@ -345,7 +345,7 @@ DEFAULT value is intended for default service at dyndns.org: dyndns@dyndns.org<b
+ '--retry_interval &#60;#&#62;': network comm miliseconds retry interval. 0 to 30,000, default 1,000.<br>
+ '--retry_pending': retry ip update even after network comm retries exhausted, default on.<br>
+ '--retry_pending_interval &#60;#&#62;': network comm seconds update retry interval, after retries exhausted, 5 to 3600, default 300.<br>
+-'--lang_file &#60;path/file&#62;': [language file path, and file name]. defaults to either ../inadyn-mt/lang/en.lng, or /etc/inadyn-mt/en.lng. No parameter option gives hard coded defaults<br>
++'--lang_file &#60;path/file&#62;': [language file path, and file name]. defaults to either ../inadyn-mt/lang/en.lng, or %%PREFIX%%/etc/inadyn-mt/en.lng. No parameter option gives hard coded defaults<br>
+ '--online_check_url &#60;srv_name[:port] url&#62;': server name, optional port, and url to reach to confirm online status.<br>
+ '--status_interval &#60;#&#62;': seconds [30..864000] interval at which to check online status, default 600.<br>
+ '--alert_retries &#60;#&#62;': network retries before audible network status alerts. [0..100], default 0.<br>
+@@ -377,7 +377,7 @@ DEFAULT value is intended for default service at dyndns.org: dyndns@dyndns.org<b
+
+ 3. Update every minute, in daemon mode, with configuration read from file of an address from freedns.afraid.org <br>
+
+- Config file (can be placed anywhere, but in linux is convenient in default location: /etc/inadyn-mt.conf<br>
++ Config file (can be placed anywhere, but in linux is convenient in default location: %%PREFIX%%/etc/inadyn-mt.conf<br>
+ Content of cfg file:<br>
+
+ --update_period 60000 <br>
+@@ -385,7 +385,7 @@ DEFAULT value is intended for default service at dyndns.org: dyndns@dyndns.org<b
+ --log_file /var/log/inadyn.log <br>
+ --change_persona 10012 #to change to another user id after init. (less rights, more secure)
+ <br>
+- Launching of inadyn-mt does not need any params. It looks for /etc/inadyn.config
++ Launching of inadyn-mt does not need any params. It looks for %%PREFIX%%/etc/inadyn.config
+ <br>
+ <br>
+ 4. Freedns update in console <br>
+@@ -396,7 +396,7 @@ DEFAULT value is intended for default service at dyndns.org: dyndns@dyndns.org<b
+ inadyn-mt can read the very same options which can be present in the
+ command line from a configuration file. This feature allows the user to
+ write the options only once, and avoids frequent retyping.<br>
+-<i>Default configuration file</i> is /etc/inadyn.conf under Unix systems. <br>
++<i>Default configuration file</i> is %%PREFIX%%/etc/inadyn.conf under Unix systems. <br>
+ The location of the config file can be given to inadyn-mt via --input_file option <br><br>
+ <i>The format</i> :<br>
+ - '#' is a comment sign. <br>
+@@ -766,7 +766,7 @@ Ver.&nbsp; inadyn-mt 2.18.28 - June 2010<br>
+ Ver.&nbsp; inadyn-mt 2.18.26 - June 2010<br>
+ &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; Changes:<br>
+ &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - inadyn man files updated to inadyn-mt<br>
+-&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - *nix inadyn-mt.conf moved to /etc<br>
++&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - *nix inadyn-mt.conf moved to %%PREFIX%%/etc<br>
+ &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - added debian dpkg-buildpackage directory, et al<br>
+ &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - moved *nix meta files to /usr/share<br><br>
+
+@@ -776,7 +776,7 @@ Ver.&nbsp; inadyn-mt 2.18.24 - May 2010<br>
+
+ Ver.&nbsp; inadyn-mt 2.18.22 - May 2010<br>
+ &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; Changes:<br>
+-&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - *nix meta files search root /etc, /usr/share, /usr/local/etc<br>
++&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - *nix meta files search root %%PREFIX%%/etc, /usr/share, /usr/local/etc<br>
+ &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - too many params compiler warning fixed<br><br>
+
+ Ver.&nbsp; inadyn-mt 2.18.20 - May 2010<br>
+@@ -1073,8 +1073,8 @@ Ver.&nbsp; inadyn-mt 2.12.02 - May 2008<br>
+ inadyn-mt<br>
+ &nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - updated inadyn-mt man files' original inadyn homepage
+ to http://www.inatech.eu/inadyn/<br>
+-&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - changed default config file from /etc/inadyn.conf to
+-/etc/inadyn-mt/inadyn-mt.conf<br><br>
++&nbsp;&nbsp;&nbsp; &nbsp;&nbsp; - changed default config file from %%PREFIX%%/etc/inadyn.conf to
++%%PREFIX%%/etc/inadyn-mt/inadyn-mt.conf<br><br>
+
+ Ver.&nbsp; inadyn-mt 2.12.01 - May 2008<br>
+ &nbsp;&nbsp;&nbsp; Changes:<br>
diff --git a/dns/inadyn-mt/pkg-descr b/dns/inadyn-mt/pkg-descr
new file mode 100644
index 000000000000..11f9b2d8a693
--- /dev/null
+++ b/dns/inadyn-mt/pkg-descr
@@ -0,0 +1,9 @@
+inadyn, inadyn-advanced fork. A multi-OS (*NIX, BSD, NT, 32 bit Win)
+console/service/daemon dynamic DNS client.
+
+It gives the possibility to have your own fixed hostname registered on the
+internet, although your IP might be changing. It checks periodically whether
+the IP address stored by the DNS server is the real current IP address of the
+machine that is running it.
+
+WWW: http://sourceforge.net/projects/inadyn-mt/