aboutsummaryrefslogtreecommitdiff
path: root/dns/knot2/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-03-05 20:08:57 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-03-05 20:08:57 +0000
commit683a9e3760b973dea83bab298e43f178cd76f50a (patch)
treef4448924a83b85162d021fcb3e6bb8992bc15908 /dns/knot2/Makefile
parentc7cf35497d0499373cf8066f7b4deba3c0fef519 (diff)
downloadports-683a9e3760b973dea83bab298e43f178cd76f50a.tar.gz
ports-683a9e3760b973dea83bab298e43f178cd76f50a.zip
Notes
Diffstat (limited to 'dns/knot2/Makefile')
-rw-r--r--dns/knot2/Makefile33
1 files changed, 23 insertions, 10 deletions
diff --git a/dns/knot2/Makefile b/dns/knot2/Makefile
index c15b32d13dd5..249d801fe462 100644
--- a/dns/knot2/Makefile
+++ b/dns/knot2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= knot
-DISTVERSION= 2.9.1
+DISTVERSION= 2.9.3
CATEGORIES= dns
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
https://dns.company/downloads/knot-dns/
@@ -12,26 +12,29 @@ MAINTAINER= freebsd@dns.company
COMMENT?= High performance authoritative-only DNS server
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
-NOT_FOR_ARCHS= i386
-NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386
+CONFLICTS= knot-1.* knot1-[0-6].*
+
+BUILD_DEPENDS= autoconf>=2.65:devel/autoconf
LIB_DEPENDS= libgnutls.so:security/gnutls \
- liblmdb.so:databases/lmdb \
- liburcu.so:sysutils/liburcu
+ liblmdb.so:databases/lmdb
-CONFLICTS= knot-1.* knot1-[0-6].*
+USES= alias libtool localbase pkgconfig tar:xz
-USES= alias compiler:c11 libedit libtool localbase ncurses pkgconfig python tar:xz
-GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_ARGS= --enable-recvmmsg=no \
- --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
+ --mandir=${MANPREFIX}/man
.if !defined(UTILS_ONLY) && !defined(LIB_ONLY)
CONFIGURE_ARGS+= --with-rundir=/var/run/knot \
--with-storage=/var/db/knot
USE_RC_SUBR= ${PORTNAME}
SUB_FILES= pkg-message
+USES+= libedit
+LIB_DEPENDS+= liburcu.so:sysutils/liburcu
.endif
.if defined(UTILS_ONLY) || defined(LIB_ONLY)
@@ -44,7 +47,6 @@ CONFIGURE_ARGS+= --disable-utilities
.endif
USE_LDCONFIG= yes
-LLD_UNSAFE= yes
INSTALL_TARGET= install-strip
USERS= knot
@@ -75,16 +77,27 @@ DNSTAP_LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c \
# in higher line count. Ideally this bug should be fixed upstream.
DNSTAP_CPPFLAGS= -I${LOCALBASE}/include
+DOCS_USES+= python
+DOCS_CONFIGURE_OFF= --disable-documentation
+
FASTPARSER_DESC= Fast zone parser (demanding compilation)
FASTPARSER_CONFIGURE_ENABLE= fastparser
IDN_CONFIGURE_WITH= libidn
+IDN_CONFIGURE_OFF= --without-libidn
IDN_LIB_DEPENDS= libidn2.so:dns/libidn2
MAXMINDDB_DESC= Enable MaxMind for geodb module
MAXMINDDB_LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
MAXMINDDB_CONFIGURE_ENABLE= maxminddb
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == i386
+USES+= autoreconf
+EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-configure.ac
+.endif
+
post-patch:
.if !defined(UTILS_ONLY) && !defined(LIB_ONLY)
@${REINPLACE_CMD} 's|$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|#$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|' \