aboutsummaryrefslogtreecommitdiff
path: root/dns/knot
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-02-18 12:39:42 +0000
committerMark Felder <feld@FreeBSD.org>2014-02-18 12:39:42 +0000
commit5445cec046409fa7c0170177ddce30e7c780fdc0 (patch)
tree63ee533062204ebc30fa835a7f38bb0e03f1c6f9 /dns/knot
parent79113a51e4051d501ce7bdd068d5ab06a47129b2 (diff)
downloadports-5445cec046409fa7c0170177ddce30e7c780fdc0.tar.gz
ports-5445cec046409fa7c0170177ddce30e7c780fdc0.zip
Notes
Diffstat (limited to 'dns/knot')
-rw-r--r--dns/knot/Makefile2
-rw-r--r--dns/knot/files/knot.in12
2 files changed, 10 insertions, 4 deletions
diff --git a/dns/knot/Makefile b/dns/knot/Makefile
index 01d6313fbcca..bd23bf261398 100644
--- a/dns/knot/Makefile
+++ b/dns/knot/Makefile
@@ -3,7 +3,7 @@
PORTNAME= knot
DISTVERSION= 1.4.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
http://dns-lab.com/downloads/knot-dns/
diff --git a/dns/knot/files/knot.in b/dns/knot/files/knot.in
index 20a17cfec69f..3ea4219a11af 100644
--- a/dns/knot/files/knot.in
+++ b/dns/knot/files/knot.in
@@ -34,7 +34,8 @@ extra_commands=reload
reload_cmd="${name}_reload"
start_precmd="${name}_prestart"
-knot_prestart() {
+knot_prestart()
+{
if [ ! -d /var/run/knot ]; then
install -d -o %%USERS%% -g %%GROUPS%% /var/run/knot
fi
@@ -46,7 +47,12 @@ knot_prestart() {
echo "Notice: not running as uid.gid knot.knot or bind.bind"
fi
${control} -c ${knot_config} checkconf
- }
+}
-knot_reload() {
+knot_reload()
+{
echo "Reloading ${name}."
+ ${control} -c ${knot_config} reload
+}
+
+run_rc_command "$1"