aboutsummaryrefslogtreecommitdiff
path: root/dns/libasr/Makefile
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2015-02-07 15:54:26 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2015-02-07 15:54:26 +0000
commit817317c0cf2947466439810b02cb3b53622ac66e (patch)
tree7193638e19b7a7046fc4e3d341f8729befac1b66 /dns/libasr/Makefile
parent5d4c196112397aea179c2f0cc7853e5045620c59 (diff)
Notes
Diffstat (limited to 'dns/libasr/Makefile')
-rw-r--r--dns/libasr/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/dns/libasr/Makefile b/dns/libasr/Makefile
new file mode 100644
index 000000000000..45bf89f367f6
--- /dev/null
+++ b/dns/libasr/Makefile
@@ -0,0 +1,24 @@
+# Created by: Ashish SHUKLA <ashish@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libasr
+PORTVERSION= 1.0.1
+CATEGORIES= dns
+MASTER_SITES= http://www.opensmtpd.org/archives/ \
+ http://distfiles.pirateparty.in/ashish/
+
+MAINTAINER= ashish@FreeBSD.org
+COMMENT= Asynchronous DNS resolver library
+
+LICENSE= ISCL BSD4CLAUSE BSD3CLAUSE BSD2CLAUSE
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENCE
+
+CONFLICTS= libasr-devel-[0-9]*
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>