aboutsummaryrefslogtreecommitdiff
path: root/dns/mydns-ng
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-31 18:34:18 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-05-31 18:34:18 +0000
commit44f665c2af44c552dbb12728c7d6762e8863b391 (patch)
treea157fca880d58f2d0ad0d725866a61e5c7207dbc /dns/mydns-ng
parent6c9268bd82def01f6471ed67c6722a9d4faa9d03 (diff)
downloadports-44f665c2af44c552dbb12728c7d6762e8863b391.tar.gz
ports-44f665c2af44c552dbb12728c7d6762e8863b391.zip
Notes
Diffstat (limited to 'dns/mydns-ng')
-rw-r--r--dns/mydns-ng/Makefile3
-rw-r--r--dns/mydns-ng/files/patch-contrib_admin.php58
-rw-r--r--dns/mydns-ng/files/pkg-message.in6
3 files changed, 63 insertions, 4 deletions
diff --git a/dns/mydns-ng/Makefile b/dns/mydns-ng/Makefile
index d20d03dee3a4..c0cced8fd60a 100644
--- a/dns/mydns-ng/Makefile
+++ b/dns/mydns-ng/Makefile
@@ -6,6 +6,7 @@
#
PORTNAME= mydns-ng
+PORTREVISION= 1
PORTVERSION= 1.2.8.27
CATEGORIES= dns databases
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -63,7 +64,7 @@ PKGNAMESUFFIX= -mysql
USE_MYSQL= yes
.endif
-.if defined(WITHOUT_NLS)
+.if !defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--with-included-gettext
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
diff --git a/dns/mydns-ng/files/patch-contrib_admin.php b/dns/mydns-ng/files/patch-contrib_admin.php
new file mode 100644
index 000000000000..b5dceb24994f
--- /dev/null
+++ b/dns/mydns-ng/files/patch-contrib_admin.php
@@ -0,0 +1,58 @@
+--- contrib/admin.php.orig 2009-01-30 12:21:32.000000000 +0000
++++ contrib/admin.php 2009-05-27 03:13:57.000000000 +0000
+@@ -85,6 +85,15 @@
+ */
+ $auto_update_ptr = 0;
+
++/*
++** This can automatically insert the defaults w/o updating the serial
++** number automatically. Sometimes you want to change entries but not
++** have the nameserver reload and start serving out new data.
++** -bek@monsterous.com
++*/
++
++$auto_defaults = 1;
++
+
+ /*
+ ** If this option is nonzero, this script will not complain if the
+@@ -2052,7 +2061,7 @@
+ global $soa_use_active, $soa_use_recursive, $soa_use_xfer, $soa_use_update_acl, $soa_use_also_notify;
+ global $rr_table_name, $soa_active_types, $soa_recursive_types;
+ global $default_refresh, $default_retry, $default_expire, $default_minimum_ttl, $default_ttl;
+- global $default_ns, $default_mbox;
++ global $default_ns, $default_mbox, $auto_defaults;
+ global $soa_bgcolor, $zonenotify;
+
+ $delete_confirm = 0;
+@@ -2112,6 +2121,18 @@
+ } else
+ $soa = $values = $_POST;
+ $new_soa = 1;
++
++ if ($auto_defaults == 1) {
++ $soa['serial'] = date("Ymd01", time());
++ $soa['refresh'] = $default_refresh;
++ $soa['retry'] = $default_retry;
++ $soa['expire'] = $default_expire;
++ $soa['minimum'] = $default_minimum_ttl;
++ $soa['ttl'] = $default_ttl;
++ $soa['ns'] = trim($default_ns);
++ $soa['mbox'] = trim($default_mbox);
++ $values = $soa;
++ }
+ }
+
+ /* Set 'values' vars to avoid 'undefined' errors */
+@@ -2166,8 +2187,9 @@
+ <TR title="The serial number for this zone.">
+ <TD class="soaFields"><INPUT class=mono type=text name="serial" value="<?php echo ent($values['serial'])?>" size=20>
+ <TD>&nbsp;
+- <TD nowrap><TT>; <B>Serial</B> (next is <?php echo next_serial(isset($soa['serial']) ? $soa['serial'] : '');?>)</TT>
+- <TD>&nbsp;
++ <TD nowrap><TT>; <B>Serial</B> (next is <?=next_serial(isset($soa['serial']) ? $soa['serial'] : '');?>)</TT>
++ <TD><input name="updateserial" class=formButton style="border-color: #FFFF99; color: #FFFF99;" type="button" value="Update Serial"onclick="javascript:document.soaform.serial.value
++ =<?=next_serial(isset($soa['serial']) ? $soa['serial'] : '');?>">&nbsp;
+
+ <TR title="The number of seconds slave nameservers will wait before updating their zone data for this zone.">
+ <TD class=soaFields><INPUT class=mono type=text name="refresh" value="<?php echo ent($values['refresh'])?>" size=10>
diff --git a/dns/mydns-ng/files/pkg-message.in b/dns/mydns-ng/files/pkg-message.in
index 4ba122025ba3..fe7528998be5 100644
--- a/dns/mydns-ng/files/pkg-message.in
+++ b/dns/mydns-ng/files/pkg-message.in
@@ -12,10 +12,10 @@ as a template. Finally enable MyDNS by adding
into your rc.conf.
-You can use %%PORTDOCS%%%%DOCSDIR%%/contrib/admin.php to maintain MyDNS.
+You can use %%DOCSDIR%%/contrib/admin.php to maintain MyDNS.
If you are looking for the web interface for MyDNS, it's included in
-the MyDNS distribution as %%PORTDOCS%%%%DOCSDIR%%/contrib/admin.php.
-See %%PORTDOCS%%%%DOCSDIR%%/contrib/README for installation instructions.
+the MyDNS distribution as %%DOCSDIR%%/contrib/admin.php.
+See %%DOCSDIR%%/contrib/README for installation instructions.
*********************************************************************