aboutsummaryrefslogtreecommitdiff
path: root/dns/mydns/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-08-05 23:35:09 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-08-05 23:35:09 +0000
commit58143feaad2a780814ff3b726514885217b17146 (patch)
tree15db8da0216076886d78bee6c0b4a1f2d8473834 /dns/mydns/Makefile
parent394cf0d6b0cd52626d7f4707d148103bf1796a7e (diff)
downloadports-58143feaad2a780814ff3b726514885217b17146.tar.gz
ports-58143feaad2a780814ff3b726514885217b17146.zip
Notes
Diffstat (limited to 'dns/mydns/Makefile')
-rw-r--r--dns/mydns/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/dns/mydns/Makefile b/dns/mydns/Makefile
new file mode 100644
index 000000000000..b2c78dda31a7
--- /dev/null
+++ b/dns/mydns/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: mydns
+# Date created: 23 July 2002
+# Whom: Simon Dick <simond@irrelevant.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mydns
+PORTVERSION= 0.8.2
+CATEGORIES= net databases
+MASTER_SITES= http://mydns.bboy.net/download/
+
+MAINTAINER= simond@irrelevant.org
+
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-confdir=${PREFIX}/etc --without-libiconv-prefix
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+MAN5= mydns.conf.5
+MAN8= mydns.8
+
+DOCS= AUTHORS COPYING ChangeLog NEWS QUICKSTART README TODO
+
+.include <bsd.port.pre.mk>
+
+.if !defined(NOPORTDOCS)
+USE_PERL5= yes
+.else
+pre-configure:
+ @${REINPLACE_CMD} -E -e "s|^(all: vars manpages info) html-doc|\1|" \
+ ${WRKSRC}/doc/Makefile.in
+.endif
+
+post-install:
+ @${SED} 's|%%%PREFIX%%%|${PREFIX}|g' < ${FILESDIR}/mydns.sh > ${WRKSRC}/mydns.sh
+ @${INSTALL_SCRIPT} ${WRKSRC}/mydns.sh ${PREFIX}/etc/rc.d/mydns.sh.sample
+ @install-info ${PREFIX}/info/mydns.info ${PREFIX}/info/dir
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}/html ${DOCSDIR}/extras
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}/html/
+ @${INSTALL_DATA} ${WRKSRC}/extras/admin.php ${DOCSDIR}/extras/
+ @${INSTALL_DATA} ${WRKSRC}/extras/README ${DOCSDIR}/extras/
+.endif
+ @${PREFIX}/sbin/mydns --dump-config >${PREFIX}/etc/mydns.conf.sample
+ @${SED} -e 's,%%%PREFIX%%%,${PREFIX},g' ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>