aboutsummaryrefslogtreecommitdiff
path: root/dns/mydns
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-04 10:01:09 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-04 10:01:09 +0000
commit6274f94c637dcaec119f36c61aa16c817fe87981 (patch)
tree2de604e136afbb80853324910e1ad92cefd8d6de /dns/mydns
parenta718b5157bfd3bea7c6f85e5145d126c6be95b2f (diff)
downloadports-6274f94c637dcaec119f36c61aa16c817fe87981.tar.gz
ports-6274f94c637dcaec119f36c61aa16c817fe87981.zip
- Fix a bug with incorrect config parsing until the next
version comes out - Bump PORTREVISION PR: 59749 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=94918
Diffstat (limited to 'dns/mydns')
-rw-r--r--dns/mydns/Makefile2
-rw-r--r--dns/mydns/files/patch-src::mydns::conf.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/dns/mydns/Makefile b/dns/mydns/Makefile
index f41734c69ba7..538a9eeb493a 100644
--- a/dns/mydns/Makefile
+++ b/dns/mydns/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mydns
PORTVERSION= 0.10.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= dns databases
MASTER_SITES= http://mydns.bboy.net/download/
diff --git a/dns/mydns/files/patch-src::mydns::conf.c b/dns/mydns/files/patch-src::mydns::conf.c
new file mode 100644
index 000000000000..797c70c7805d
--- /dev/null
+++ b/dns/mydns/files/patch-src::mydns::conf.c
@@ -0,0 +1,11 @@
+--- src/mydns/conf.c.orig Fri Nov 28 12:04:45 2003
++++ src/mydns/conf.c Fri Nov 28 12:04:58 2003
+@@ -351,7 +351,7 @@
+
+ /* Set additional where clauses if provided */
+ mydns_set_soa_where_clause(conf_get(&Conf, "soa-where", NULL));
+- mydns_set_rr_where_clause(conf_get(&Conf, "soa-where", NULL));
++ mydns_set_rr_where_clause(conf_get(&Conf, "rr-where", NULL));
+ }
+ /*--- load_config() -----------------------------------------------------------------------------*/
+