aboutsummaryrefslogtreecommitdiff
path: root/dns/namesilo_ddns
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2018-08-06 22:13:45 +0000
committerChris Rees <crees@FreeBSD.org>2018-08-06 22:13:45 +0000
commit23f8f2302df71aba955c4b4dfea34d255e135c05 (patch)
treeaac239d33df78ad82f378223037171cc9349bce3 /dns/namesilo_ddns
parent837fbe31535a1142fd000677929935ece2f864fe (diff)
downloadports-23f8f2302df71aba955c4b4dfea34d255e135c05.tar.gz
ports-23f8f2302df71aba955c4b4dfea34d255e135c05.zip
Notes
Diffstat (limited to 'dns/namesilo_ddns')
-rw-r--r--dns/namesilo_ddns/Makefile29
-rw-r--r--dns/namesilo_ddns/distinfo3
-rw-r--r--dns/namesilo_ddns/pkg-descr6
3 files changed, 38 insertions, 0 deletions
diff --git a/dns/namesilo_ddns/Makefile b/dns/namesilo_ddns/Makefile
new file mode 100644
index 000000000000..4a855cd6f90c
--- /dev/null
+++ b/dns/namesilo_ddns/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= namesilo_ddns
+PORTVERSION= 2.0
+DISTVERSIONPREFIX=v
+CATEGORIES= dns net
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Updates DNS records with Namesilo for dynamic IP addresses
+
+LICENSE= MIT
+
+RUN_DEPENDS= curl:ftp/curl \
+ xmllint:textproc/libxml2
+
+USE_GITHUB= yes
+GH_ACCOUNT= crees
+
+NO_BUILD= yes
+
+PLIST_FILES= sbin/${PORTNAME} "@sample etc/${PORTNAME}.conf.sample"
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.sh \
+ ${STAGEDIR}${PREFIX}/sbin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample \
+ ${STAGEDIR}${PREFIX}/etc/
+
+.include <bsd.port.mk>
diff --git a/dns/namesilo_ddns/distinfo b/dns/namesilo_ddns/distinfo
new file mode 100644
index 000000000000..41c3fcb93d66
--- /dev/null
+++ b/dns/namesilo_ddns/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533592899
+SHA256 (crees-namesilo_ddns-v2.0_GH0.tar.gz) = c460d272250af293bc7bfe8e665f453b69a9a74317d1c02e62e6f8b6ad25dc2d
+SIZE (crees-namesilo_ddns-v2.0_GH0.tar.gz) = 3878
diff --git a/dns/namesilo_ddns/pkg-descr b/dns/namesilo_ddns/pkg-descr
new file mode 100644
index 000000000000..c34e230547ad
--- /dev/null
+++ b/dns/namesilo_ddns/pkg-descr
@@ -0,0 +1,6 @@
+Dynamic DNS record update with NameSilo.
+
+This is a shell script to update Namesilo's DNS record when IP changed.
+Set to run this script as cronjob in your system.
+
+WWW: https://github.com/crees/namesilo_ddns