aboutsummaryrefslogtreecommitdiff
path: root/dns/nsd
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-04-11 21:05:20 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-04-11 21:05:20 +0000
commitb1706ea03165377e2b8b5d0e047ea0c1ea9575c3 (patch)
tree4ce8cf1e0b7ae9919e1c4b12112751f6920526b5 /dns/nsd
parent017177e33bba578aeb35c69c2b22081cf88f5f6f (diff)
downloadports-b1706ea03165377e2b8b5d0e047ea0c1ea9575c3.tar.gz
ports-b1706ea03165377e2b8b5d0e047ea0c1ea9575c3.zip
Notes
Diffstat (limited to 'dns/nsd')
-rw-r--r--dns/nsd/Makefile1
-rw-r--r--dns/nsd/files/patch-aa19
-rw-r--r--dns/nsd/files/patch-ab20
3 files changed, 40 insertions, 0 deletions
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index 9c01aa999281..16db84d26fa7 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nsd
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/
diff --git a/dns/nsd/files/patch-aa b/dns/nsd/files/patch-aa
new file mode 100644
index 000000000000..b987f2a1529b
--- /dev/null
+++ b/dns/nsd/files/patch-aa
@@ -0,0 +1,19 @@
+--- nsd.c 17 Dec 2002 14:42:06 -0000 1.56.2.10
++++ nsd.c 12 Feb 2003 09:19:50 -0000
+@@ -159,6 +159,7 @@
+ signal(SIGINT, &sig_handler);
+ signal(SIGILL, &sig_handler);
+ signal(SIGALRM, &sig_handler);
++ signal(SIGPIPE, SIG_IGN);
+
+
+ /* Are we a tcp child? */
+@@ -566,6 +567,8 @@
+ signal(SIGINT, &sig_handler);
+ signal(SIGILL, &sig_handler);
+ signal(SIGALRM, &sig_handler);
++ signal(SIGPIPE, SIG_IGN);
++
+
+ /* Get our process id */
+ nsd.pid[0] = getpid();
diff --git a/dns/nsd/files/patch-ab b/dns/nsd/files/patch-ab
new file mode 100644
index 000000000000..12b595e4fc97
--- /dev/null
+++ b/dns/nsd/files/patch-ab
@@ -0,0 +1,20 @@
+diff -u -r1.83 query.c
+--- query.c 14 Oct 2002 13:12:16 -0000 1.83
++++ query.c 18 Feb 2003 10:46:11 -0000
+@@ -145,11 +145,13 @@
+
+ /* Truncate */
+ if(d && DOMAIN_FLAGS(d) & NAMEDB_DELEGATION) {
+- ANCOUNT(q) = NSCOUNT(q);
++ ANCOUNT(q) = htons(ntohs(NSCOUNT(q)) + ntohs(ARCOUNT(q)));
++ } else {
++ q->iobufptr = qptr + ANSWER_RRS(a, ntohs(ANCOUNT(q)));
+ }
+- NSCOUNT(q) = 0;
++
+ ARCOUNT(q) = 0;
+- q->iobufptr = qptr + ANSWER_RRS(a, ntohs(ANCOUNT(q)));
++ NSCOUNT(q) = 0;
+
+ /* More data... */
+ return 1;