aboutsummaryrefslogtreecommitdiff
path: root/dns/nsnotifyd
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2017-07-26 16:44:40 +0000
committerDan Langille <dvl@FreeBSD.org>2017-07-26 16:44:40 +0000
commit24c9bcde1ea1b7f5103786fd8ac9e6f5e67b7068 (patch)
tree0a49ae6511e6a7c29a4ff192e28b7067e292ffc7 /dns/nsnotifyd
parentda37bb5bd7c151b67b5f34e3b31ef48d017f112b (diff)
downloadports-24c9bcde1ea1b7f5103786fd8ac9e6f5e67b7068.tar.gz
ports-24c9bcde1ea1b7f5103786fd8ac9e6f5e67b7068.zip
Notes
Diffstat (limited to 'dns/nsnotifyd')
-rw-r--r--dns/nsnotifyd/Makefile40
-rw-r--r--dns/nsnotifyd/distinfo3
-rw-r--r--dns/nsnotifyd/pkg-descr7
-rw-r--r--dns/nsnotifyd/pkg-plist10
4 files changed, 60 insertions, 0 deletions
diff --git a/dns/nsnotifyd/Makefile b/dns/nsnotifyd/Makefile
new file mode 100644
index 000000000000..70c5be6ebf2c
--- /dev/null
+++ b/dns/nsnotifyd/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= nsnotifyd
+PORTVERSION= 1.6
+CATEGORIES= dns
+MASTER_SITES= http://dotat.at/prog/nsnotifyd/
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= Handle DNS NOTIFY messages by running a command
+
+LICENSE= CC0-1.0
+
+GNU_CONFIGURE= yes
+
+USES= shebangfix
+SHEBANG_FILES= nsnotify-liststealth
+
+EXEFILES= nsnotify nsnotifyd
+BINFILES= nsnotify-liststealth nsnotify2git nsnotify2stealth nsnotify2update
+MAN1FILES= metazone nsnotify nsnotifyd
+MAN5FILES= metazone
+
+do-install:
+.for bin in ${EXEFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${bin} ${STAGEDIR}${PREFIX}/bin
+.endfor
+
+.for bin in ${BINFILES}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${bin} ${STAGEDIR}${PREFIX}/bin
+.endfor
+
+.for man in ${MAN1FILES}
+ ${INSTALL_MAN} ${WRKSRC}/${man}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+.endfor
+
+.for man in ${MAN5FILES}
+ ${INSTALL_MAN} ${WRKSRC}/${man}.5 ${STAGEDIR}${MAN1PREFIX}/man/man5
+.endfor
+
+.include <bsd.port.mk>
diff --git a/dns/nsnotifyd/distinfo b/dns/nsnotifyd/distinfo
new file mode 100644
index 000000000000..7600f165d239
--- /dev/null
+++ b/dns/nsnotifyd/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501085119
+SHA256 (nsnotifyd-1.6.tar.gz) = 4a7f53425ba508dcc1a6609dc2f26e7fb74578801dfcb990c864f111b174c7d7
+SIZE (nsnotifyd-1.6.tar.gz) = 22186
diff --git a/dns/nsnotifyd/pkg-descr b/dns/nsnotifyd/pkg-descr
new file mode 100644
index 000000000000..cd230379422a
--- /dev/null
+++ b/dns/nsnotifyd/pkg-descr
@@ -0,0 +1,7 @@
+The nsnotifyd daemon monitors a set of DNS zones and runs a command
+when any of them change. It listens for DNS NOTIFY messages so it can
+respond to changes promptly. It also uses each zone's SOA refresh and
+retry parameters to poll for updates if nsnotifyd does not receive
+NOTIFY messages more frequently.
+
+WWW: https://dotat.at/prog/nsnotifyd/
diff --git a/dns/nsnotifyd/pkg-plist b/dns/nsnotifyd/pkg-plist
new file mode 100644
index 000000000000..161e899fa385
--- /dev/null
+++ b/dns/nsnotifyd/pkg-plist
@@ -0,0 +1,10 @@
+bin/nsnotify
+bin/nsnotify-liststealth
+bin/nsnotify2git
+bin/nsnotify2stealth
+bin/nsnotify2update
+bin/nsnotifyd
+man/man1/metazone.1.gz
+man/man1/nsnotify.1.gz
+man/man1/nsnotifyd.1.gz
+man/man5/metazone.5.gz