aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-DNS-EasyDNS/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-28 20:10:52 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-28 20:10:52 +0000
commita2000d4d0977e71147f11990db6f75f10ccf0bba (patch)
tree0df1c42b228d40ec17552734b985533c285312e3 /dns/p5-DNS-EasyDNS/Makefile
parent950d1f7bd113f75c16c5a511ef8579a022becd0a (diff)
downloadports-a2000d4d0977e71147f11990db6f75f10ccf0bba.tar.gz
ports-a2000d4d0977e71147f11990db6f75f10ccf0bba.zip
Notes
Diffstat (limited to 'dns/p5-DNS-EasyDNS/Makefile')
-rw-r--r--dns/p5-DNS-EasyDNS/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/dns/p5-DNS-EasyDNS/Makefile b/dns/p5-DNS-EasyDNS/Makefile
new file mode 100644
index 000000000000..d101325271fc
--- /dev/null
+++ b/dns/p5-DNS-EasyDNS/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-DNS-EasyDNS
+# Date created: 28 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DNS-EasyDNS
+PORTVERSION= 0.04
+CATEGORIES= dns perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= DNS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Update your EasyDNS dynamic DNS entries
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= DNS::EasyDNS.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>