aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-Net-Bonjour
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-04-05 16:21:01 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-04-05 16:21:01 +0000
commitf874e732f21711a8105d3037a49b93080738bfb4 (patch)
tree0dfa7c212188e61fb5a08492efc4121edc511e38 /dns/p5-Net-Bonjour
parent29e3e85dc33f470c2f177818fbe424b253339d06 (diff)
downloadports-f874e732f21711a8105d3037a49b93080738bfb4.tar.gz
ports-f874e732f21711a8105d3037a49b93080738bfb4.zip
Notes
Diffstat (limited to 'dns/p5-Net-Bonjour')
-rw-r--r--dns/p5-Net-Bonjour/Makefile35
-rw-r--r--dns/p5-Net-Bonjour/distinfo2
-rw-r--r--dns/p5-Net-Bonjour/pkg-descr5
-rw-r--r--dns/p5-Net-Bonjour/pkg-plist8
4 files changed, 50 insertions, 0 deletions
diff --git a/dns/p5-Net-Bonjour/Makefile b/dns/p5-Net-Bonjour/Makefile
new file mode 100644
index 000000000000..2e65e75cce9b
--- /dev/null
+++ b/dns/p5-Net-Bonjour/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Net-Bonjour
+# Date created: 2011-04-05
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Bonjour
+PORTVERSION= 0.96
+CATEGORIES= dns net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:CHLIGE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Module for DNS service discovery
+
+LICENSE_COMB= dual
+LICENSE= ART20 GPLv1
+
+PERL_CONFIGURE= yes
+
+BUILD_DEPENDS= p5-Net-DNS>=0.5:${PORTSDIR}/dns/p5-Net-DNS
+
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+MAN3= Net::Rendezvous.3 \
+ Net::Bonjour::Entry.3 \
+ Net::Rendezvous::Entry.3 \
+ Net::Bonjour.3
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/my $$ans = .*/my $$ans = "n";/g' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/dns/p5-Net-Bonjour/distinfo b/dns/p5-Net-Bonjour/distinfo
new file mode 100644
index 000000000000..ff168a6cc0ad
--- /dev/null
+++ b/dns/p5-Net-Bonjour/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Bonjour-0.96.tar.gz) = c38a1f3ab200b08208d0c3a02b23d30653dfc62c09c6a12561c6ea08a69b1f97
+SIZE (Net-Bonjour-0.96.tar.gz) = 8323
diff --git a/dns/p5-Net-Bonjour/pkg-descr b/dns/p5-Net-Bonjour/pkg-descr
new file mode 100644
index 000000000000..d31d7a95bde0
--- /dev/null
+++ b/dns/p5-Net-Bonjour/pkg-descr
@@ -0,0 +1,5 @@
+This is Net::Bonjour, a set of perl modules to utilize DNS for service
+discovery. This method of service discovery is branded as Bonjour by
+Apple Computer.
+
+WWW: http://search.cpan.org/dist/Net-Bonjour/
diff --git a/dns/p5-Net-Bonjour/pkg-plist b/dns/p5-Net-Bonjour/pkg-plist
new file mode 100644
index 000000000000..22e338930e7b
--- /dev/null
+++ b/dns/p5-Net-Bonjour/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Bonjour/.packlist
+%%SITE_PERL%%/Net/Bonjour.pm
+%%SITE_PERL%%/Net/Bonjour/Entry.pm
+%%SITE_PERL%%/Net/Rendezvous/Entry.pm
+%%SITE_PERL%%/Net/Rendezvous.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Bonjour
+@dirrmtry %%SITE_PERL%%/Net/Rendezvous
+@dirrmtry %%SITE_PERL%%/Net/Bonjour