aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-Tie-DNS/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2009-01-06 18:16:18 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2009-01-06 18:16:18 +0000
commitb80c8190efeb8c2b21810fb90e6032a789f4070e (patch)
tree04b2eb9dcbe0a2f05d42edb8f9e6b845a7ca7062 /dns/p5-Tie-DNS/Makefile
parentb2a96c6df1c8809216eced623ec37a8372b3216e (diff)
downloadports-b80c8190efeb8c2b21810fb90e6032a789f4070e.tar.gz
ports-b80c8190efeb8c2b21810fb90e6032a789f4070e.zip
Notes
Diffstat (limited to 'dns/p5-Tie-DNS/Makefile')
-rw-r--r--dns/p5-Tie-DNS/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/dns/p5-Tie-DNS/Makefile b/dns/p5-Tie-DNS/Makefile
index 28d4e53be273..b2d9aac1bf5a 100644
--- a/dns/p5-Tie-DNS/Makefile
+++ b/dns/p5-Tie-DNS/Makefile
@@ -6,27 +6,32 @@
#
PORTNAME= Tie-DNS
-PORTVERSION= 0.5
+PORTVERSION= 0.6.1
PORTEPOCH= 1
CATEGORIES= dns perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
COMMENT= Tie interface to p5-Net-DNS
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0.12:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-Tie-Cache>=0.01:${PORTSDIR}/devel/p5-Tie-Cache
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Tie::DNS.3
+.if !defined(NOPORTEXAMPLES)
+
+PORTEXAMPLES= *
+
post-install:
-.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/eg/* ${EXAMPLESDIR}
+
.endif
.include <bsd.port.mk>