aboutsummaryrefslogtreecommitdiff
path: root/dns/p5-pgeodns/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-17 00:23:40 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-17 00:23:40 +0000
commit49d9214310549e568c0e8d34623d8bd50cf3af90 (patch)
tree25bfd69dc7a812d4b0dc9fbcc9be2bdb99840460 /dns/p5-pgeodns/Makefile
parent183765f2f10b67e6089579bda2e2d4ca7fedf3b0 (diff)
downloadports-49d9214310549e568c0e8d34623d8bd50cf3af90.tar.gz
ports-49d9214310549e568c0e8d34623d8bd50cf3af90.zip
Notes
Diffstat (limited to 'dns/p5-pgeodns/Makefile')
-rw-r--r--dns/p5-pgeodns/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/dns/p5-pgeodns/Makefile b/dns/p5-pgeodns/Makefile
new file mode 100644
index 000000000000..786626567f6e
--- /dev/null
+++ b/dns/p5-pgeodns/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pgeodns
+# Date created: 16 May 2009
+# Whom: Phillip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgeodns
+PORTVERSION= 1.32
+CATEGORIES= dns
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= A Geographic NameServer
+
+BUILD_DEPENDS= p5-Geo-IP>=0:${PORTSDIR}/net/p5-Geo-IP \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= pgeodns.pl.1
+
+.include <bsd.port.mk>