aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns-devel
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-05-09 17:56:13 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-05-09 17:56:13 +0000
commitef67eb675f410737b873039871de3375320377a2 (patch)
tree343f9908d8592d6df1be7bda229ed201227c17da /dns/powerdns-devel
parent283ea695936b6e97b33bb352fce9449f9c7fbcc9 (diff)
downloadports-ef67eb675f410737b873039871de3375320377a2.tar.gz
ports-ef67eb675f410737b873039871de3375320377a2.zip
Notes
Diffstat (limited to 'dns/powerdns-devel')
-rw-r--r--dns/powerdns-devel/Makefile46
-rw-r--r--dns/powerdns-devel/distinfo4
-rw-r--r--dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in14
-rw-r--r--dns/powerdns-devel/files/patch-pdns_Makefile_in23
-rw-r--r--dns/powerdns-devel/files/pdns.conf104
-rw-r--r--dns/powerdns-devel/pkg-plist2
6 files changed, 153 insertions, 40 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index baa49cbc2b68..0769d7f62c8d 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -6,24 +6,25 @@
#
PORTNAME= powerdns
-PORTVERSION= 2.9.22.${SNAPSHOT}
-PORTREVISION= 1
+PORTVERSION= 3.1.r2
+PORTREVISION?= 0
PORTEPOCH= 1
CATEGORIES= dns ipv6
-MASTER_SITES= http://svn.powerdns.com/snapshots/${REVISION}/
-PKGNAMESUFFIX= -devel
-DISTNAME= pdns-${PORTVERSION:S/.${SNAPSHOT}//}-rc1.${SNAPSHOT}.${REVISION}
+MASTER_SITES= http://powerdnssec.org/downloads/
+DISTNAME= pdns-${PORTVERSION:S/.r/-rc/}
MAINTAINER= tremere@cainites.net
COMMENT= An advanced DNS server with multiple backends including SQL
BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost-jam \
- ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+ ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
+LIB_DEPENDS= botan.0:${PORTSDIR}/security/botan \
+ boost_serialization.[4-9]:${PORTSDIR}/devel/boost-libs
-SNAPSHOT= 20081119
-REVISION= 1305
+USE_LUA= 5.1
+LUA_COMPS= lua
-CONFLICTS= powerdns-[0-2]*
+CONFLICTS= powerdns-3.0*
USE_GMAKE= YES
USE_SUBMAKE= YES
@@ -31,10 +32,12 @@ USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --with-modules="pipe" \
- --with-dynmodules="${CONFIGURE_MODULES}" \
- --sysconfdir="${PREFIX}/etc/pdns" \
-# --enable-debug
+CONFIGURE_ARGS= --with-modules="" \
+ --with-dynmodules="pipe ${CONFIGURE_MODULES}" \
+ --sysconfdir="${PREFIX}/etc/pdns" \
+ --with-boost="${LOCALBASE}" \
+ --enable-botan1.8 \
+ --enable-cryptopp
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
CURDIR2="${.CURDIR}" \
MKDIR="${MKDIR}" \
@@ -76,18 +79,19 @@ CONFIGURE_ARGS+= --with-pgsql=${LOCALBASE}
CONFIGURE_MODULES+= "gpgsql"
PLIST_SUB+= WITHPGSQL=""
.else
-CONFIGURE_ARGS+= --disable-pgsql
+CONFIGURE_ARGS+= --without-pgsql
PLIST_SUB+= WITHPGSQL="@comment "
.endif
.if defined(WITH_MYSQL)
USE_MYSQL?= YES
+CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
CONFIGURE_MODULES+= "gmysql"
-CXXFLAGS+= -I${LOCALBASE}/include/mysql
-LDFLAGS+= -L${LOCALBASE}/lib/mysql
+#CXXFLAGS+= -I${LOCALBASE}/include/mysql
+#LDFLAGS+= -L${LOCALBASE}/lib/mysql
PLIST_SUB+= WITHMYSQL=""
.else
-CONFIGURE_ARGS+= --disable-mysql
+CONFIGURE_ARGS+= --without-mysql
PLIST_SUB+= WITHMYSQL="@comment "
.endif
@@ -96,18 +100,18 @@ PLIST_SUB+= WITHMYSQL="@comment "
USE_PGSQL?= YES
RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
SUB_LIST+= PGSQL=postgresql
-. else
-SUB_LIST+= PGSQL=
. endif
+.else
+SUB_LIST+= PGSQL=
.endif
.if defined(WITH_OPENDBX) || defined(WITH_MYSQL)
. if defined(WITH_MYSQL_LOCAL)
USE_MYSQL?= YES
RUN_DEPENDS+= mysql-server>=0:${PORTSDIR}/databases/mysql${MYSQL_VER}-server
SUB_LIST+= MYSQL=mysql
-. else
-SUB_LIST+= MYSQL=
. endif
+.else
+SUB_LIST+= MYSQL=
.endif
.if defined(WITH_OPENLDAP)
diff --git a/dns/powerdns-devel/distinfo b/dns/powerdns-devel/distinfo
index fe7e835b8a01..b4a76ca4e649 100644
--- a/dns/powerdns-devel/distinfo
+++ b/dns/powerdns-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pdns-2.9.22-rc1.20081119.1305.tar.gz) = 791be0119d8183e8737313b606eabd9841aceebc26ee14ffc0350f8787a9cca5
-SIZE (pdns-2.9.22-rc1.20081119.1305.tar.gz) = 1059468
+SHA256 (pdns-3.1-rc2.tar.gz) = 9527c248dcf7fe115168025694d027c5cc3f41389a017bcf9192e7ca465807ab
+SIZE (pdns-3.1-rc2.tar.gz) = 1273089
diff --git a/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in b/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in
index 98a64b5a1095..91e11a68ef41 100644
--- a/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in
+++ b/dns/powerdns-devel/files/patch-modules_gpgsqlbackend_Makefile_in
@@ -1,6 +1,6 @@
---- modules/gpgsqlbackend/Makefile.in.org 2008-03-18 22:30:19.000000000 +0100
-+++ modules/gpgsqlbackend/Makefile.in 2008-03-18 22:31:26.000000000 +0100
-@@ -213,14 +213,14 @@
+--- modules/gpgsqlbackend/Makefile.in.org 2009-01-28 10:55:21.000000000 +0100
++++ modules/gpgsqlbackend/Makefile.in 2009-01-28 11:02:29.000000000 +0100
+@@ -217,8 +217,8 @@
AM_CPPFLAGS = @THREADFLAGS@
lib_LTLIBRARIES = libgpgsqlbackend.la
EXTRA_DIST = OBJECTFILES OBJECTLIBS
@@ -9,11 +9,3 @@
libgpgsqlbackend_la_SOURCES = gpgsqlbackend.cc gpgsqlbackend.hh \
spgsql.hh spgsql.cc
- libgpgsqlbackend_la_LDFLAGS = -module -avoid-version @PGSQL_lib@ -Wl,-Bstatic -lpq \
- -Wl,-Bdynamic
-
--libgpgsqlbackend_la_LIBADD = -lssl -lcrypt -lcrypto
-+libgpgsqlbackend_la_LIBADD = -lssl -lcrypto
- all: all-am
-
- .SUFFIXES:
diff --git a/dns/powerdns-devel/files/patch-pdns_Makefile_in b/dns/powerdns-devel/files/patch-pdns_Makefile_in
new file mode 100644
index 000000000000..909edd631248
--- /dev/null
+++ b/dns/powerdns-devel/files/patch-pdns_Makefile_in
@@ -0,0 +1,23 @@
+--- pdns/Makefile.in.orig 2011-07-22 13:26:07.000000000 +0200
++++ pdns/Makefile.in 2011-08-09 10:11:41.000000000 +0200
+@@ -51,16 +51,16 @@
+ dnslog$(EXEEXT) nproxy$(EXEEXT) notify$(EXEEXT) \
+ pdnssec$(EXEEXT) dnsbulktest$(EXEEXT)
+ @BOTAN110_TRUE@am__append_1 = botan110signers.cc botansigners.cc
+-@BOTAN110_TRUE@am__append_2 = -lbotan-1.10 -lgmp
++@BOTAN110_TRUE@am__append_2 = -lbotan-1.10
+ @BOTAN18_TRUE@am__append_3 = botan18signers.cc botansigners.cc
+-@BOTAN18_TRUE@am__append_4 = -lbotan -lgmp
++@BOTAN18_TRUE@am__append_4 = -lbotan
+ @CRYPTOPP_TRUE@am__append_5 = cryptoppsigners.cc
+ @CRYPTOPP_TRUE@am__append_6 = -lcryptopp
+ @SQLITE3_TRUE@am__append_7 = ssqlite3.cc ssqlite3.hh
+ @BOTAN110_TRUE@am__append_8 = botan110signers.cc botansigners.cc
+-@BOTAN110_TRUE@am__append_9 = -lbotan-1.10 -lgmp
++@BOTAN110_TRUE@am__append_9 = -lbotan-1.10
+ @BOTAN18_TRUE@am__append_10 = botan18signers.cc botansigners.cc
+-@BOTAN18_TRUE@am__append_11 = -lbotan -lgmp
++@BOTAN18_TRUE@am__append_11 = -lbotan
+ @CRYPTOPP_TRUE@am__append_12 = cryptoppsigners.cc
+ @CRYPTOPP_TRUE@am__append_13 = -lcryptopp
+ @SQLITE3_TRUE@am__append_14 = ssqlite3.cc ssqlite3.hh \ No newline at end of file
diff --git a/dns/powerdns-devel/files/pdns.conf b/dns/powerdns-devel/files/pdns.conf
index c539c38c2b81..07616949a456 100644
--- a/dns/powerdns-devel/files/pdns.conf
+++ b/dns/powerdns-devel/files/pdns.conf
@@ -29,7 +29,7 @@
#ldap-secret (default "")
#ldap-method (default "simple")
#ldap-filter-axfr (default "(:target:)" )
-ldap-filter-lookup (default "(:target:)" )
+#ldap-filter-lookup (default "(:target:)" )
# OpenDBX (check http://www.linuxnetworks.de for more information)
#launch=opendbx
@@ -44,7 +44,7 @@ ldap-filter-lookup (default "(:target:)" )
#################################
# allow-axfr-ips Allow zonetransfers only to these subnets
#
-# allow-axfr-ips=0.0.0.0/0
+# allow-axfr-ips=0.0.0.0/0,::/0
#################################
# allow-recursion List of subnets that are allowed to recurse
@@ -69,7 +69,7 @@ ldap-filter-lookup (default "(:target:)" )
#################################
# config-dir Location of configuration directory (pdns.conf)
#
-# config-dir=/usr/local/etc
+# config-dir=/usr/local/etc/pdns
#################################
# config-name Name of this virtual configuration - will rename the binary image
@@ -117,6 +117,21 @@ ldap-filter-lookup (default "(:target:)" )
# do-ipv6-additional-processing=no
#################################
+# edns-subnet-option-number EDNS option number to use
+#
+# edns-subnet-option-number=20730
+
+#################################
+# edns-subnet-processing If we should act on EDNS Subnet options
+#
+# edns-subnet-processing=no
+
+#################################
+# entropy-source If set, read entropy from this file
+#
+# entropy-source=/dev/urandom
+
+#################################
# fancy-records Process URL and MBOXFW records
#
# fancy-records=no
@@ -162,12 +177,17 @@ ldap-filter-lookup (default "(:target:)" )
# log-dns-details=
#################################
+# log-dns-queries If PDNS should log all incoming DNS queries
+#
+# log-dns-queries=no
+
+#################################
# log-failed-updates If PDNS should log failed update requests
#
# log-failed-updates=
#################################
-# logfile Logfile to use
+# logfile Logfile to use (Windows only)
#
# logfile=pdns.log
@@ -187,6 +207,11 @@ ldap-filter-lookup (default "(:target:)" )
# master=no
#################################
+# max-cache-entries Maximum number of cache entries
+#
+# max-cache-entries=1000000
+
+#################################
# max-queue-length Maximum queuelength before considering situation lost
#
# max-queue-length=5000
@@ -217,6 +242,16 @@ ldap-filter-lookup (default "(:target:)" )
# out-of-zone-additional-processing=yes
#################################
+# overload-queue-length Maximum queuelength moving to packetcache only
+#
+# overload-queue-length=0
+
+#################################
+# per-zone-axfr-acls When set, backends that implement it perform per-zone AXFL ACL checks
+#
+# per-zone-axfr-acls=off
+
+#################################
# pipebackend-abi-version Version of the pipe backend ABI
#
# pipebackend-abi-version=1
@@ -229,7 +264,12 @@ ldap-filter-lookup (default "(:target:)" )
#################################
# query-local-address Source IP address for sending queries
#
-# query-local-address=
+# query-local-address=0.0.0.0
+
+#################################
+# query-local-address6 Source IPv6 address for sending queries
+#
+# query-local-address6=::
#################################
# query-logging Hint backends that queries should be logged
@@ -242,6 +282,11 @@ ldap-filter-lookup (default "(:target:)" )
# queue-limit=1500
#################################
+# receiver-threads Default number of Distributor (backend) threads to start
+#
+# receiver-threads=1
+
+#################################
# recursive-cache-ttl Seconds to store packets in the PacketCache
#
# recursive-cache-ttl=10
@@ -252,11 +297,21 @@ ldap-filter-lookup (default "(:target:)" )
# recursor=no
#################################
+# retrieval-threads Number of AXFR-retrieval threads for slave operation
+#
+# retrieval-threads=2
+
+#################################
# send-root-referral Send out old-fashioned root-referral instead of ServFail in case of no authority
#
# send-root-referral=no
#################################
+# server-id Returned when queried for 'server.id' TXT or NSID, defaults to hostname
+#
+# server-id=
+
+#################################
# setgid If set, change group id to this gid for more security
#
# setgid=
@@ -267,6 +322,11 @@ ldap-filter-lookup (default "(:target:)" )
# setuid=
#################################
+# signing-threads Default number of signer threads to start
+#
+# signing-threads=3
+
+#################################
# skip-cname Do not perform CNAME indirection for each query
#
# skip-cname=no
@@ -282,6 +342,11 @@ ldap-filter-lookup (default "(:target:)" )
# slave-cycle-interval=60
#################################
+# slave-renotify If we should send out notifications for slaved updates
+#
+# slave-renotify=no
+
+#################################
# smtpredirector Our smtpredir MX host
#
# smtpredirector=a.misconfigured.powerdns.smtp.server
@@ -322,12 +387,37 @@ ldap-filter-lookup (default "(:target:)" )
# strict-rfc-axfrs=no
#################################
+# tcp-control-address If set, PowerDNS can be controlled over TCP on this address
+#
+# tcp-control-address=
+
+#################################
+# tcp-control-port If set, PowerDNS can be controlled over TCP on this address
+#
+# tcp-control-port=53000
+
+#################################
+# tcp-control-range If set, remote control of PowerDNS is possible over these networks only
+#
+# tcp-control-range=127.0.0.0/8, 10.0.0.0/8, 192.168.0.0/16, 172.16.0.0/12, ::1/128, fe80::/10
+
+#################################
+# tcp-control-secret If set, PowerDNS can be controlled over TCP after passing this secret
+#
+# tcp-control-secret=
+
+#################################
+# trusted-notification-proxy IP address of incoming notification proxy
+#
+# trusted-notification-proxy=
+
+#################################
# urlredirector Where we send hosts to that need to be url redirected
#
# urlredirector=127.0.0.1
#################################
-# use-logfile Use a log file
+# use-logfile Use a log file (Windows only)
#
# use-logfile=no
@@ -370,3 +460,5 @@ ldap-filter-lookup (default "(:target:)" )
# wildcards Honor wildcards in the database
#
# wildcards=
+
+
diff --git a/dns/powerdns-devel/pkg-plist b/dns/powerdns-devel/pkg-plist
index 5defeccb8457..4010385c1030 100644
--- a/dns/powerdns-devel/pkg-plist
+++ b/dns/powerdns-devel/pkg-plist
@@ -1,4 +1,6 @@
+bin/dnsreplay
bin/pdns_control
+bin/pdnssec
bin/zone2ldap
bin/zone2sql
sbin/pdns_server