aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns-devel
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-01-12 16:00:01 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-01-12 16:00:01 +0000
commit922367dd73eafa548600934f8ef1aeeaaa321602 (patch)
treeff4c599119ba02bd99699be4be9fcb4af852d5f8 /dns/powerdns-devel
parent6b8771fe6247df3dc812ae4964a07de362a99ba4 (diff)
downloadports-922367dd73eafa548600934f8ef1aeeaaa321602.tar.gz
ports-922367dd73eafa548600934f8ef1aeeaaa321602.zip
Notes
Diffstat (limited to 'dns/powerdns-devel')
-rw-r--r--dns/powerdns-devel/Makefile5
-rw-r--r--dns/powerdns-devel/distinfo4
-rw-r--r--dns/powerdns-devel/files/patch-pdns__dnsreplay.cc10
-rw-r--r--dns/powerdns-devel/files/patch-pdns_cryptoppsigners_cc31
-rw-r--r--dns/powerdns-devel/files/patch-pdns_pdns_backends_bind_binddnssec_cc16
-rw-r--r--dns/powerdns-devel/pkg-plist1
6 files changed, 36 insertions, 31 deletions
diff --git a/dns/powerdns-devel/Makefile b/dns/powerdns-devel/Makefile
index 73a47421e082..c192f4388db2 100644
--- a/dns/powerdns-devel/Makefile
+++ b/dns/powerdns-devel/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= powerdns
-PORTVERSION= 3.2.r1
+PORTVERSION= 3.2.r4
PORTREVISION?= 0
PORTEPOCH= 1
CATEGORIES= dns ipv6
@@ -15,7 +15,6 @@ COMMENT= An advanced DNS server with multiple backends including SQL
LICENSE= GPLv2
LIB_DEPENDS= boost_serialization.[4-9]:${PORTSDIR}/devel/boost-libs
-# botan.0:${PORTSDIR}/security/botan
USE_LUA= 5.1
LUA_COMPS= lua
@@ -160,7 +159,7 @@ PLIST_SUB+= WITHOPENDBX="@comment "
.if ${PORT_OPTIONS:MDNSSEC}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
-CONFIGURE_FLAGS+= --enable-cryptopp
+CONFIGURE_ARGS+= --enable-cryptopp
.endif
post-patch:
diff --git a/dns/powerdns-devel/distinfo b/dns/powerdns-devel/distinfo
index 73be01f1b904..c8d7a52dd5d3 100644
--- a/dns/powerdns-devel/distinfo
+++ b/dns/powerdns-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pdns-3.2-rc1.tar.gz) = c450828c042e6c893fb8f5232b67f7808f9cbb0d09296aa11b331cfe9ed6a7dd
-SIZE (pdns-3.2-rc1.tar.gz) = 1277305
+SHA256 (pdns-3.2-rc4.tar.gz) = adcf5f651811fb979f9033a3c156492c5637b3f9c872f335ac24ffa046a60934
+SIZE (pdns-3.2-rc4.tar.gz) = 1292662
diff --git a/dns/powerdns-devel/files/patch-pdns__dnsreplay.cc b/dns/powerdns-devel/files/patch-pdns__dnsreplay.cc
deleted file mode 100644
index 1ef3323d6673..000000000000
--- a/dns/powerdns-devel/files/patch-pdns__dnsreplay.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./pdns/dnsreplay.cc.orig 2012-12-04 13:37:13.000000000 -0500
-+++ ./pdns/dnsreplay.cc 2012-12-04 13:37:43.000000000 -0500
-@@ -489,7 +489,6 @@
-
- QuestionData qd;
- try {
-- dnsheader* dh=(dnsheader*)pr.d_payload;
- if(!dh->qr) {
- qd.d_assignedID = s_idmanager.peakID();
- uint16_t tmp=dh->id;
diff --git a/dns/powerdns-devel/files/patch-pdns_cryptoppsigners_cc b/dns/powerdns-devel/files/patch-pdns_cryptoppsigners_cc
new file mode 100644
index 000000000000..66de02685293
--- /dev/null
+++ b/dns/powerdns-devel/files/patch-pdns_cryptoppsigners_cc
@@ -0,0 +1,31 @@
+--- pdns/cryptoppsigners.cc (revision 3032)
++++ pdns/cryptoppsigners.cc (working copy)
+@@ -82,18 +82,26 @@
+ storvect.push_back(make_pair("PrivateKey", string((char*)buffer, sizeof(buffer))));
+ return storvect;
+ }
++
+ template<class HASHER, class CURVE, int BITS>
+ void CryptoPPECDSADNSCryptoKeyEngine<HASHER,CURVE,BITS>::fromISCMap(DNSKEYRecordContent& drc, std::map<std::string, std::string>& stormap )
+ {
++ AutoSeededRandomPool prng;
+ privatekey_t* privateKey = new privatekey_t;
+- const CryptoPP::Integer x;
++ const CryptoPP::Integer x(reinterpret_cast<const unsigned char*>(stormap["privatekey"].c_str()), BITS/8); // well it should be this long
+ CryptoPP::OID oid=CURVE();
+- privateKey->Initialize(oid, x );
++ privateKey->Initialize(oid, x);
++ bool result = privateKey->Validate(prng, 3);
++ if (!result) {
++ throw "Cannot load private key - validation failed!";
++ }
+ d_key = shared_ptr<privatekey_t>(privateKey);
+ publickey_t* publicKey = new publickey_t();
+ d_key->MakePublicKey(*publicKey);
+ d_pubkey = shared_ptr<publickey_t>(publicKey);
++ drc.d_algorithm = atoi(stormap["algorithm"].c_str());
+ }
++
+ template<class HASHER, class CURVE, int BITS>
+ std::string CryptoPPECDSADNSCryptoKeyEngine<HASHER,CURVE,BITS>::getPubKeyHash() const
+ {
diff --git a/dns/powerdns-devel/files/patch-pdns_pdns_backends_bind_binddnssec_cc b/dns/powerdns-devel/files/patch-pdns_pdns_backends_bind_binddnssec_cc
deleted file mode 100644
index 21e929a2a7fe..000000000000
--- a/dns/powerdns-devel/files/patch-pdns_pdns_backends_bind_binddnssec_cc
+++ /dev/null
@@ -1,16 +0,0 @@
---- pdns/backends/bind/binddnssec.cc (revision 2874)
-+++ pdns/backends/bind/binddnssec.cc (revision 2888)
-@@ -29,6 +29,4 @@
- if(!getArg("dnssec-db").empty())
- throw runtime_error("bind-dnssec-db requires building PowerDNS with SQLite3");
--
-- d_dnssecdb->setLog(::arg().mustDo("query-logging"));
- }
-
-@@ -80,4 +78,6 @@
- throw runtime_error("Error opening DNSSEC database in BIND backend: "+se.txtReason());
- }
-+
-+ d_dnssecdb->setLog(::arg().mustDo("query-logging"));
- }
- \ No newline at end of file
diff --git a/dns/powerdns-devel/pkg-plist b/dns/powerdns-devel/pkg-plist
index 4010385c1030..2f05f1506d12 100644
--- a/dns/powerdns-devel/pkg-plist
+++ b/dns/powerdns-devel/pkg-plist
@@ -1,6 +1,7 @@
bin/dnsreplay
bin/pdns_control
bin/pdnssec
+bin/zone2json
bin/zone2ldap
bin/zone2sql
sbin/pdns_server