aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns-recursor
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2008-08-06 20:48:41 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2008-08-06 20:48:41 +0000
commitf530698359a007ea092ba92d1db962a1ef6bd038 (patch)
tree6a4b42b8240a1c33789137ba11e8044b6450ea81 /dns/powerdns-recursor
parentd661e422ddd159b2487cadb1cf323e160a5d8559 (diff)
downloadports-f530698359a007ea092ba92d1db962a1ef6bd038.tar.gz
ports-f530698359a007ea092ba92d1db962a1ef6bd038.zip
Notes
Diffstat (limited to 'dns/powerdns-recursor')
-rw-r--r--dns/powerdns-recursor/Makefile2
-rw-r--r--dns/powerdns-recursor/files/patch-makefile12
-rw-r--r--dns/powerdns-recursor/files/pdns-recursor.in2
-rw-r--r--dns/powerdns-recursor/pkg-deinstall19
4 files changed, 33 insertions, 2 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 41101acec317..c9791dfba32b 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -7,6 +7,7 @@
PORTNAME= powerdns-recursor
PORTVERSION= 3.1.7
+PORTREVISION= 1
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/ \
http://mirrors.evolva.ro/powerdns.com/releases/
@@ -48,7 +49,6 @@ MAKE_ENV+="LUA_LIBS_CONFIG=-L${LOCALBASE}/lib/lua51/ -llua"
.if defined(WITH_STATIC)
MAKE_ENV+=STATIC=full
-PLIST_SUB+= STATIC="@comment "
.endif
.if exists(/usr/include/ucontext.h)
diff --git a/dns/powerdns-recursor/files/patch-makefile b/dns/powerdns-recursor/files/patch-makefile
index f5e9b7a04008..ab97d9d40995 100644
--- a/dns/powerdns-recursor/files/patch-makefile
+++ b/dns/powerdns-recursor/files/patch-makefile
@@ -8,6 +8,18 @@
CXXFLAGS:= $(CXXFLAGS) -Wall -DBOOST_SP_DISABLE_THREADS $(OPTFLAGS) $(PROFILEFLAGS)
CFLAGS:=$(CFLAGS) -Wall $(OPTFLAGS) $(PROFILEFLAGS)
LINKCC=$(CXX)
+@@ -41,9 +40,9 @@
+ ifeq ($(STATIC),semi)
+ STATICFLAGS=-Wl,-Bstatic -lstdc++ $(LUALIBS) -lgcc -Wl,-Bdynamic -static-libgcc -lm -lc
+ LINKCC=$(CC)
+- LDFLAGS += malloc.o -ldl -lm
++ LDFLAGS += malloc.o -lm
+ else ifeq ($(STATIC),full)
+- STATICFLAGS=-lstdc++ $(LUALIBS) -ldl -lm -static
++ STATICFLAGS=-lstdc++ $(LUALIBS) -lm -static
+ LINKCC=$(CC)
+ else
+ LDFLAGS += malloc.o $(LUALIBS)
@@ -54,16 +53,14 @@
fi
diff --git a/dns/powerdns-recursor/files/pdns-recursor.in b/dns/powerdns-recursor/files/pdns-recursor.in
index 4056deaf7961..39497615d473 100644
--- a/dns/powerdns-recursor/files/pdns-recursor.in
+++ b/dns/powerdns-recursor/files/pdns-recursor.in
@@ -4,7 +4,7 @@
#
# PROVIDE: pdns_recursor
-# REQUIRE: DAEMON
+# REQUIRE: SERVERS cleanvar
# KEYWORD: shutdown
#
diff --git a/dns/powerdns-recursor/pkg-deinstall b/dns/powerdns-recursor/pkg-deinstall
new file mode 100644
index 000000000000..6a235b2fc88f
--- /dev/null
+++ b/dns/powerdns-recursor/pkg-deinstall
@@ -0,0 +1,19 @@
+#!/bin/sh
+
+if [ "$2" != "POST-DEINSTALL" ]; then
+ exit 0
+fi
+
+PDNSUSER=${PDNSUSER:-pdns_recursor}
+PDNSUID=${PDNSUID:-120}
+PDNSGROUP=${PDNSGROUP:-pdns}
+PDNSGID=${PDNSGID:-120}
+
+if pw groupshow "$PDNSGROUP" 2>/dev/null 1>&2; then
+ echo "To delete the PowerDNS group permanently, use 'pw groupdel ${PDNSGROUP}'"
+fi
+
+if pw usershow "$PDNSUSER" 2>/dev/null 1>&2; then
+ echo "To delete the PowerDNS user permanently, use 'pw userdel ${PDNSUSER}'"
+fi
+exit 0