aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns-recursor
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2019-02-18 15:38:47 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2019-02-18 15:38:47 +0000
commit5b35cf7267a0eb5021d8179b58d9da7298474c30 (patch)
treefb33d6b40be253fca5a2ed18bf4a29fff8fe4504 /dns/powerdns-recursor
parentea2b4d789b422bb16cb684089d3ea828bb6dfb64 (diff)
downloadports-5b35cf7267a0eb5021d8179b58d9da7298474c30.tar.gz
ports-5b35cf7267a0eb5021d8179b58d9da7298474c30.zip
Notes
Diffstat (limited to 'dns/powerdns-recursor')
-rw-r--r--dns/powerdns-recursor/Makefile4
-rw-r--r--dns/powerdns-recursor/distinfo6
-rw-r--r--dns/powerdns-recursor/files/patch-dnsname.hh4
3 files changed, 6 insertions, 8 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index edbf4bb6671c..7a01cfe77d08 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= recursor
-DISTVERSION= 4.1.10
+DISTVERSION= 4.1.11
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
PKGNAMEPREFIX= powerdns-
@@ -22,8 +22,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libboost_context.so:devel/boost-libs \
libprotobuf.so:devel/protobuf
-CONFLICTS_INSTALL= powerdns-recursor40
-
USES= compiler:c++11-lib cpe gmake localbase:ldflags pkgconfig ssl tar:bzip2
GNU_CONFIGURE= YES
CXXFLAGS+= -D_GLIBCXX_USE_C99
diff --git a/dns/powerdns-recursor/distinfo b/dns/powerdns-recursor/distinfo
index be649030d07d..1e1c2d78c594 100644
--- a/dns/powerdns-recursor/distinfo
+++ b/dns/powerdns-recursor/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1548341968
-SHA256 (pdns-recursor-4.1.10.tar.bz2) = f22dc09dae32fbf394a80831f7e7a2fde2e5a2a5ac572e134de9935629817f01
-SIZE (pdns-recursor-4.1.10.tar.bz2) = 1238148
+TIMESTAMP = 1549022270
+SHA256 (pdns-recursor-4.1.11.tar.bz2) = 9ec7d52b545d3ea4498b17ea5433a686aa0d82e882608dcdcea9a116a3f4d670
+SIZE (pdns-recursor-4.1.11.tar.bz2) = 1239986
diff --git a/dns/powerdns-recursor/files/patch-dnsname.hh b/dns/powerdns-recursor/files/patch-dnsname.hh
index a1de8ea78853..00e1420f724c 100644
--- a/dns/powerdns-recursor/files/patch-dnsname.hh
+++ b/dns/powerdns-recursor/files/patch-dnsname.hh
@@ -1,4 +1,4 @@
---- dnsname.hh.orig 2017-01-17 03:18:41 UTC
+--- dnsname.hh.orig 2019-01-31 19:43:44 UTC
+++ dnsname.hh
@@ -30,7 +30,7 @@
#include <boost/version.hpp>
@@ -9,7 +9,7 @@
#include <boost/container/string.hpp>
#endif
-@@ -133,7 +133,7 @@ public:
+@@ -135,7 +135,7 @@ class DNSName (public)
inline bool canonCompare(const DNSName& rhs) const;
bool slowCanonCompare(const DNSName& rhs) const;