aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns-recursor
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-11-29 11:00:35 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-11-29 11:00:35 +0000
commitf80318b3373f9749091f3f077f06cd24b39b0b4f (patch)
tree5613c6b0425ab6e6272c82fe42e8e9248e199582 /dns/powerdns-recursor
parent5cd204745ce8f38912542a481d254785d986f065 (diff)
downloadports-f80318b3373f9749091f3f077f06cd24b39b0b4f.tar.gz
ports-f80318b3373f9749091f3f077f06cd24b39b0b4f.zip
Notes
Diffstat (limited to 'dns/powerdns-recursor')
-rw-r--r--dns/powerdns-recursor/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 103d71fc8368..5a26743b298f 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -18,10 +18,10 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libboost_context.so:devel/boost-libs
BROKEN_sparc64= Does not compile on sparc64
-BROKEN_FreeBSD_9= linker error
-USES= compiler:c++11-lib cpe gmake pkgconfig ssl tar:bzip2
+USES= compiler:c++11-lib cpe gmake localbase pkgconfig ssl tar:bzip2
GNU_CONFIGURE= YES
+CXXFLAGS+= -D_GLIBCXX_USE_C99
CPE_VENDOR= powerdns
@@ -54,4 +54,15 @@ USERS= pdns_recursor
GROUPS= pdns
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} == base
+BROKEN_FreeBSD_9= FreeBSD 9.x requires SSL from ports
+.endif
+
+.if ${OSVERSION} < 1000000 && ${ARCH} == i386
+#BUILD_DEPENDS= ${LOCALBASE}/lib/libatomic_ops.a:devel/libatomic_ops
+LDFLAGS+= -latomic
+.endif
+
+.include <bsd.port.post.mk>