aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns-recursor
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2010-03-12 18:54:22 +0000
committerAlberto Villa <avilla@FreeBSD.org>2010-03-12 18:54:22 +0000
commit9ad1c46cf5d8c3103954361e59bfd8bec20cd7e9 (patch)
tree49da34138b82c813701d4da4c13aeb6fcbb8ee0e /dns/powerdns-recursor
parente0f6fa3d7c65907b494ff2a33ce055ecf1ac479a (diff)
downloadports-9ad1c46cf5d8c3103954361e59bfd8bec20cd7e9.tar.gz
ports-9ad1c46cf5d8c3103954361e59bfd8bec20cd7e9.zip
Notes
Diffstat (limited to 'dns/powerdns-recursor')
-rw-r--r--dns/powerdns-recursor/Makefile2
-rw-r--r--dns/powerdns-recursor/distinfo6
-rw-r--r--dns/powerdns-recursor/files/extrapatch-setuid10
-rw-r--r--dns/powerdns-recursor/files/patch-makefile30
-rw-r--r--dns/powerdns-recursor/files/patch-manpages34
5 files changed, 37 insertions, 45 deletions
diff --git a/dns/powerdns-recursor/Makefile b/dns/powerdns-recursor/Makefile
index 5b5809ba5e30..8502bda60e36 100644
--- a/dns/powerdns-recursor/Makefile
+++ b/dns/powerdns-recursor/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= powerdns-recursor
-PORTVERSION= 3.1.7.2
+PORTVERSION= 3.2
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/ \
http://mirrors.evolva.ro/powerdns.com/releases/
diff --git a/dns/powerdns-recursor/distinfo b/dns/powerdns-recursor/distinfo
index dd21fbc4bbd9..852a9217c991 100644
--- a/dns/powerdns-recursor/distinfo
+++ b/dns/powerdns-recursor/distinfo
@@ -1,3 +1,3 @@
-MD5 (pdns-recursor-3.1.7.2.tar.bz2) = 5fdba3612e281bf65c6c9f665673dc4e
-SHA256 (pdns-recursor-3.1.7.2.tar.bz2) = 0f2fd93eec8d7c68578fbf1f680f6d1ab44c3249f0a08257a4e6531e48a9d2ea
-SIZE (pdns-recursor-3.1.7.2.tar.bz2) = 174082
+MD5 (pdns-recursor-3.2.tar.bz2) = 7e14d9487664d58c27448ae26e824215
+SHA256 (pdns-recursor-3.2.tar.bz2) = 1994140bf0816ef16fe5c8fe9956737a8f7445041adc3d8bc4d0795b2c50c0de
+SIZE (pdns-recursor-3.2.tar.bz2) = 139569
diff --git a/dns/powerdns-recursor/files/extrapatch-setuid b/dns/powerdns-recursor/files/extrapatch-setuid
index 50db88ce9e7a..3ccbd3fc8ea7 100644
--- a/dns/powerdns-recursor/files/extrapatch-setuid
+++ b/dns/powerdns-recursor/files/extrapatch-setuid
@@ -1,6 +1,6 @@
---- pdns_recursor.cc.orig Wed Jan 17 23:45:51 2007
-+++ pdns_recursor.cc Thu Jan 18 00:01:47 2007
-@@ -1669,8 +1669,8 @@
+--- pdns_recursor.cc.orig 2010-03-06 13:10:44.000000000 +0100
++++ pdns_recursor.cc 2010-03-07 21:13:07.000000000 +0100
+@@ -1890,8 +1890,8 @@
::arg().set("daemon","Operate as a daemon")="yes";
::arg().set("log-common-errors","If we should log rather common errors")="yes";
::arg().set("chroot","switch to chroot jail")="";
@@ -8,6 +8,6 @@
- ::arg().set("setuid","If set, change user id to this uid for more security")="";
+ ::arg().set("setgid","If set, change group id to this gid for more security")="pdns";
+ ::arg().set("setuid","If set, change user id to this uid for more security")="pdns_recursor";
+ ::arg().set("network-timeout", "Wait this nummer of milliseconds for network i/o")="1500";
+ ::arg().set("threads", "Launch this number of threads")="2";
#ifdef WIN32
- ::arg().set("quiet","Suppress logging of questions and answers")="off";
- ::arg().setSwitch( "register-service", "Register the service" )= "no";
diff --git a/dns/powerdns-recursor/files/patch-makefile b/dns/powerdns-recursor/files/patch-makefile
index 54d478cdce16..73d03786b1d2 100644
--- a/dns/powerdns-recursor/files/patch-makefile
+++ b/dns/powerdns-recursor/files/patch-makefile
@@ -1,27 +1,19 @@
---- Makefile.orig 2010-01-03 15:26:42.000000000 +0100
-+++ Makefile 2010-01-05 10:32:00.000000000 +0100
-@@ -2,7 +2,6 @@
- SBINDIR=/usr/sbin/
- BINDIR=/usr/bin/
- CONFIGDIR="/etc/powerdns/"
--OPTFLAGS?=-O3
- CXXFLAGS:= $(CXXFLAGS) -Wall -DBOOST_SP_DISABLE_THREADS $(OPTFLAGS) $(PROFILEFLAGS)
- CFLAGS:=$(CFLAGS) -Wall $(OPTFLAGS) $(PROFILEFLAGS)
- LINKCC=$(CXX)
-@@ -41,10 +40,10 @@
+--- Makefile.orig 2010-02-10 20:46:15.000000000 +0100
++++ Makefile 2010-02-11 13:22:25.000000000 +0100
+@@ -38,10 +38,10 @@
ifeq ($(STATIC),semi)
STATICFLAGS=-Wl,-Bstatic -lstdc++ $(LUALIBS) -lgcc -Wl,-Bdynamic -static-libgcc -lm -lc
LINKCC=$(CC)
-- LDFLAGS += malloc.o -ldl -lm
-+ LDFLAGS += malloc.o -lm
- else
- ifeq ($(STATIC),full)
+- LDFLAGS += -ldl -lm
++ LDFLAGS += -lm
+ else
+ ifeq ($(STATIC),full)
- STATICFLAGS=-lstdc++ $(LUALIBS) -ldl -lm -static
+ STATICFLAGS=-lstdc++ $(LUALIBS) -lm -static
LINKCC=$(CC)
- else
- LDFLAGS += malloc.o $(LUALIBS)
-@@ -72,16 +71,14 @@
+ else
+ LDFLAGS += $(LUALIBS)
+@@ -69,16 +69,14 @@
fi
install: all
@@ -39,4 +31,4 @@
+ mv rec_control.1 rec_control.8
$(OS_SPECIFIC_INSTALL)
- clean:
+ clean: binclean
diff --git a/dns/powerdns-recursor/files/patch-manpages b/dns/powerdns-recursor/files/patch-manpages
index 416d379d2410..8f85e86b4c08 100644
--- a/dns/powerdns-recursor/files/patch-manpages
+++ b/dns/powerdns-recursor/files/patch-manpages
@@ -1,11 +1,11 @@
---- pdns_recursor.1.orig 2010-01-03 15:26:42.000000000 +0100
-+++ pdns_recursor.1 2010-01-05 10:36:30.000000000 +0100
+--- pdns_recursor.1.orig 2010-02-11 11:28:22.000000000 +0100
++++ pdns_recursor.1 2010-02-11 11:27:38.000000000 +0100
@@ -5,7 +5,7 @@
.\" Manual:
.\" Source:
.\"
--.TH "PDNS_RECURSOR" "1" "12/29/2009" "" ""
-+.TH "PDNS_RECURSOR" "8" "12/29/2009" "" ""
+-.TH "PDNS_RECURSOR" "1" "03/22/2008" "" ""
++.TH "PDNS_RECURSOR" "8" "03/22/2008" "" ""
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
@@ -13,28 +13,28 @@
\fIpdns_recursor\fR [\-\-daemon] [\-\-local\-address] [\-\-help, \-h] [\-\-allow\-from]
.sp
.SH "DESCRIPTION"
--pdns_recursor(1) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
-+pdns_recursor(8) is a high performance, simple and secure recursing nameserver\&. It currently powers over two million internet connections\&.
+-pdns_recursor(1) is a high performance, simple and secure recursing nameserver. It currently powers over two million internet connections.
++pdns_recursor(8) is a high performance, simple and secure recursing nameserver. It currently powers over two million internet connections.
.sp
- The recursor is configured via a configuration file, but each item in that file can be overridden on the command line\&.
+ The recursor is configured via a configuration file, but each item in that file can be overridden on the command line.
.sp
-@@ -242,7 +242,7 @@
- Website: http://wiki\&.powerdns\&.com, http://www\&.powerdns\&.com
+@@ -243,7 +243,7 @@
+ Website: http://wiki.powerdns.com, http://www.powerdns.com
.sp
.SH "SEE ALSO"
-rec_control(1)
+rec_control(8)
.sp
.SH "COPYING"
- Copyright \(co 2006 PowerDNS\&.COM BV\&. Free use of this software is granted under the terms of the GNU General Public License (GPL) version 2\&.
---- rec_control.1.orig 2010-01-03 15:26:42.000000000 +0100
-+++ rec_control.1 2010-01-05 10:35:14.000000000 +0100
+ Copyright \(co 2006 PowerDNS.COM BV. Free use of this software is granted under the terms of the GNU General Public License (GPL) version 2.
+--- rec_control.1.orig 2010-02-11 11:28:12.000000000 +0100
++++ rec_control.1 2010-02-11 11:27:38.000000000 +0100
@@ -5,7 +5,7 @@
.\" Manual:
.\" Source:
.\"
--.TH "REC_CONTROL" "1" "12/29/2009" "" ""
-+.TH "REC_CONTROL" "8" "12/29/2009" "" ""
+-.TH "REC_CONTROL" "1" "09/22/2009" "" ""
++.TH "REC_CONTROL" "8" "09/22/2009" "" ""
.\" disable hyphenation
.nh
.\" disable justification (adjust text to left margin only)
@@ -47,12 +47,12 @@
.sp
The commands that can be passed to the recursor are described on http://doc\&.powerdns\&.com/rec\-control\&.html
.sp
-@@ -105,7 +105,7 @@
- Website: http://wiki\&.powerdns\&.com, http://www\&.powerdns\&.com
+@@ -110,7 +110,7 @@
+ Website: http://wiki\&.powerdns\&.com, http://www\&.powerdns\&.com
.sp
.SH "SEE ALSO"
-pdns_recursor(1)
+pdns_recursor(8)
.sp
.SH "COPYING"
- Copyright \(co 2006 PowerDNS\&.COM BV\&. Free use of this software is granted under the terms of the GNU General Public License (GPL) version 2\&.
+ Copyright \(co 2006 PowerDNS\&.COM BV\&. Free use of this software is granted under the terms of the GNU General Public License (GPL) version 2\&.