aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-15 12:56:37 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-02-15 12:56:37 +0000
commit4f9ca7d4bfefeef7faba38b6d2f2be8f78fbd6fe (patch)
treed10bf3f4151005ffd044cb5501b795a157548075 /dns/powerdns/Makefile
parent0be8d00ea7b2d26776b4a4b77b1f57e8b2fffa00 (diff)
downloadports-4f9ca7d4bfefeef7faba38b6d2f2be8f78fbd6fe.tar.gz
ports-4f9ca7d4bfefeef7faba38b6d2f2be8f78fbd6fe.zip
Notes
Diffstat (limited to 'dns/powerdns/Makefile')
-rw-r--r--dns/powerdns/Makefile28
1 files changed, 7 insertions, 21 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index d7bcf28e2882..f8a99b79d50a 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -7,8 +7,10 @@
PORTNAME= powerdns
PORTVERSION= 2.9.19
+PORTREVISION= 1
CATEGORIES= dns ipv6
-MASTER_SITES= http://downloads.powerdns.com/releases/
+MASTER_SITES= http://downloads.powerdns.com/releases/ \
+ http://mirrors.evolva.ro/powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
MAINTAINER= tremere@cainites.net
@@ -18,10 +20,9 @@ BUILD_DEPENDS= bjam:${PORTSDIR}/devel/boost
USE_GMAKE= YES
USE_SUBMAKE= YES
-USE_REINPLACE= YES
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= YES
-CXXFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-modules="${CONFIGURE_MODULES} pipe" \
@@ -38,18 +39,7 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500037
-USE_RCORDER= pdns.sh
-RC_DIR= /etc/rc.d
-RC_SUFX=
-.else
-USE_RC_SUBR+= pdns.sh
-RC_DIR= ${PREFIX}/etc/rc.d
-RC_SUFX= .sh
-.endif
-
-PLIST_SUB+= RC_DIR=${RC_DIR} \
- RC_SUFX=${RC_SUFX}
+USE_RC_SUBR+= pdns
# use user config if possible
.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
@@ -102,11 +92,7 @@ PLIST_SUB+= WITHSQLLITE="@comment "
.endif
.if defined(POWERDNS_WITH_RECURSOR)
-.if ${OSVERSION} >= 500037
-USE_RCORDER+= pdns_recursor.sh
-.else
-USE_RC_SUBR+= pdns_recursor.sh
-.endif
+USE_RC_SUBR+= pdns_recursor
CONFIGURE_ARGS+= --enable-recursor
PLIST_SUB+= RECURSOR=""
.else
@@ -118,7 +104,7 @@ PLIST_SUB+= RECURSOR="@comment "
UCONTEXT!= ${AWK} '/setcontext/ { print "YES" }' \
/usr/include/ucontext.h
.if ${UCONTEXT} == ""
-BROKEN= "setcontext for recursor not found or FreeBSD version lower than 5.0"
+BROKEN= setcontext for recursor not found or FreeBSD version lower than 5.0
.endif
.endif
.endif