aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-06 12:44:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-06 12:44:50 +0000
commit7a59b9247faf8ecf47ff45044af7ad30e36e383d (patch)
treede0412b0a5262751e3cc2c71beca95a9a88d17ed /dns/powerdns/Makefile
parent380b29758f3712e9d1d29f29293d80bb8970f301 (diff)
downloadports-7a59b9247faf8ecf47ff45044af7ad30e36e383d.tar.gz
ports-7a59b9247faf8ecf47ff45044af7ad30e36e383d.zip
Notes
Diffstat (limited to 'dns/powerdns/Makefile')
-rw-r--r--dns/powerdns/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index 64333597c989..d12a244abcdf 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -7,7 +7,7 @@
PORTNAME= powerdns
PORTVERSION= 2.9.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
@@ -73,6 +73,15 @@ PLIST_SUB+= WITHLDAP=""
PLIST_SUB+= WITHLDAP="@comment "
.endif
+.if defined(WITH_SQLITE)
+LIB_DEPENDS= sqlite.2:${PORTSDIR}/${SQLITE_PORT}
+SQLITE_PORT?= databases/sqlite
+CONFIGURE_ARGS+= --enable-sqlite
+CONFIGURE_MODULES+= "gsqlite"
+.else
+CONFIGURE_ARGS+= --disable-sqlite
+.endif
+
.if defined(POWERDNS_WITH_RECURSOR)
USE_GCC=3.2
CONFIGURE_ARGS+= --enable-recursor
@@ -123,7 +132,7 @@ post-install:
.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
-.for i in pdns.conf pdns_mysql.sql pdns_postgresql.sql
+.for i in pdns.conf pdns_mysql.sql pdns_postgresql.sql pdns_sqlite.sql
${INSTALL_DATA} ${FILESDIR}/$i ${EXAMPLESDIR}/
.endfor
.endif