aboutsummaryrefslogtreecommitdiff
path: root/dns/powerdns
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-15 01:29:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-15 01:29:59 +0000
commitd140f474a1366a288c0873c2c40a4798e60b5029 (patch)
treee6524b6c0f4f10e831516db635bc3aef6f39b87b /dns/powerdns
parent4b953ec5c878a7969eff1cb9c942e4089bcf5495 (diff)
downloadports-d140f474a1366a288c0873c2c40a4798e60b5029.tar.gz
ports-d140f474a1366a288c0873c2c40a4798e60b5029.zip
Notes
Diffstat (limited to 'dns/powerdns')
-rw-r--r--dns/powerdns/Makefile3
-rw-r--r--dns/powerdns/distinfo4
-rw-r--r--dns/powerdns/files/patch-pdns_pdns_recursor_cc54
3 files changed, 28 insertions, 33 deletions
diff --git a/dns/powerdns/Makefile b/dns/powerdns/Makefile
index b522b29e984d..493ac6f1ecf6 100644
--- a/dns/powerdns/Makefile
+++ b/dns/powerdns/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= powerdns
-PORTVERSION= 2.9.16
-PORTREVISION= 7
+PORTVERSION= 2.9.17
CATEGORIES= dns ipv6
MASTER_SITES= http://downloads.powerdns.com/releases/
DISTNAME= pdns-${PORTVERSION}
diff --git a/dns/powerdns/distinfo b/dns/powerdns/distinfo
index f18a7179aea2..aac7de4a572f 100644
--- a/dns/powerdns/distinfo
+++ b/dns/powerdns/distinfo
@@ -1,2 +1,2 @@
-MD5 (pdns-2.9.16.tar.gz) = 7e9a859a5a21996dbf7b31cd61731dbc
-SIZE (pdns-2.9.16.tar.gz) = 767977
+MD5 (pdns-2.9.17.tar.gz) = 92489391182dc40012f1de7b2005ea93
+SIZE (pdns-2.9.17.tar.gz) = 782592
diff --git a/dns/powerdns/files/patch-pdns_pdns_recursor_cc b/dns/powerdns/files/patch-pdns_pdns_recursor_cc
index 74b7ca3d6f45..ebc3dfa3df96 100644
--- a/dns/powerdns/files/patch-pdns_pdns_recursor_cc
+++ b/dns/powerdns/files/patch-pdns_pdns_recursor_cc
@@ -1,33 +1,29 @@
---- pdns/pdns_recursor.cc.orig Tue Nov 16 21:21:59 2004
-+++ pdns/pdns_recursor.cc Tue Nov 16 21:22:31 2004
-@@ -22,6 +22,8 @@
- #include <errno.h>
- #include <map>
- #include <set>
-+#include <semaphore.h>
-+#include <pthread.h>
- #ifndef WIN32
- #include <netdb.h>
- #endif // WIN32
-@@ -42,21 +44,6 @@
- MemRecursorCache RC;
+--- pdns/pdns_recursor.cc.orig Wed Jan 12 15:30:19 2005
++++ pdns/pdns_recursor.cc Wed Jan 12 15:31:01 2005
+@@ -39,7 +39,7 @@
+ #include <fstream>
+ #include "recursor_cache.hh"
+
+-#ifdef FreeBSD // see cvstrac ticket #26
++#ifdef __FreeBSD__ // see cvstrac ticket #26
+ #include <pthread.h>
+ #include <semaphore.h>
+ #endif
+@@ -48,7 +48,8 @@
string s_programname="pdns_recursor";
--
--#ifndef WIN32
--extern "C" {
-- int sem_init(sem_t*, int, unsigned int){return 0;}
-- int sem_wait(sem_t*){return 0;}
-- int sem_trywait(sem_t*){return 0;}
-- int sem_post(sem_t*){return 0;}
-- int sem_getvalue(sem_t*, int*){return 0;}
-- pthread_t pthread_self(void){return (pthread_t) 0;}
-- int pthread_mutex_init(pthread_mutex_t *mutex, const pthread_mutexattr_t *mutexattr){ return 0; }
-- int pthread_mutex_lock(pthread_mutex_t *mutex){ return 0; }
-- int pthread_mutex_unlock(pthread_mutex_t *mutex) { return 0; }
--
--}
--#endif // WIN32
+
+-#if !WIN32 && !FreeBSD
++#ifndef WIN32
++#ifndef __FreeBSD__
+ extern "C" {
+ int sem_init(sem_t*, int, unsigned int){return 0;}
+ int sem_wait(sem_t*){return 0;}
+@@ -61,6 +62,7 @@
+ int pthread_mutex_unlock(pthread_mutex_t *mutex) { return 0; }
+
+ }
++#endif // __FreeBSD__
+ #endif // WIN32
StatBag S;
- ArgvMap &arg()