aboutsummaryrefslogtreecommitdiff
path: root/dns/rbllookup/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2004-11-06 22:25:28 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2004-11-06 22:25:28 +0000
commit946f6ba0e4ec0e0f6e7aa13f2d41d4045827bab4 (patch)
treea17482c30be4fe15246bc948705ffba11ddffad5 /dns/rbllookup/Makefile
parent10b8e22a359aeb64efd185f629880a68a026a786 (diff)
downloadports-946f6ba0e4ec0e0f6e7aa13f2d41d4045827bab4.tar.gz
ports-946f6ba0e4ec0e0f6e7aa13f2d41d4045827bab4.zip
Notes
Diffstat (limited to 'dns/rbllookup/Makefile')
-rw-r--r--dns/rbllookup/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/dns/rbllookup/Makefile b/dns/rbllookup/Makefile
new file mode 100644
index 000000000000..c366ec5d8ebd
--- /dev/null
+++ b/dns/rbllookup/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: rbllookup
+# Date created: 2004-07-14
+# Whom: Marcin Gondek <drixter@e-utp.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rbllookup
+PORTVERSION= 0.0.1.1
+CATEGORIES= dns mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= drixter@e-utp.net
+COMMENT= Check given IP/Host presence in 106 RBLs
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
+ ${SITE_PERL}/Term/ANSIColor.pm:${PORTSDIR}/devel/p5-Term-ANSIColor
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+PLIST_FILES= bin/rbllookup
+PORTDOCS= CHANGELOG INSTALL NOTES README TODO gpg.asc
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/rbl.pl ${PREFIX}/bin/rbllookup
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKDIR} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>