aboutsummaryrefslogtreecommitdiff
path: root/dns/rbllookup
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-22 21:47:38 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-22 21:47:38 +0000
commit04180c7fbf72965039b9f5fe5252ee99693023a9 (patch)
tree84c2f43f818acda540dd8ddd74030762b6a86d16 /dns/rbllookup
parente8dd31dfc2ccbb8a360bd3289e326f7f14813666 (diff)
downloadports-04180c7fbf72965039b9f5fe5252ee99693023a9.tar.gz
ports-04180c7fbf72965039b9f5fe5252ee99693023a9.zip
Notes
Diffstat (limited to 'dns/rbllookup')
-rw-r--r--dns/rbllookup/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/dns/rbllookup/Makefile b/dns/rbllookup/Makefile
index b0a621673e5b..19bb5799583d 100644
--- a/dns/rbllookup/Makefile
+++ b/dns/rbllookup/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rbllookup
PORTVERSION= 0.0.1.1
+PORTREVISION= 1
CATEGORIES= dns mail
MASTER_SITES= SF
@@ -12,8 +13,10 @@ COMMENT= Check given IP/Host presence in 106 RBLs
BUILD_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
p5-Term-ANSIColor>=0:${PORTSDIR}/devel/p5-Term-ANSIColor
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= rbl.pl
NO_BUILD= yes
+NO_WRKSUBDIR= yes
PLIST_FILES= bin/rbllookup
PORTDOCS= CHANGELOG INSTALL NOTES README TODO gpg.asc
@@ -21,8 +24,8 @@ PORTDOCS= CHANGELOG INSTALL NOTES README TODO gpg.asc
OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/rbl.pl ${STAGEDIR}${PREFIX}/bin/rbllookup
+ ${INSTALL_SCRIPT} ${WRKSRC}/rbl.pl ${STAGEDIR}${PREFIX}/bin/rbllookup
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- cd ${WRKDIR} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>