aboutsummaryrefslogtreecommitdiff
path: root/dns/sleuth/Makefile
diff options
context:
space:
mode:
authorMark Pulford <markp@FreeBSD.org>2001-06-15 12:46:45 +0000
committerMark Pulford <markp@FreeBSD.org>2001-06-15 12:46:45 +0000
commit670c3475e9da4c1c149be929ffc3f789788cb13a (patch)
tree4d564585e85da5d69d476d5f14f4c59602b884d5 /dns/sleuth/Makefile
parent07290919ca81ba8b3bf125f911629bcd44b4b5be (diff)
downloadports-670c3475e9da4c1c149be929ffc3f789788cb13a.tar.gz
ports-670c3475e9da4c1c149be929ffc3f789788cb13a.zip
Notes
Diffstat (limited to 'dns/sleuth/Makefile')
-rw-r--r--dns/sleuth/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/dns/sleuth/Makefile b/dns/sleuth/Makefile
new file mode 100644
index 000000000000..285126aada1f
--- /dev/null
+++ b/dns/sleuth/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: sleuth
+# Date created: Jun 15, 2001
+# Whom: Mark Pulford <mark@kyne.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sleuth
+PORTVERSION= 1.2
+CATEGORIES= net
+MASTER_SITES= ftp://atrey.karlin.mff.cuni.cz/pub/local/mj/net/
+
+MAINTAINER= markp@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/DNS.pm:${PORTSDIR}/net/p5-Net-DNS
+
+USE_PERL5= yes
+
+post-patch:
+ ${PERL} -pi -e "s|/etc/sleuth.conf|${PREFIX}/etc/sleuth.conf|g; \
+ s|#!/usr/bin/perl|#!${PERL}|g;" ${WRKSRC}/sleuth
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/sleuth ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/sleuth.conf ${PREFIX}/etc/sleuth.conf.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>