aboutsummaryrefslogtreecommitdiff
path: root/dns/totd
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-12 13:28:00 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-12 13:28:00 +0000
commit521887cacaf26cf295a50bdbda78e2365ceec2bc (patch)
tree76bbb17bfe0cc1686d0e46cf876d1e86b74e6b06 /dns/totd
parent2a248fb04a2f71ec0d5387e9c6855bd817c4994a (diff)
downloadports-521887cacaf26cf295a50bdbda78e2365ceec2bc.tar.gz
ports-521887cacaf26cf295a50bdbda78e2365ceec2bc.zip
Notes
Diffstat (limited to 'dns/totd')
-rw-r--r--dns/totd/Makefile13
-rw-r--r--dns/totd/files/patch-totd.c11
2 files changed, 19 insertions, 5 deletions
diff --git a/dns/totd/Makefile b/dns/totd/Makefile
index 754a8b3fcdc3..a0f5b8e83b9a 100644
--- a/dns/totd/Makefile
+++ b/dns/totd/Makefile
@@ -6,17 +6,17 @@
PORTNAME= totd
PORTVERSION= 1.5.1
+PORTREVISION= 1
CATEGORIES= dns ipv6
MASTER_SITES= ftp://ftp.pasta.cs.uit.no/pub/Vermicelli/
MAINTAINER= ports@FreeBSD.org
COMMENT= DNS proxy that supports IPv6 <==> IPv4 record translation
-MAN8= totd.8
+USE_RC_SUBR= yes
+GNU_CONFIGURE= yes
-USE_RC_SUBR= YES
-GNU_CONFIGURE= YES
-USE_REINPLACE= YES
+MAN8= totd.8
RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
@@ -25,8 +25,11 @@ RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
.if ${OSVERSION} >= 500000
EXTRA_PATCHES= ${FILESDIR}/extra-patch-ne_mesg.c \
${FILESDIR}/extra-patch-tcp_response.c
-.else
+.endif
+
post-patch:
+ @${REINPLACE_CMD} -e '/^CC/d' ${WRKSRC}/${MAKEFILE}.in
+.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's/%zd/%d/g' ${WRKSRC}/*.c
.endif
diff --git a/dns/totd/files/patch-totd.c b/dns/totd/files/patch-totd.c
new file mode 100644
index 000000000000..0c537b6b2551
--- /dev/null
+++ b/dns/totd/files/patch-totd.c
@@ -0,0 +1,11 @@
+--- totd.c.orig Wed Feb 2 12:10:31 2005
++++ totd.c Wed Apr 12 14:56:16 2006
+@@ -504,7 +504,7 @@
+ tvp = &tv_out;
+ if (T.debug > 2)
+ syslog (LOG_DEBUG, "next timeout after %ld s.",
+- tv_out.tv_sec);
++ (long)tv_out.tv_sec);
+ }
+ }
+