aboutsummaryrefslogtreecommitdiff
path: root/dns/unbound/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2009-06-16 13:35:00 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2009-06-16 13:35:00 +0000
commit010dc19b352b26402d621838b15c3dc7cb500337 (patch)
tree2dae7d0ad7dfe6aca70c482cc60e1b2a34768df2 /dns/unbound/Makefile
parent65e8eaca3054ef9c5f5066ee3ab1d7a3d745e457 (diff)
downloadports-010dc19b352b26402d621838b15c3dc7cb500337.tar.gz
ports-010dc19b352b26402d621838b15c3dc7cb500337.zip
Notes
Diffstat (limited to 'dns/unbound/Makefile')
-rw-r--r--dns/unbound/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index bfd76f6832e2..e2ecc5167e2d 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= unbound
-PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTVERSION= 1.3.0
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
@@ -33,9 +32,22 @@ PORTDOCS= CREDITS Changelog FEATURES LICENSE README README.svn \
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES= pkg-install pkg-deinstall
+PLIST_SUB+= PYTHON=${PYTHON}
OPTIONS= LIBEVENT "is useful when using many (10000) outgoing ports" off \
- THREADS "build with threads support" on
+ THREADS "build with threads support" on \
+ PYTHON "build python bindings" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_PYTHON)
+USE_PYTHON= yes
+CONFIGURE_ARGS+= --with-pyunbound=yes --with-pythonmodule=yes
+BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig13
+PYTHON=
+.else
+PYTHON= "@comment "
+.endif
.include <bsd.port.pre.mk>