aboutsummaryrefslogtreecommitdiff
path: root/dns/unbound/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2008-04-29 07:35:14 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2008-04-29 07:35:14 +0000
commit18fa7d9169bc8cdddd4d4d88e1a5f6b61e9e7689 (patch)
tree29fdcd761e4f211ee95fd6fae06e18ffcb1405d9 /dns/unbound/Makefile
parent081b7b28d55bd76e6f038a6c7cc0744a25442f19 (diff)
downloadports-18fa7d9169bc8cdddd4d4d88e1a5f6b61e9e7689.tar.gz
ports-18fa7d9169bc8cdddd4d4d88e1a5f6b61e9e7689.zip
Notes
Diffstat (limited to 'dns/unbound/Makefile')
-rw-r--r--dns/unbound/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
new file mode 100644
index 000000000000..6a74fbe9d3ed
--- /dev/null
+++ b/dns/unbound/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: unbound
+# Date created: 25 Apr 2008
+# Whom: Sergey Matveychuk <sem@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= unbound
+PORTVERSION= 0.11
+CATEGORIES= dns
+MASTER_SITES= http://unbound.net/downloads/
+
+MAINTAINER= sem@FreeBSD.org
+COMMENT= A validating, recursive, and caching DNS resolver
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+USE_RC_SUBR= unbound
+
+MAN1= unbound-host.1
+MAN3= libunbound.3
+MAN5= unbound.conf.5
+MAN8= unbound.8 unbound-checkconf.8
+
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+SUB_FILES= pkg-install pkg-deinstall
+
+OPTIONS= LIBEVENT "is useful when using many (10000) outgoing ports" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LIBEVENT)
+LIB_DEPENDS+= event:${PORTSDIR}/devel/libevent
+CONFIGURE_ARGS+= --with-libevent=${PREFIX}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's#/usr/local/etc/unbound/unbound.pid#/var/run/unbound/unbound.pid#' ${WRKSRC}/doc/example.conf ${WRKSRC}/doc/unbound.conf.5
+
+pre-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+.include <bsd.port.post.mk>