aboutsummaryrefslogtreecommitdiff
path: root/dns/unbound
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2008-12-18 15:41:14 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2008-12-18 15:41:14 +0000
commitd6d4e4e6325698caa9da33266ef9be0555a46e01 (patch)
tree0fe3fd909e5f74759c339202bd03c9ec0855c46c /dns/unbound
parentb649424174a63f0a364e4a14d421d370174ce531 (diff)
downloadports-d6d4e4e6325698caa9da33266ef9be0555a46e01.tar.gz
ports-d6d4e4e6325698caa9da33266ef9be0555a46e01.zip
Notes
Diffstat (limited to 'dns/unbound')
-rw-r--r--dns/unbound/Makefile1
-rw-r--r--dns/unbound/files/patch-daemon-unbound.c24
2 files changed, 25 insertions, 0 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index e2713c174d3e..e033b82e39d6 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -7,6 +7,7 @@
PORTNAME= unbound
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
diff --git a/dns/unbound/files/patch-daemon-unbound.c b/dns/unbound/files/patch-daemon-unbound.c
new file mode 100644
index 000000000000..65744c811fbb
--- /dev/null
+++ b/dns/unbound/files/patch-daemon-unbound.c
@@ -0,0 +1,24 @@
+--- daemon/unbound.c.orig 2008-11-20 12:48:36.000000000 +0300
++++ daemon/unbound.c 2008-12-18 17:36:58.000000000 +0300
+@@ -345,8 +345,6 @@
+ * a fork error could not be printed since daemonize closed stderr.*/
+ if(cfg->use_syslog) {
+ log_init(cfg->logfile, cfg->use_syslog, cfg->chrootdir);
+- /* but syslog is not really opened by glibc until first msg */
+- log_info("open syslog, startup in progress");
+ }
+ /* if using a logfile, we cannot open it because the logfile would
+ * be created with the wrong permissions, we cannot chown it because
+@@ -516,7 +514,11 @@
+ if(!done_setup) {
+ perform_setup(daemon, cfg, debug_mode, &cfgfile);
+ done_setup = 1;
+- } else log_init(cfg->logfile, cfg->use_syslog, cfg->chrootdir);
++ } else {
++ /* reopen log after HUP to facilitate log rotation */
++ if(!cfg->use_syslog)
++ log_init(cfg->logfile, 0, cfg->chrootdir);
++ }
+ /* work */
+ daemon_fork(daemon);
+