aboutsummaryrefslogtreecommitdiff
path: root/dns/unbound
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-07-09 16:30:19 +0000
committerChris Rees <crees@FreeBSD.org>2011-07-09 16:30:19 +0000
commitc32d99baaf0e55342a9afe3214d7921367c458d9 (patch)
treee9ee42507efe2eafc28d03d63e6a6279f35cfeef /dns/unbound
parentd370880c749ddb189337f7237fc453f6ef229834 (diff)
downloadports-c32d99baaf0e55342a9afe3214d7921367c458d9.tar.gz
ports-c32d99baaf0e55342a9afe3214d7921367c458d9.zip
Notes
Diffstat (limited to 'dns/unbound')
-rw-r--r--dns/unbound/Makefile7
-rw-r--r--dns/unbound/files/pkg-install.in17
2 files changed, 2 insertions, 22 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index a374251db115..c2966876b84e 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -19,6 +19,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE} --with-ldns-builtin
USE_LDCONFIG= yes
+USERS= ${PORTNAME}
+
USE_RC_SUBR= unbound
MAN1= unbound-host.1
@@ -29,8 +31,6 @@ MAN8= unbound.8 unbound-anchor.8 unbound-control.8 unbound-checkconf.8
PORTDOCS= CREDITS Changelog FEATURES LICENSE README README.svn \
README.tests TODO control_proto_spec.txt ietf67-design-02.odp \
ietf67-design-02.pdf requirements.txt
-PKGINSTALL= ${WRKDIR}/pkg-install
-PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES= pkg-install pkg-deinstall
PLIST_SUB+= PYTHON=${PYTHON}
@@ -84,9 +84,6 @@ post-patch:
@${MKDIR} ${WRKSRC}/balancer
@${RM} ${WRKSRC}/util/configlexer.c
-pre-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.if !defined(NOPORTDOCS)
diff --git a/dns/unbound/files/pkg-install.in b/dns/unbound/files/pkg-install.in
index 56ff09006d99..5a5c026be37e 100644
--- a/dns/unbound/files/pkg-install.in
+++ b/dns/unbound/files/pkg-install.in
@@ -4,27 +4,10 @@
#
PW=/usr/sbin/pw
-UID=59
USER="unbound"
PREFIX="%%PREFIX%%"
case $2 in
-
-PRE-INSTALL)
- if ${PW} user show "${USER}" 2>/dev/null; then
- echo "You already have a user \"${USER}\", so I will use it."
- else
- if ${PW} useradd ${USER} -u ${UID} -g daemon -h - \
- -d "/nonexistent" -s /usr/sbin/nologin -c "unbound dns resolver"
- then
- echo "Added user \"${USER}\"."
- else
- echo "Adding user \"${USER}\" failed..."
- exit 1
- fi
- fi
- ;;
-
POST-INSTALL)
chown "${USER}" $PREFIX/etc/unbound
;;