aboutsummaryrefslogtreecommitdiff
path: root/dns/unbound
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2008-06-16 21:31:38 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2008-06-16 21:31:38 +0000
commitb663a290a5cffea8f4f24e6be89a7586e8544e22 (patch)
tree485be19e946c63c526d837351fbcbfe477d46190 /dns/unbound
parentb977a2fc921460d1ab94075f8d3f362b8a805934 (diff)
downloadports-b663a290a5cffea8f4f24e6be89a7586e8544e22.tar.gz
ports-b663a290a5cffea8f4f24e6be89a7586e8544e22.zip
Notes
Diffstat (limited to 'dns/unbound')
-rw-r--r--dns/unbound/Makefile16
-rw-r--r--dns/unbound/files/patch-configure11
2 files changed, 26 insertions, 1 deletions
diff --git a/dns/unbound/Makefile b/dns/unbound/Makefile
index c9eb41a6c128..9e85793986d5 100644
--- a/dns/unbound/Makefile
+++ b/dns/unbound/Makefile
@@ -7,6 +7,7 @@
PORTNAME= unbound
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= dns
MASTER_SITES= http://unbound.net/downloads/
@@ -14,7 +15,10 @@ MAINTAINER= sem@FreeBSD.org
COMMENT= A validating, recursive, and caching DNS resolver
USE_GMAKE= yes
+USE_OPENSSL= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
USE_LDCONFIG= yes
USE_RC_SUBR= unbound
@@ -24,6 +28,8 @@ MAN3= libunbound.3
MAN5= unbound.conf.5
MAN8= unbound.8 unbound-checkconf.8
+PORTDOCS= CREDITS Changelog FEATURES LICENSE README README.svn \
+ README.tests TODO plan requirements.txt
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
SUB_FILES= pkg-install pkg-deinstall
@@ -34,7 +40,9 @@ OPTIONS= LIBEVENT "is useful when using many (10000) outgoing ports" off
.if defined(WITH_LIBEVENT)
LIB_DEPENDS+= event:${PORTSDIR}/devel/libevent
-CONFIGURE_ARGS+= --with-libevent=${PREFIX}
+CONFIGURE_ARGS+= --with-libevent=${LOCALBASE}
+.else
+CONFIGURE_ARGS+= --with-libevent=no
.endif
post-patch:
@@ -45,5 +53,11 @@ pre-install:
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}; \
+ for f in ${PORTDOCS}; do \
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} $${f} ${DOCSDIR}/; \
+ done
+.endif
.include <bsd.port.post.mk>
diff --git a/dns/unbound/files/patch-configure b/dns/unbound/files/patch-configure
new file mode 100644
index 000000000000..6200b21ac2cd
--- /dev/null
+++ b/dns/unbound/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2008-06-17 01:16:01.000000000 +0400
++++ configure 2008-06-17 01:16:29.000000000 +0400
+@@ -22125,7 +22125,7 @@
+ withval="no"
+ fi
+
+-if test x_$withval == x_yes -o x_$withval != x_no; then
++if test x_$withval = x_yes -o x_$withval != x_no; then
+ { echo "$as_me:$LINENO: checking for libevent" >&5
+ echo $ECHO_N "checking for libevent... $ECHO_C" >&6; }
+ if test x_$withval = x_ -o x_$withval = x_yes; then