aboutsummaryrefslogtreecommitdiff
path: root/dns/vizone/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2007-08-13 21:37:31 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2007-08-13 21:37:31 +0000
commitce3fafbe36fe35377cdd36c0716d4c112949a540 (patch)
tree379335a16bfdabff06b0153cd84b782f7d9c1558 /dns/vizone/Makefile
parentb90d3677734da27410603242382dfe01c2e6454c (diff)
Notes
Diffstat (limited to 'dns/vizone/Makefile')
-rw-r--r--dns/vizone/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/dns/vizone/Makefile b/dns/vizone/Makefile
new file mode 100644
index 000000000000..764ee7ec75aa
--- /dev/null
+++ b/dns/vizone/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: vizone
+# Date created: 13 Aug 2007
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vizone
+PORTVERSION= 0.1
+CATEGORIES= dns
+MASTER_SITES= http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Updates the serialnumber in one or more zonefiles
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+PORTEXAMPLES= example.tld
+PLIST_FILES= bin/vizone bin/updserial
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PERL}|' ${WRKSRC}/updserial
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/updserial ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.tld ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>