aboutsummaryrefslogtreecommitdiff
path: root/dns/yadifa/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-09-19 17:53:21 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-09-19 17:53:21 +0000
commit7aa6c96ebd94d4d6cd4373d683c9c30f459b9243 (patch)
tree06201358822d795c970145911f642a6b8e1f8b2c /dns/yadifa/Makefile
parent25bea540929db8fc8b71e88602e439c6d41370d1 (diff)
downloadports-7aa6c96ebd94d4d6cd4373d683c9c30f459b9243.tar.gz
ports-7aa6c96ebd94d4d6cd4373d683c9c30f459b9243.zip
Notes
Diffstat (limited to 'dns/yadifa/Makefile')
-rw-r--r--dns/yadifa/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/dns/yadifa/Makefile b/dns/yadifa/Makefile
index 81463fecd413..ac06f0a55cc6 100644
--- a/dns/yadifa/Makefile
+++ b/dns/yadifa/Makefile
@@ -2,25 +2,35 @@
# $FreeBSD$
PORTNAME= yadifa
-PORTVERSION= 1.0.3
-PORTREVISION= 3
-DISTVERSIONSUFFIX= -2880
+PORTVERSION= 2.0.0
+DISTVERSIONSUFFIX= -4192
CATEGORIES= dns ipv6
-MASTER_SITES= http://cdn.yadifa.eu/sites/default/files/releases/
+MASTER_SITES= http://cdn.yadifa.eu/sites/default/files/releases/ LOCAL/mat/yadifa
MAINTAINER= mat@FreeBSD.org
COMMENT= YADIFA is an authoritative Name Server with DNSSEC capabilities
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= DOCS EXAMPLES TCL
+OPTIONS_DEFINE= DOCS EXAMPLES TCL RRL MESSAGES NSID
+OPTIONS_DEFAULT= RRL NSID
+OPTIONS_SUB= yes
+
+RRL_DESC= Response Rate Limiting
+MESSAGES_DESC= Use messages instead of send (if many ip aliases)
+NSID_DESC= Name Server Identifier Option
GNU_CONFIGURE= yes
-USES= libtool
+USES= libtool tar:tgz autoreconf compiler:c11
USE_OPENSSL= yes
CONFIGURE_ARGS= --localstatedir=/var
+
TCL_USES= tcl
TCL_CONFIGURE_ENABLE= tcl
+RRL_CONFIGURE_ENABLE= rrl
+MESSAGES_CONFIGURE_ENABLE= messages
+NSID_CONFIGURE_ENABLE= nsid
USE_RC_SUBR= ${PORTNAME}d