aboutsummaryrefslogtreecommitdiff
path: root/dns/yadifa/Makefile
diff options
context:
space:
mode:
authorLeo Vandewoestijne <freebsd@dns.company>2021-08-12 14:42:20 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-08-12 14:43:20 +0000
commitd04985d352e9dc1c63061e292734689148909410 (patch)
treec813a281bab1cb7810a382874421f10af99404e7 /dns/yadifa/Makefile
parentea108b209da047ec7e974ffb75414288401b53fc (diff)
Diffstat (limited to 'dns/yadifa/Makefile')
-rw-r--r--dns/yadifa/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/dns/yadifa/Makefile b/dns/yadifa/Makefile
index 153eb85e6518..db4b9f513ae5 100644
--- a/dns/yadifa/Makefile
+++ b/dns/yadifa/Makefile
@@ -1,6 +1,6 @@
PORTNAME= yadifa
-DISTVERSION= 2.4.1
-DISTVERSIONSUFFIX= -9916
+DISTVERSION= 2.5.0
+DISTVERSIONSUFFIX= -10188
CATEGORIES= dns
MASTER_SITES= https://www.yadifa.eu/sites/default/files/releases/ \
https://dns.company/downloads/yadifa/
@@ -17,6 +17,15 @@ USE_RC_SUBR= ${PORTNAME}d
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var
+SUB_LIST+= GROUPS="${GROUPS}" \
+ USERS="${USERS}"
+
+USERS= yadifa
+GROUPS= yadifa
+
+PLIST_SUB= GROUPS="${GROUPS}" \
+ USERS="${USERS}"
+
PORTDOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README VERSION
OPTIONS_DEFINE= CTRL DDNS DNSSECTOOLS DOCS ECDSA EXAMPLES KEYGEN \
@@ -39,16 +48,16 @@ ZONESIGN_DESC= Zonesign tool
CTRL_CONFIGURE_OFF= --disable-ctrl
DDNS_CONFIGURE_OFF= --disable-dynupdate
+DNSSECTOOLS_CONFIGURE_OFF= --disable-dnssec-tools
ECDSA_CONFIGURE_OFF= --disable-ecdsa
+KEYGEN_CONFIGURE_ENABLE= keygen
LARGEFILE_CONFIGURE_OFF= --disable-largefile
MASTER_CONFIGURE_OFF= --disable-master
NSID_CONFIGURE_OFF= --disable-nsid
RRL_CONFIGURE_OFF= --disable-rrl
RRSIG_CONFIGURE_OFF= --disable-rrsig-management
TCL_USES= tcl
-DNSSECTOOLS_OFF= --disable-dnssec-tools
-KEYGEN_ENABLE= keygen
-ZONESIGN_ENABLE= zonesign
+ZONESIGN_CONFIGURE_ENABLE= zonesign
post-configure:
${REINPLACE_CMD} -e 's|^docdir = .*|docdir = ${EXAMPLESDIR}|' ${WRKSRC}/etc/Makefile