aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-10-24 08:05:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-10-24 08:05:48 +0000
commit545f02d9a4241e51130120f0c4039dc25cb5c96b (patch)
tree30228933d5cdcc6176fe884fd4a0ed3773b5c233 /dns
parent3feec6d6b1e564f5fbe0106a62cad4399ab38adf (diff)
downloadports-545f02d9a4241e51130120f0c4039dc25cb5c96b.tar.gz
ports-545f02d9a4241e51130120f0c4039dc25cb5c96b.zip
Update to 9.11.5.
Notes
Notes: svn path=/head/; revision=482890
Diffstat (limited to 'dns')
-rw-r--r--dns/bind911/Makefile2
-rw-r--r--dns/bind911/distinfo6
-rw-r--r--dns/bind911/files/extrapatch-bind-min-override-ttl28
-rw-r--r--dns/bind911/files/patch-bin_named_include_named_globals.h4
-rw-r--r--dns/bind911/files/patch-configure8
5 files changed, 24 insertions, 24 deletions
diff --git a/dns/bind911/Makefile b/dns/bind911/Makefile
index 29334e4ea43d..b7108e1523d1 100644
--- a/dns/bind911/Makefile
+++ b/dns/bind911/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
USES= cpe libedit
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.11.4-P2
+ISCVERSION= 9.11.5
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind911/distinfo b/dns/bind911/distinfo
index 064fbda01f96..c404ad2f4437 100644
--- a/dns/bind911/distinfo
+++ b/dns/bind911/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1537447447
-SHA256 (bind-9.11.4-P2.tar.gz) = a85af7b629109d41285c7adeae1515daac638bbe4d5dc30d1f4b343dff09d811
-SIZE (bind-9.11.4-P2.tar.gz) = 9617963
+TIMESTAMP = 1540325506
+SHA256 (bind-9.11.5.tar.gz) = a4cae11dad954bdd4eb592178f875bfec09fcc7e29fe0f6b7a4e5b5c6bc61322
+SIZE (bind-9.11.5.tar.gz) = 8810710
diff --git a/dns/bind911/files/extrapatch-bind-min-override-ttl b/dns/bind911/files/extrapatch-bind-min-override-ttl
index d99a4463a3b2..8abc2b7be407 100644
--- a/dns/bind911/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind911/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
---- bin/named/config.c.orig 2018-06-10 06:06:33 UTC
+--- bin/named/config.c.orig 2018-10-06 01:36:17 UTC
+++ bin/named/config.c
-@@ -176,6 +176,8 @@ options {\n\
+@@ -177,6 +177,8 @@ options {\n\
" max-acache-size 16M;\n\
max-cache-size 90%;\n\
max-cache-ttl 604800; /* 1 week */\n\
@@ -9,9 +9,9 @@
max-clients-per-query 100;\n\
max-ncache-ttl 10800; /* 3 hours */\n\
max-recursion-depth 7;\n\
---- bin/named/server.c.orig 2018-06-10 06:06:33 UTC
+--- bin/named/server.c.orig 2018-10-06 01:36:17 UTC
+++ bin/named/server.c
-@@ -3692,6 +3692,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -3695,6 +3695,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -28,20 +28,20 @@
result = ns_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-06-10 06:06:33 UTC
+--- lib/dns/include/dns/view.h.orig 2018-10-06 01:36:17 UTC
+++ lib/dns/include/dns/view.h
-@@ -150,6 +150,8 @@ struct dns_view {
- isc_boolean_t requestnsid;
- isc_boolean_t sendcookie;
+@@ -152,6 +152,8 @@ struct dns_view {
+ bool requestnsid;
+ bool sendcookie;
dns_ttl_t maxcachettl;
+ dns_ttl_t mincachettl;
+ dns_ttl_t overridecachettl;
dns_ttl_t maxncachettl;
- isc_uint32_t nta_lifetime;
- isc_uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-06-10 06:06:33 UTC
+ uint32_t nta_lifetime;
+ uint32_t nta_recheck;
+--- lib/dns/resolver.c.orig 2018-10-06 01:36:17 UTC
+++ lib/dns/resolver.c
-@@ -5473,6 +5473,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5474,6 +5474,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -60,9 +60,9 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-06-10 06:06:33 UTC
+--- lib/isccfg/namedconf.c.orig 2018-10-06 01:36:17 UTC
+++ lib/isccfg/namedconf.c
-@@ -1770,6 +1770,8 @@ view_clauses[] = {
+@@ -1773,6 +1773,8 @@ view_clauses[] = {
#endif
{ "max-acache-size", &cfg_type_sizenodefault, 0 },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind911/files/patch-bin_named_include_named_globals.h b/dns/bind911/files/patch-bin_named_include_named_globals.h
index 9f5abb33c1c5..159550d369dc 100644
--- a/dns/bind911/files/patch-bin_named_include_named_globals.h
+++ b/dns/bind911/files/patch-bin_named_include_named_globals.h
@@ -1,8 +1,8 @@
We reference the pid file as being run/named/pid everywere else.
---- bin/named/include/named/globals.h.orig 2018-06-10 06:06:33 UTC
+--- bin/named/include/named/globals.h.orig 2018-10-06 01:36:17 UTC
+++ bin/named/include/named/globals.h
-@@ -138,7 +138,7 @@ EXTERN isc_boolean_t ns_g_forcelock IN
+@@ -139,7 +139,7 @@ EXTERN bool ns_g_forcelock INIT(false)
#if NS_RUN_PID_DIR
EXTERN const char * ns_g_defaultpidfile INIT(NS_LOCALSTATEDIR
"/run/named/"
diff --git a/dns/bind911/files/patch-configure b/dns/bind911/files/patch-configure
index 550d35b914a4..3d88a1052f83 100644
--- a/dns/bind911/files/patch-configure
+++ b/dns/bind911/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-06-10 06:06:33 UTC
+--- configure.orig 2018-10-06 01:36:17 UTC
+++ configure
-@@ -14961,27 +14961,9 @@ done
+@@ -15106,27 +15106,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -15024,47 +15006,7 @@ $as_echo "no" >&6; } ;;
+@@ -15169,47 +15151,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -23847,7 +23789,7 @@ $as_echo "" >&6; }
+@@ -23938,7 +23880,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).