aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
commit9dff3523203bdda7ae358dcff3eb5a5ef3e54d33 (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /dns
parent2e4b740f2cc9a250b2c6056d8706e15d3bfa9763 (diff)
downloadports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.tar.gz
ports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Notes
Notes: svn path=/head/; revision=481365
Diffstat (limited to 'dns')
-rw-r--r--dns/p5-AnyEvent-CacheDNS/Makefile4
-rw-r--r--dns/p5-BIND-Config-Parser/Makefile4
-rw-r--r--dns/p5-DNS-EasyDNS/Makefile4
-rw-r--r--dns/p5-DSC/Makefile4
-rw-r--r--dns/p5-Data-Validate-Domain/Makefile4
-rw-r--r--dns/p5-IO-Async-Resolver-DNS/Makefile4
-rw-r--r--dns/p5-Mozilla-PublicSuffix/Makefile2
-rw-r--r--dns/p5-Net-Amazon-Route53/Makefile4
-rw-r--r--dns/p5-Net-Bonjour/Makefile4
-rw-r--r--dns/p5-Net-DNS-Async/Makefile4
-rw-r--r--dns/p5-Net-DNS-Lite/Makefile4
-rw-r--r--dns/p5-Net-DNS-RR-SRV-Helper/Makefile4
-rw-r--r--dns/p5-Net-DNS-Resolver-Mock/Makefile4
-rw-r--r--dns/p5-Net-DNS-Resolver-Programmable/Makefile4
-rw-r--r--dns/p5-Net-DNS-TestNS/Makefile4
-rw-r--r--dns/p5-Net-DNS-ToolKit/Makefile4
-rw-r--r--dns/p5-Net-DNS-ZoneFile-Fast/Makefile4
-rw-r--r--dns/p5-Net-DNSBL-MultiDaemon/Makefile4
-rw-r--r--dns/p5-Net-DNSBL-Statistics/Makefile4
-rw-r--r--dns/p5-Net-Domain-ExpireDate/Makefile4
-rw-r--r--dns/p5-Net-Nslookup/Makefile4
-rw-r--r--dns/p5-Net-RBLClient/Makefile4
-rw-r--r--dns/p5-POE-Component-Client-DNS-Recursive/Makefile4
-rw-r--r--dns/p5-POE-Component-Client-DNS/Makefile4
-rw-r--r--dns/p5-POE-Component-Client-DNSBL/Makefile4
-rw-r--r--dns/p5-POE-Component-Resolver/Makefile4
-rw-r--r--dns/p5-POE-Component-Server-DNS/Makefile4
-rw-r--r--dns/p5-Tie-DNS/Makefile4
-rw-r--r--dns/p5-pgeodns/Makefile4
29 files changed, 57 insertions, 57 deletions
diff --git a/dns/p5-AnyEvent-CacheDNS/Makefile b/dns/p5-AnyEvent-CacheDNS/Makefile
index f2ee2ca62dad..4de0b49d1dca 100644
--- a/dns/p5-AnyEvent-CacheDNS/Makefile
+++ b/dns/p5-AnyEvent-CacheDNS/Makefile
@@ -13,8 +13,8 @@ COMMENT= Simple DNS resolver with caching
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-AnyEvent>=0:devel/p5-AnyEvent
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-AnyEvent>=0:devel/p5-AnyEvent
NO_ARCH= yes
USE_PERL5= modbuild
diff --git a/dns/p5-BIND-Config-Parser/Makefile b/dns/p5-BIND-Config-Parser/Makefile
index 2867086561da..5f48ca516136 100644
--- a/dns/p5-BIND-Config-Parser/Makefile
+++ b/dns/p5-BIND-Config-Parser/Makefile
@@ -12,8 +12,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Parse BIND Config files
-BUILD_DEPENDS= p5-Parse-RecDescent>=0:devel/p5-Parse-RecDescent
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Parse-RecDescent>=0:devel/p5-Parse-RecDescent
USES= perl5
USE_PERL5= configure
diff --git a/dns/p5-DNS-EasyDNS/Makefile b/dns/p5-DNS-EasyDNS/Makefile
index 099237bda3a6..60ab938cdc7c 100644
--- a/dns/p5-DNS-EasyDNS/Makefile
+++ b/dns/p5-DNS-EasyDNS/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Update your EasyDNS dynamic DNS entries
-BUILD_DEPENDS= p5-libwww>=0:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-libwww>=0:www/p5-libwww
USES= perl5
USE_PERL5= configure
diff --git a/dns/p5-DSC/Makefile b/dns/p5-DSC/Makefile
index fa921d55af09..82ca9dc53164 100644
--- a/dns/p5-DSC/Makefile
+++ b/dns/p5-DSC/Makefile
@@ -12,7 +12,8 @@ COMMENT= DNS Statistics Presenter Perl Library
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ploticus>=2.40:math/ploticus \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= ploticus>=2.40:math/ploticus \
p5-CGI-Untaint>=1.26:www/p5-CGI-Untaint \
p5-File-NFSLock>=1.21:devel/p5-File-NFSLock \
p5-Hash-Merge>=0.299:textproc/p5-Hash-Merge \
@@ -24,7 +25,6 @@ BUILD_DEPENDS= ploticus>=2.40:math/ploticus \
p5-URI>=1.73:net/p5-URI \
p5-XML-Simple>=2.24:textproc/p5-XML-Simple
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/dns/p5-Data-Validate-Domain/Makefile b/dns/p5-Data-Validate-Domain/Makefile
index e3f4cea0a526..27f6ac57c97c 100644
--- a/dns/p5-Data-Validate-Domain/Makefile
+++ b/dns/p5-Data-Validate-Domain/Makefile
@@ -12,8 +12,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Data::Validate::Domain - domain validation methods
-BUILD_DEPENDS= p5-Net-Domain-TLD>=0:dns/p5-Net-Domain-TLD
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-Domain-TLD>=0:dns/p5-Net-Domain-TLD
USES= perl5
USE_PERL5= configure
diff --git a/dns/p5-IO-Async-Resolver-DNS/Makefile b/dns/p5-IO-Async-Resolver-DNS/Makefile
index fdbb91cd3b73..e4960ad66781 100644
--- a/dns/p5-IO-Async-Resolver-DNS/Makefile
+++ b/dns/p5-IO-Async-Resolver-DNS/Makefile
@@ -13,11 +13,11 @@ COMMENT= Resolve DNS queries using IO::Async
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Future>=0:devel/p5-Future \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Future>=0:devel/p5-Future \
p5-IO-Async>=0.52:devel/p5-IO-Async \
p5-List-UtilsBy>=0.07:devel/p5-List-UtilsBy \
p5-Net-DNS>=0:dns/p5-Net-DNS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USE_PERL5= configure
diff --git a/dns/p5-Mozilla-PublicSuffix/Makefile b/dns/p5-Mozilla-PublicSuffix/Makefile
index 871f27307f1e..86a5649e656f 100644
--- a/dns/p5-Mozilla-PublicSuffix/Makefile
+++ b/dns/p5-Mozilla-PublicSuffix/Makefile
@@ -15,8 +15,8 @@ COMMENT= Get public suffix of domain name via Mozilla Public Suffix List
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${RUN_DEPENDS}
PATCH_DEPENDS= public_suffix_list>=0:dns/public_suffix_list
+BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-URI>=0:net/p5-URI
USES= perl5
diff --git a/dns/p5-Net-Amazon-Route53/Makefile b/dns/p5-Net-Amazon-Route53/Makefile
index dbc902622af6..3f0671cba915 100644
--- a/dns/p5-Net-Amazon-Route53/Makefile
+++ b/dns/p5-Net-Amazon-Route53/Makefile
@@ -14,13 +14,13 @@ COMMENT= Manage your DNS entries on Amazon's Route53 service
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Crypt-SSLeay>=0:security/p5-Crypt-SSLeay \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Crypt-SSLeay>=0:security/p5-Crypt-SSLeay \
p5-Digest-HMAC>=0:security/p5-Digest-HMAC \
p5-HTML-Parser>=0:www/p5-HTML-Parser \
p5-Mouse>=0:devel/p5-Mouse \
p5-XML-Bare>=0:textproc/p5-XML-Bare \
p5-libwww>=0:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= py[23][0-9]-boto-devel-[0-9]*
diff --git a/dns/p5-Net-Bonjour/Makefile b/dns/p5-Net-Bonjour/Makefile
index 1848ac6b4a8e..ba0d3de8f160 100644
--- a/dns/p5-Net-Bonjour/Makefile
+++ b/dns/p5-Net-Bonjour/Makefile
@@ -14,8 +14,8 @@ COMMENT= Module for DNS service discovery
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Net-DNS>=0.5:dns/p5-Net-DNS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0.5:dns/p5-Net-DNS
USES= perl5
USE_PERL5= configure
diff --git a/dns/p5-Net-DNS-Async/Makefile b/dns/p5-Net-DNS-Async/Makefile
index 110c06fa748a..44ed8a954d81 100644
--- a/dns/p5-Net-DNS-Async/Makefile
+++ b/dns/p5-Net-DNS-Async/Makefile
@@ -14,8 +14,8 @@ COMMENT= Asynchronous DNS helper for high volume applications
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
USES= perl5
USE_PERL5= configure
diff --git a/dns/p5-Net-DNS-Lite/Makefile b/dns/p5-Net-DNS-Lite/Makefile
index fa2a88766450..97a36866dc11 100644
--- a/dns/p5-Net-DNS-Lite/Makefile
+++ b/dns/p5-Net-DNS-Lite/Makefile
@@ -14,8 +14,8 @@ COMMENT= Pure-Perl DNS resolver with support for timeout
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-List-MoreUtils>=0:lang/p5-List-MoreUtils
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-List-MoreUtils>=0:lang/p5-List-MoreUtils
TEST_DEPENDS= p5-Cache-LRU>=0:devel/p5-Cache-LRU \
p5-Test-Requires>=0:devel/p5-Test-Requires
diff --git a/dns/p5-Net-DNS-RR-SRV-Helper/Makefile b/dns/p5-Net-DNS-RR-SRV-Helper/Makefile
index 7f3b373d756d..7b818e97bfd4 100644
--- a/dns/p5-Net-DNS-RR-SRV-Helper/Makefile
+++ b/dns/p5-Net-DNS-RR-SRV-Helper/Makefile
@@ -12,9 +12,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= vvelox@vvelox.net
COMMENT= Orders SRV records by priority and weight for Net::DNS
-BUILD_DEPENDS= p5-Net-DNS>=0.68:dns/p5-Net-DNS \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0.68:dns/p5-Net-DNS \
p5-Sort-Naturally>=1.03:textproc/p5-Sort-Naturally
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/dns/p5-Net-DNS-Resolver-Mock/Makefile b/dns/p5-Net-DNS-Resolver-Mock/Makefile
index 768b64511c87..b70608e3e245 100644
--- a/dns/p5-Net-DNS-Resolver-Mock/Makefile
+++ b/dns/p5-Net-DNS-Resolver-Mock/Makefile
@@ -14,8 +14,8 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
NO_ARCH= yes
USE_PERL5= configure
diff --git a/dns/p5-Net-DNS-Resolver-Programmable/Makefile b/dns/p5-Net-DNS-Resolver-Programmable/Makefile
index eec132b8647a..7235bddfd385 100644
--- a/dns/p5-Net-DNS-Resolver-Programmable/Makefile
+++ b/dns/p5-Net-DNS-Resolver-Programmable/Makefile
@@ -14,8 +14,8 @@ LICENSE= ART10 GPLv2+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Net-DNS>=0.69:dns/p5-Net-DNS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0.69:dns/p5-Net-DNS
NO_ARCH= yes
USES= perl5
diff --git a/dns/p5-Net-DNS-TestNS/Makefile b/dns/p5-Net-DNS-TestNS/Makefile
index 80139f404680..98f11f78f33c 100644
--- a/dns/p5-Net-DNS-TestNS/Makefile
+++ b/dns/p5-Net-DNS-TestNS/Makefile
@@ -11,9 +11,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Perl extension for simulating simple Nameservers
-BUILD_DEPENDS= p5-Net-DNS>=0.64:dns/p5-Net-DNS \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0.64:dns/p5-Net-DNS \
p5-XML-LibXML>=1.53:textproc/p5-XML-LibXML
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USE_PERL5= configure
diff --git a/dns/p5-Net-DNS-ToolKit/Makefile b/dns/p5-Net-DNS-ToolKit/Makefile
index 530ef817a517..f82e6085d4f4 100644
--- a/dns/p5-Net-DNS-ToolKit/Makefile
+++ b/dns/p5-Net-DNS-ToolKit/Makefile
@@ -14,9 +14,9 @@ COMMENT= Tools for working with DNS packets
LICENSE= ART10 GPLv2 GPLv3
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Net-DNS-Codes>=0.09:dns/p5-Net-DNS-Codes \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS-Codes>=0.09:dns/p5-Net-DNS-Codes \
p5-NetAddr-IP>=1.30:net-mgmt/p5-NetAddr-IP
-RUN_DEPENDS:= ${BUILD_DEPENDS}
MAKE_JOBS_UNSAFE= yes
USES= perl5
diff --git a/dns/p5-Net-DNS-ZoneFile-Fast/Makefile b/dns/p5-Net-DNS-ZoneFile-Fast/Makefile
index b773ef3e7839..453681ca9606 100644
--- a/dns/p5-Net-DNS-ZoneFile-Fast/Makefile
+++ b/dns/p5-Net-DNS-ZoneFile-Fast/Makefile
@@ -12,9 +12,9 @@ COMMENT= Perl module to parse BIND8/9 zone files
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= p5-Net-DNS>=0.65:dns/p5-Net-DNS \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0.65:dns/p5-Net-DNS \
p5-Net-DNS-SEC>=0.15:dns/p5-Net-DNS-SEC
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/dns/p5-Net-DNSBL-MultiDaemon/Makefile b/dns/p5-Net-DNSBL-MultiDaemon/Makefile
index 715324f7c671..1091766d7f23 100644
--- a/dns/p5-Net-DNSBL-MultiDaemon/Makefile
+++ b/dns/p5-Net-DNSBL-MultiDaemon/Makefile
@@ -14,14 +14,14 @@ COMMENT= Net::DNSBL::MultiDaemon - multi DNSBL prioritization
LICENSE= ART10 GPLv1 GPLv2 GPLv3
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-File-SafeDO>=0.12:devel/p5-File-SafeDO \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-File-SafeDO>=0.12:devel/p5-File-SafeDO \
p5-Geo-IP-PurePerl>=1.10:net/p5-Geo-IP-PurePerl \
p5-Net-DNS-Codes>=0.09:dns/p5-Net-DNS-Codes \
p5-Net-DNS-ToolKit>=0.47:dns/p5-Net-DNS-ToolKit \
p5-Net-NBsocket>=0.23:net/p5-Net-NBsocket \
p5-NetAddr-IP>=4.067:net-mgmt/p5-NetAddr-IP \
p5-Unix-Syslog>=0.97:sysutils/p5-Unix-Syslog
-RUN_DEPENDS:= ${BUILD_DEPENDS}
OPTIONS_DEFINE= RHBL
OPTIONS_DEFAULT=RHBL
diff --git a/dns/p5-Net-DNSBL-Statistics/Makefile b/dns/p5-Net-DNSBL-Statistics/Makefile
index 1ab45a8a82bd..512e75455256 100644
--- a/dns/p5-Net-DNSBL-Statistics/Makefile
+++ b/dns/p5-Net-DNSBL-Statistics/Makefile
@@ -14,10 +14,10 @@ COMMENT= Gather DNSBL Statistics
LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Net-DNS-Codes>=0.09:dns/p5-Net-DNS-Codes \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS-Codes>=0.09:dns/p5-Net-DNS-Codes \
p5-Net-DNS-ToolKit>=0.41:dns/p5-Net-DNS-ToolKit \
p5-Net-DNSBL-MultiDaemon>=0.26:dns/p5-Net-DNSBL-MultiDaemon
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USE_PERL5= configure
diff --git a/dns/p5-Net-Domain-ExpireDate/Makefile b/dns/p5-Net-Domain-ExpireDate/Makefile
index ccd1bb23aba5..0bd613cd2452 100644
--- a/dns/p5-Net-Domain-ExpireDate/Makefile
+++ b/dns/p5-Net-Domain-ExpireDate/Makefile
@@ -10,8 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module obtain expiration date of domain names
-BUILD_DEPENDS= p5-Net-Whois-Raw>=0:net/p5-Net-Whois-Raw
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-Whois-Raw>=0:net/p5-Net-Whois-Raw
NO_ARCH= yes
USES= perl5
diff --git a/dns/p5-Net-Nslookup/Makefile b/dns/p5-Net-Nslookup/Makefile
index ac2a394e0cec..91a0868a1eba 100644
--- a/dns/p5-Net-Nslookup/Makefile
+++ b/dns/p5-Net-Nslookup/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Provides the capabilities of the standard tool nslookup(1)
-BUILD_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
USES= perl5
USE_PERL5= configure
diff --git a/dns/p5-Net-RBLClient/Makefile b/dns/p5-Net-RBLClient/Makefile
index f669e6907966..f973afffdcae 100644
--- a/dns/p5-Net-RBLClient/Makefile
+++ b/dns/p5-Net-RBLClient/Makefile
@@ -14,8 +14,8 @@ COMMENT= Queries multiple Realtime Blackhole Lists in parallel
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS
NO_ARCH= yes
USE_PERL5= configure
diff --git a/dns/p5-POE-Component-Client-DNS-Recursive/Makefile b/dns/p5-POE-Component-Client-DNS-Recursive/Makefile
index 8662d5afacee..16730b1b689f 100644
--- a/dns/p5-POE-Component-Client-DNS-Recursive/Makefile
+++ b/dns/p5-POE-Component-Client-DNS-Recursive/Makefile
@@ -14,10 +14,10 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS \
p5-Net-IP-Minimal>=0:net/p5-Net-IP-Minimal \
p5-POE>=1.004:devel/p5-POE
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/dns/p5-POE-Component-Client-DNS/Makefile b/dns/p5-POE-Component-Client-DNS/Makefile
index 68c26e1f7c0a..cc8f49fa77a9 100644
--- a/dns/p5-POE-Component-Client-DNS/Makefile
+++ b/dns/p5-POE-Component-Client-DNS/Makefile
@@ -15,9 +15,9 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Net-DNS>=0.65:dns/p5-Net-DNS \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0.65:dns/p5-Net-DNS \
p5-POE>=1.249:devel/p5-POE
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-NoWarnings>=1.02:devel/p5-Test-NoWarnings
NO_ARCH= yes
diff --git a/dns/p5-POE-Component-Client-DNSBL/Makefile b/dns/p5-POE-Component-Client-DNSBL/Makefile
index 12b0914ecbbe..7a81ffa817e0 100644
--- a/dns/p5-POE-Component-Client-DNSBL/Makefile
+++ b/dns/p5-POE-Component-Client-DNSBL/Makefile
@@ -11,10 +11,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl POE component that provides non-blocking DNSBL lookups
-BUILD_DEPENDS= p5-POE>=1.004:devel/p5-POE \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=1.004:devel/p5-POE \
p5-Net-IP-Minimal>=0:net/p5-Net-IP-Minimal \
p5-POE-Component-Client-DNS>=0:dns/p5-POE-Component-Client-DNS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/dns/p5-POE-Component-Resolver/Makefile b/dns/p5-POE-Component-Resolver/Makefile
index 8270e0311492..f408f1f594a3 100644
--- a/dns/p5-POE-Component-Resolver/Makefile
+++ b/dns/p5-POE-Component-Resolver/Makefile
@@ -16,8 +16,8 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-POE>=1.311:devel/p5-POE
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-POE>=1.311:devel/p5-POE
NO_ARCH= yes
USES= perl5
diff --git a/dns/p5-POE-Component-Server-DNS/Makefile b/dns/p5-POE-Component-Server-DNS/Makefile
index dfc5182d1254..baae718d444e 100644
--- a/dns/p5-POE-Component-Server-DNS/Makefile
+++ b/dns/p5-POE-Component-Server-DNS/Makefile
@@ -14,13 +14,13 @@ LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= p5-Net-DNS>=0.58:dns/p5-Net-DNS \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0.58:dns/p5-Net-DNS \
p5-POE>=0.38:devel/p5-POE \
p5-POE-Component-Client-DNS>=1.051:dns/p5-POE-Component-Client-DNS \
p5-POE-Component-Client-DNS-Recursive>=1.04:dns/p5-POE-Component-Client-DNS-Recursive \
p5-POE-Component-Generic>=0.0910:net/p5-POE-Component-Generic \
p5-POE-Filter-DNS-TCP>=0.04:dns/p5-POE-Filter-DNS-TCP
-RUN_DEPENDS:= ${BUILD_DEPENDS}
NO_ARCH= yes
USES= perl5
diff --git a/dns/p5-Tie-DNS/Makefile b/dns/p5-Tie-DNS/Makefile
index f78ac5c6b9c1..72b2f5d568ef 100644
--- a/dns/p5-Tie-DNS/Makefile
+++ b/dns/p5-Tie-DNS/Makefile
@@ -14,9 +14,9 @@ COMMENT= Tie interface to Net::DNS
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-DNS>=0:dns/p5-Net-DNS \
p5-Tie-Cache>=0:devel/p5-Tie-Cache
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-CheckManifest>=0:devel/p5-Test-CheckManifest \
p5-Test-Perl-Critic>=0:textproc/p5-Test-Perl-Critic
diff --git a/dns/p5-pgeodns/Makefile b/dns/p5-pgeodns/Makefile
index 4a51db74b732..7d9955b328cc 100644
--- a/dns/p5-pgeodns/Makefile
+++ b/dns/p5-pgeodns/Makefile
@@ -10,10 +10,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Geographic NameServer
-BUILD_DEPENDS= p5-Geo-IP>=0:net/p5-Geo-IP \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Geo-IP>=0:net/p5-Geo-IP \
p5-JSON>=0:converters/p5-JSON \
p5-Net-DNS>=0:dns/p5-Net-DNS
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Warn>=0:devel/p5-Test-Warn
USES= perl5