aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-10-28 10:45:44 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-10-28 10:45:44 +0000
commitcf820675350cb53155a88c40a06b79866a4776c4 (patch)
tree37749b1b0590c43e943a517be471e93164b7865a /dns
parent507d4164f01375109ba25f229f4477deef9f9712 (diff)
downloadports-cf820675350cb53155a88c40a06b79866a4776c4.tar.gz
ports-cf820675350cb53155a88c40a06b79866a4776c4.zip
Fix build with powerpc64.
PR: 232447 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=483267
Diffstat (limited to 'dns')
-rw-r--r--dns/mdnsd/Makefile2
-rw-r--r--dns/mdnsd/files/patch-libmdnsd_CMakeLists.txt11
2 files changed, 11 insertions, 2 deletions
diff --git a/dns/mdnsd/Makefile b/dns/mdnsd/Makefile
index 1d2f49eb6105..a3b9826cab5d 100644
--- a/dns/mdnsd/Makefile
+++ b/dns/mdnsd/Makefile
@@ -15,8 +15,6 @@ COMMENT= Advertise a service via Rendezvous
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wpedantic"
-
USES= cmake:outsource
USE_GITHUB= yes
GH_ACCOUNT= Pro
diff --git a/dns/mdnsd/files/patch-libmdnsd_CMakeLists.txt b/dns/mdnsd/files/patch-libmdnsd_CMakeLists.txt
new file mode 100644
index 000000000000..d430fea9335e
--- /dev/null
+++ b/dns/mdnsd/files/patch-libmdnsd_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- libmdnsd/CMakeLists.txt.orig 2018-10-19 15:18:01 UTC
++++ libmdnsd/CMakeLists.txt
+@@ -10,7 +10,7 @@ mark_as_advanced(MDNSD_COMPILE_AS_CXX)
+
+ if(NOT MDNSD_COMPILE_AS_CXX AND (CMAKE_COMPILER_IS_GNUCC OR "x${CMAKE_C_COMPILER_ID}" STREQUAL "xClang"))
+ add_definitions(-std=c99 -pipe
+- -Wall -Wextra -Werror -Wpedantic
++ -Wall -Wextra
+ -Wno-unused-parameter # some methods may require unused arguments to cast to a method pointer
+ -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls
+ -Wformat -Wformat-security -Wformat-nonliteral