aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-10-19 05:47:41 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-10-19 05:47:41 +0000
commitf1579be110d78f1be723fc9ba38ff236f431bed2 (patch)
treee63074925d086c396b54454bc69b44f4df2cf5a0 /dns
parent9e7e90b1515603e870cdcc8ed257b376a58ef0c5 (diff)
downloadports-f1579be110d78f1be723fc9ba38ff236f431bed2.tar.gz
ports-f1579be110d78f1be723fc9ba38ff236f431bed2.zip
dns/knot2: fix include of <bsd.port.options.mk>
PR: 232284 Submitted by: tobik
Notes
Notes: svn path=/head/; revision=482411
Diffstat (limited to 'dns')
-rw-r--r--dns/knot2/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/dns/knot2/Makefile b/dns/knot2/Makefile
index 57587374fbc8..8aa3fecb4ce5 100644
--- a/dns/knot2/Makefile
+++ b/dns/knot2/Makefile
@@ -3,6 +3,7 @@
PORTNAME= knot
DISTVERSION= 2.7.3
+PORTREVISION= 1
CATEGORIES= dns ipv6
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
https://dns.company/downloads/knot-dns/
@@ -13,12 +14,6 @@ COMMENT= High performance authoritative-only DNS server
LICENSE= GPLv3
-.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1120000
-NOT_FOR_ARCHS= i386
-NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386 on FreeBSD >= 11.2
-.endif
-
LIB_DEPENDS= libgnutls.so:security/gnutls \
libidn2.so:dns/libidn2 \
liblmdb.so:databases/lmdb \
@@ -65,6 +60,13 @@ FASTPARSER_CONFIGURE_ENABLE= fastparser
IDN_CONFIGURE_WITH= libidn
IDN_LIB_DEPENDS= libidn.so:dns/libidn
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1120000
+NOT_FOR_ARCHS= i386
+NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386 on FreeBSD >= 11.2
+.endif
+
post-patch:
@${REINPLACE_CMD} 's|$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|#$$(INSTALL) -d $$(DESTDIR)/\@run_dir\@|' \
${WRKSRC}/src/Makefile.in